3 Replies Latest reply: Dec 21, 2011 1:34 PM by PAHU
cweirup Level 1 Level 1 (0 points)

I'm at the end of my rope with connecting to my Canon MX870 AIO. I was having the issues with my MacBook (late 2008 aluminum running Lion) occassionally showing the printer in Paused mode or having a Communication Error. This required a restart of the printer. I was finally sick of it, so I looked on the Apple Support site for suggestions. After trying a few options, I've now messed it up enough so that I can't connect to the printer at all. All I can see now is the Bonjour Scanner. The printer is on my wireless network, as is my MacBook. Here's what's happened so far.


  • The first thing I tried was to enable the printer to broadcast over Bonjour (I believe suggested by PAHU). I went to the printer's internal webpage and set it to broadcast over Bonjour (LPR protocol and service notification; it was set to DISABLE when I first went in). This allowed me to see the printer in the drop-down list when I clicked on the Plus button in Print & Scan preference panel. Once I did that, it started the software install dialog, showing "Finding Software" in the status. After it got to about 1/4 of the way on the progress bar, it showed an error that the software could not be found and my only option was to exit without installing the printer. I'm assuming it is trying to download the latest drivers. I've retried this multiple times without success.


  • Assuming that I changed the Bonjour setting incorrectly, I turned off the printer Bonjour broadcast.
  • Then I tried to re-add the printer. This time, I went to the list of printers after clicking the Plus button (the printer didn't show up in the drop-down). Under Default, the printer shows up with "Bonjour Scanner" under Kind immediately. However, the printer component never shows up. I've left it there for at least 2-3 minutes and "canonijprinter" under Kind is never shown. If I eventually add it as is, it is not displayed as a printer, only a scanner.
  • I ran both Software Update and manually downloaded and installed the latest Canon drivers from Apple. After retrying the first 3 bullets, the issue was not resolved.
  • I then reinstalled the latest drivers from Canon's site. Again, retried first 3 bullets; again that did not fix the issue.
  • I also tried reboots of both the MacBook and printer. No fix after retrying first 3 bullets.
  • I've confirmed that the printer is on the wireless network, as I can connect to the internal webpage and Bonjour to the scanner portion seems to work.
  • My work Windows laptop has no issues connecting and printing to it.


What's strange is after putting the Bonjour setting back to its previous state, the printer will not come up at all. I don't believe I've changed any other settings.


Any help would be greatly appreciated. Thanks!


MacBook, Mac OS X (10.7.2)
  • PAHU Level 6 Level 6 (15,750 points)

    Hello Chris,


    With the printer not appearing at all, if you can still connect to the MX870 web page, then I would open the Other Settings page and click on Defaults. If you then click the OK button, all the settings on this page should go back to the factory default and hopefully this is enough to get the printer appearing again in the Add Printer browser.


    With regards to your first bullet point and the enabling of the LPR service notification, with the printer appearing in the Default Add Printer view, selecting this entry should have created the queue (for both the printer and scanner) assuming that Lion could see the driver locally. When it has to connect to Apple Software Update then it believes the driver is not already installed. Given that you have installed the driver and the Canon driver update, this action by Lion would suggest that your driver files are corrupted. So I suggest you trash the BJPrinters folder located in /Library/Printers/Canon and then empty the trash. With this completed, run the v2.7 Canon Update again and then open Print & Scan. If you then connect the Mac to the MX870 via USB cable, the MX870 should be automatically added to the list. If this happens then you know the driver is okay. At this stage I would print a page to be sure all is okay and if this works, you can disconnect the USB cable and add the wifi connected printer.


    Now, with the wifi connection and the LPR service notification on, what you should find is that when you click the plus button in Print & Scan, the little window that appears showing Nearby Printers and Nearby Scanners, will have the MX870 under Nearby Printers. With the LPR service notification off, the printer component is not shown but the scanner component is seen under Nearby Scanners. Do you see this?


    If you do press "Add Other Printer or Scanner", as you have noticed the scanner component appears quickly. And I find that the printer component takes just a few seconds to appear showing 'canonijnetwork', but with the LPR service notification on the MX870 will also appear as Bonjour Multifunction (or only as Bonjour Multifunction if the canonijnetwork never appears). Selecting this multifunction entry should make the Print Using menu change to "Canon MX870 series". And if it does you can click Add to complete the queue creation.


    Hope this helps you and if not, then please reply.

  • cweirup Level 1 Level 1 (0 points)

    PAHU, thank you for the very detailed response, and my apologies for my very late response.


    I tried the Default button in Other Settings, but that did not solve the problem.


    On a whim, I went into the local CUPS web interface (http://localhost:631) just to poke around. While I was able to see the main page, when I clicked on any other link (Admin, Maintenance, etc.), I received an error (I don't remember exactly, but it was something similar to a Access Forbidden). Thinking maybe the CUPS system had crashed or was in a strange state, I reset it by holding down the Option key and clicking on the "-" button (Remove Printer). Once I let it restart, I went back into the CUPS web interface, and all of the pages worked properly. I was then able to add the


    I also confirmed that the printer could be added in the Print & Scan preference pane, and it showed up first as Bonjour Scanner, then quickly as canonijprinter, just as expected.


    For right now, I'm going to leave it as-is, but I am curious about the corrupted drivers. Since I was able to readd the printer after a CUPS restart, I'm wondering if the drivers are okay or may still have a problem. I am going to keep your detailed instructions for future reference.


    I'm going to mark this closed. Thanks again for your help!

  • PAHU Level 6 Level 6 (15,750 points)

    Good to read that you got it working. The need to reset the printing system would suggest that files within the core printing system had become corrupt, so good on you for finding that and resolving. As for the printer drivers, they won't be corrupted - they don't influence your ability to navigate around the CUPS web page - so there is no need to remove/re-add them.