5 Replies Latest reply: Sep 9, 2012 2:56 AM by rjrcooper1
julianfromberkshire Level 1 Level 1 (0 points)

I recently changed my router from an old Netgear 834 to a TP-Link W8961ND and now I keep losing the Airplay Speaker logo from my iphone4, ipad2, and itunes on my Windows 7 PC. When I unplug the AE and restart it connects but afer abour 30-40mins it disconnects and the only way to get it back is to unplug again. Is there some incompatibility with AE and the TP-Link router.

Airplay Express, Windows 7, All devices latest software
  • eilc Level 1 Level 1 (0 points)

    Well, that's exactly what's happening to me as well!.

    I have an IMAC, IPAD2, Airport Express and the same tp link router.

    Seems like there is some sort of incompatibility. It only works if you disable all security in the router's wifi.

    Even with MAC access list it keeps loosing connection (but at IP level it is still connected, as you can Ping it). Weird.

  • Truhop Level 1 Level 1 (0 points)

    Same again, here...


    TP-Link TD-W8961ND

    Windows 7 PC


    iPad 2

    iPhone 4s

    2 Airport Expresses (1 old, 1 new)


    I got the router and second AE (for another room) about a month ago to replace an aging 'g' Netgear (which, although dying occasionally connected to everything and the AE worked fine). Had the same problem from the start (only now properly investigating):


    - Plug in either AE - light goes green

    - Shows up in Airport Utility, speakers on all devices

    - Fine for 30-40 mins

    - Disappears from all devices and Airport Utility but light stays green

    - Only way to resolve is to unplug and plug back in.


    Strange. Pretty sure it's not the AE as I have one brand new and one old (which until we got the new router worked fine), and it's unlikely they'd both start exhibiting the same behaviour. So that leaves figuring out potential settings on the TP-Link.


    And I don't think it's channel interference as (a) using iStumbler I see all the devices in the area are on either channel 1 or 11 - I've set the router to channel 6, and (b) other people are experiencing the same problem, and it's unlikely we'd all have the same conditions around us.


    I'm not too sure about the various wireless settings - they're all a bit beyond me, but will continue with trial and error until something works... will let you know if I find anything.

  • julianfromberkshire Level 1 Level 1 (0 points)

    I finally gave up and returned the TP-Link to the store and exchanged for a Netgear - this is working perfectly with my AE. There is obviously a compatibility issue with Airport and the TP-link - I could not get any reply from TP-link so I don't know if they are aware or if they plan an update.

  • akpearson73 Level 1 Level 1 (0 points)

    I had a similar problem, my several years old Airport Express 802.11g couldn't join my TP-Link TD-W8960N wireless network (I wanted to use iTunes AirPlay with my stereo). I didn't want to turn off security completely but I went to the TP-Link router configuration in Safari ( and under Wireless...Security discovered that changing Network Authentication from WPA2-PSK to Mixed WPA2/WPA-PSK Adaptive seemed to fix it.

  • rjrcooper1 Level 1 Level 1 (0 points)

    @akpearson73: Thank you, thank you, thank you! I was having a similar problem with the same router only I couldn't share my iPod touch stuff with my Apple TV - I don't have an Airport Express. I couldn't find the setting you mentioned in my router settings but I thought I'd mess around with the wireless settings and the first one I tried fixed the problem: In Interface Setup -> Wireless -> WPA-PSK/WPA2-PSK section, I changed Encryption from TKIP/AES to AES and now I can stream music from the Music app on my iPod touch to my Apple TV and use the Remote app on my iPod touch to control my Apple TV, neither of which I could do before making that change.


    Thanks for the tip!