10 Replies Latest reply: Dec 30, 2013 7:53 PM by BadWolfPhoto
Bastionboku Level 1 Level 1 (0 points)

I have had my Apple TV about 90 days now and have had no problem in playing movies rented from Apple.  Now when I try to watch one, it starts an plays for about 10 or 15 seconds, then freezes.  I try to play it again, and I get an HDCP error message saying that I am either not using an HDMI cable or it is not properly connected to an HDTV.  Neither is true.  And nothing has changed with my setup.  I tried restoring and resetting to the original factory settings, and one time it did fix this, but now it does not.  What should I do?

  • 1. Re: HDCP Error Message
    Mike1121 Level 1 Level 1 (10 points)

    There are a number of posts on this subject and unfortunately there does not appear to be a consensus.  I've got the same problem and in my opinion it is an Apple TV firmware problem.  The latest update doesn't fix it either.  Anything HD will give you a problem but standard definition movies or TV shows seem to stream fine.  I've looked at several HDMI cables for sale and not one of them mentions HDCP compatibility at all, so I don't think that is the issue.  The most plausible solution I have heard is resetting the original settings on the Apple TV, but don't restore.

  • 2. Re: HDCP Error Message
    sardomus1 Level 1 Level 1 (5 points)

    I have the same issue. I am using my iPad 2 mirrored to the ATV2, then using the HP HDMI to VGA adapter to a VGA projector.

     

    Mirroring works fine, but playing video (even ones I created) give me the HDCP error message.  Playing a video embedded in a webpage (CNN.com, YouTube, etc) works fine, until I go fullscreen, where it stops playing and I get the HDCP error message again.  It's frustrating.

  • 3. Re: HDCP Error Message
    adamgrn Level 1 Level 1 (0 points)

    I suggest everyone report their expeience using this ATV feedback form:

    http://www.apple.com/feedback/appletv.html

  • 4. Re: HDCP Error Message
    Bastionboku Level 1 Level 1 (0 points)

    I may have a workaround that seems to work for me.  I use an HDMI hub that has 5 ports coming in and then feeding my TV set.  I also use a Logitech Univerisal Remote.  I discovered by accident that turning everything off from the Remote, then turning of the desired device seems to sovle the problem.  At least it has for awhile.  For example, if I am watching regular TV and want to switch to Apple TV, turn everything off from the remote, then select Apple TV from the remote and power up only those devices associated with Apple TV rather than just switching the remote to Apple TV while everything else is on.  I don't know if this is permanent, but it seems to work for me.  I think the HDMI hub is what may be causing the problem.

  • 5. Re: HDCP Error Message
    jrpski Level 1 Level 1 (0 points)

    Hi guys, I had the same error messages when trying to connect my macbook pro to my brand new sony bravia LED display. I was using a mini-dvi to VGA adapter, and then into the PC input of the TV. Everything I ever tried to play through to the tv worked fine, until I tried an HD movie from the iTunes store. Same problems as you all seemed to have. I went down to the local Apple reseller (not an Apple store) and the guy in there suspected my cable was the issue.

     

    He said that as VGA can potentially be used as an input source to create a full def copy, they have tried to eliminate that avenue of piracy and made all VGA cables display the error. I walked out of the store with a $49 mini-dvi to HDMI cable (Kanex) and came home to try it out - works perfect. All HD purchases come through in glorious 1080p. A much better solution than being forced into a corner and buying an Apple TV (which incidently only outputs 720p.

     

    This worked for me, hope you guys have the same success!

  • 6. Re: HDCP Error Message
    Flintstone6 Level 1 Level 1 (0 points)

    This is what I did to solve the problem.  Wake the Apple TV with the remote, and then turn on the TV(and TV only).  If other electronics are turned on before the Apple TV, it doesn't work.  It seems like it's a sequence thing.........  It worked for me and I hope it works for you too!

  • 7. Re: HDCP Error Message
    Jays1fan Level 1 Level 1 (0 points)

    I was watching a mlb.tv game , got 5 innings then I got this HDCP message.

    Tried to do what you suggested and still did not fix

  • 8. Re: HDCP Error Message
    appo71 Level 1 Level 1 (0 points)

    Well i was able to fix the same problem by simply adjust the Video Resolution and it works perfectly now with my Sony Bravia TV (model No KDL-46NX720), steps to follow:

    1-click Menu on the remote

    2- choose settings

    3- iTunes Store

    4-Video Resolution (choose Standard Definition)

    5- click Menu again twice and try to mirror your Ipad

     

    hope it works with you, especially if your internet speed are not fast. no need to change the Cable or TV and the resolution on the screen is just perfect.

     

    all the best...

  • 9. Re: HDCP Error Message
    Jackieferrara Level 1 Level 1 (0 points)

    This is all beyond me. Once upon a time, I bought things in Itunes and those things played on my Macbook Air. I am hating all of my Apple products lately. I have paid an idiotic amount trying to watch Argo and afteer about fifty bucks, no Argo for me! Now no Flight, either. Thanks HDCP!

  • 10. Re: HDCP Error Message
    BadWolfPhoto Level 1 Level 1 (0 points)

    I have an LED TV that is less than 6 months old (and my ATV is using the HDMI cable that freakin' came with it!) and I have been watching movies on it just fine until a recent up date and then have had the same HDCP problem that everyone else is posting about. Here is the only way I found to resolve it (besides the not helpful suggestion of "buy a new TV" ):

     

    On Apple tv go to:

    Settings

    General

    Reset

    Reset all Settings (make sure you don't click Restore as it automatically updates the latest firmware).


    You will have to go in and re-enter all your user info after doing this, but it fixed my HDCP error message problem and all my purchased movies are now playing like they should. Apple fail on this one as a lot of people seem to be having this problem and Apple should have at the very least warned everyone that this might occur.