5 Replies Latest reply: Jun 27, 2014 2:05 AM by Cubica
Commodore Kain Level 1 Level 1 (0 points)

Great news! My Mac mini is sending true 5.1 to my reciever through the HDMI cable! Okay so here's my list of gear.

 

MAC MINI 2011 2.5 i5 8gb ram

Using a quality audioquest hdmi I have connected my Mac mini to my Denon 1712 Reciever. I have connected this hdmi cable into hdmi port entitled game 2. I have connect my reciever to my tv with a monster 1000 hdx thx certified hdmi cable. It has a transmission sped of 17 gb or so...meaning it can handle transmitting 3d...if only I had a 3d tv.

 

Okay so that's the gear. Now onto the changes in audio midi. Open audio midi and Simply change it to 48000 hz and to 2 channel 16 bit integer. That's all I did and now it works. Before I had it set to 8 channel 24 bit and when I pulled up my surround sound options I could pretty much only get multi channel stereo. Now I can get several Dolby choices.

 

The voices are coming out of the center speaker and all the action is coming out of the other speakers....so in other words 5.1 surround sound has been achieved on my Mac mini 2011 which has Lion on it.

 

I have tested this with iTunes and Netflix. Both are in 5.1 and sound great. In iTunes I have tested both music and digital copies of movies. Both worked flawlessly.

 

Rejoice Mac mini owners 5.1 surround is now possible over your Mac mini 2011 edition with just an hdmi cable to your reciever. You can throw away that toslink cable becuase now you don't need it!

 

I hope this works for you. Remember not all hdmi cables and the same holds true for your reciever. If it does not work consider getting either audioquest or monster....everything else is junk.


Mac mini, Mac OS X (10.7.2)
  • bonimac Level 1 Level 1 (20 points)

    Thanks mate, works now on my 2011 Mac mini server just like you explained!

  • woodmeister50 Level 5 Level 5 (4,275 points)

    FWI, on my 2010 Mini, have it set to 48 kHz, 24 bit, 2 channel

    and my Yamaha receiver displays Dolby D and DTS and their

    extended types, not the lossless types though (ex. DTS-MA).

    And the receiver happily decodes it.

  • Lucubrato Level 1 Level 1 (0 points)

    I want to add my thanks for your post: it solved my problems too.

     

    The only thing I find now is that I need to leave the MIDI app open. When I want to play video in iTunes or DVD Player app, I need to ensure I have 48 kHz selected. I often find the channels will automatically go to encoded digital audio. I need to also select the surround sound option from the speech-bubble on the bottom menu bar in the iTunes playback window. Failing to do both has produce a few crashes in iTunes.

     

    If I want to play music, I need to select 44 kHz.

     

    (I wish Apple would fix this once and for all. I can work this okay, but it is still not ready for mainstream home use in my view. Neither my wife or kids can work this. Until then, the PS3 with its ability to just put a disc in and press 'play' will continue to win out.)

     

    But at least I can use iTunes for playback. It's now beginning to be a worthwhile media management tool. Cheers!

  • Lucubrato Level 1 Level 1 (0 points)

    I want to share an update in case it helps anyone else.

     

    I had downloaded and installed the Perian plug-in. (It installs in the preferences pane in the Mac's system settings.)

     

    In previous versions of OS X, Perian was a sometimes essential to getting 5.1 surround from a Mac. I know I used it with great success in OS X 10.5 and 10.6.

     

    However, I was having real troubles — some of them as I discussed above — with my sound preferences in 10.8.2.

     

    After much mucking around, I stumbled upon the solution.

     

    I removed Perian.

     

    I know have no trouble at all. I use either Handbrake, and more recently iVi Pro, to convert movies for iTunes. With Perian removed, the only change I need to make in some movies is to select the surround sound track. Mac OS X will automatically change the settings if necessary in the MIDI player, and my Marantz NR 1603 does the rest.

     

    If I play music, OS X changes the settings back to stereo, with no intervention.

     

    The only setup that might be necessary for anyone else is to ensure that your MIDI player is set for your HDMI or optical audio (TOSLINK) device to use 48kHz.

  • Cubica Level 1 Level 1 (0 points)

    Hi,

    I have gotten the 5.1 surround sound through HDMI connected to my Pioneer AVR. However, there is audible noise, continuous hissing sound, through my speakers. Did you face the same problem?

     

    I have read here that the reason is because because of the difference between audio signals from a computer and other consumer electronic products. One of the suggestion is to connect the HDMI from Mac Mini direct to the TV/projector and toslink cable between mac mini and AVR.

     

    I have not tried the suggested solutions. But I would like to know if anyone else is getting the noise out of their speakers when connecting the mac mini to the AVR?