Previous 1 2 3 Next 35 Replies Latest reply: Oct 11, 2014 9:09 PM by Ericw1
twesterm Level 1 Level 1 (0 points)

I got an AppleTV last month and it has been working great until yesterday.  Starting yesterday, the AirPlay icon stopped showing up and I can't figure out how to get it back.  I've restarted my iPhone 4, iPad 2, updated iTunes on my Windows Laptop, restarted my router, restarted my AppleTV, and restored my AppleTV back to factory settings.

 

I got it to work once last night after changing the language setting on my iPhone to French and then back to English and for some reason that worked.  When I came back later I was missing the AirPlay icon again and changing the language didn't work that time.

 

Everything I have is up-to-date (iPad is 5.0.1 and AppleTV is 4.4.4).  I tried asking this in the AppleTV discussions but got no answers so I'm trying here now.

 

Everything else on the AppleTV appears to work fine.  I've been watching Netflix without a problem and Home Sharing works as well.  It's currently connected using the ethernet port and my iPad is on the same network.  I tried connecting the AppleTV to the WiFi but that did not work either.  I've double checked and AirPlay is turned on.

 

The *only* thing that changed within the last day is I got a wireless blue tooth keyboard for my iPad (which makes typing this post easy ^^) and I'm completely lost on what else to do to get my AirPlay working again.

  • pjl123 Level 5 Level 5 (6,160 points)

    So on the apple tv, go to settings, and check your network.  After several months of no problem, i lost mine earlier today, and had to re establish the network connection.  Is just stopped, dont know why, but redoing the network and password did the trick.  If the pad does not see the apple tv, the airplay icon will not be there.

  • finnb123 Level 1 Level 1 (5 points)

    Try resetting both the iPad and Apple TV.

    iPad: Hold down the home button and lock button until screen turns black.

    Apple TV: Hold down the menu and down button until the LED light flashes on the apple TV box.

    And try resetting your wireless box: there should be a switch/button on the box somewhere.

  • Marbono Level 1 Level 1 (0 points)

    I just posted this on another thread. The problem is similar, from the sounds of it. It is definitely a work around and not a solution. Apple needs to address this.

     

    "I have been having similar problems. I can shed some light and help with some work arounds but I don't think this should be happening. With respect to the intermittent music streaming. Mine would do the same. Using iPhone 4 and AppleTV2 I would stream music to the ATV2 and it would work for about five to ten minutes then cut out. I solved this by turning off Bluetooth. Once I did that streaming worked for as long as I wanted it to. As many of you have said when trying to start music streaming from the iphone to the ATV2 there is no Airplay symbol. If you go to settings on the ATV2 then down to Airplay - toggle it off and on again. Once you do that the symbol will appear on the phone and streaming can begin. But, I don't think this should be required each time. It does work and is a lot quicker than rebotting the phone but to much to have to do each time. If Airplay is on then it should be ready to stream anytime you want to play music across it. Apple needs to resolve this. Hope this helps you out."

  • andrewbrick Level 1 Level 1 (0 points)

    I have an iPhone 3GS, an iPad 2 and an ATV2. I haven't used the AirPlay function in a week or so, but I tried to today, and no apps on the phone or pad have the airplay icon. I've updated everything across the board, reset the network on the ATV2, rebooted everything, and even powered down my wireless router. Nothing is working.  Also, ATV2 is not finding my computer's iTunes library through home sharing.  I've turned it off and back on, but no luck. Did they frack something up with the latest ATV2 update?

  • iphoneusersd Level 1 Level 1 (0 points)

    I have apple tv and the airplay suddenly disappeared on all my devices (iphones, ipad and pc laptop with win7.)  My devices are all working on my wifi network.  I restarted everything a couple of times including the router and atv.  Nothing worked.  Saw another post about turning off the airplay service on the atv and then turning it back on.  That worked.  Be sure to turn it off and 'save' it as off...don't just toggle between on and off. Then turn back on.

  • andrewbrick Level 1 Level 1 (0 points)

    Tried it.  Turned it off, put it to sleep, woke it up, then turned airplay back on.  No workie.

  • pjl123 Level 5 Level 5 (6,160 points)

    If you are not seeing the icon, and if you cannot see your shared files, then the atv has dropped off of your network.  Nothing you can do with the pad.

     

    Have you changed anything on your router?  When you look at settings on the atv, does it show you connected to the right wifi network? 

     

    Try starting over on the atv network set up.  This sometimes wakes up the connection.  Re search to find your network, and rejoin.  

     

    I assume you have already tried powering the router down then up. 

  • andrewbrick Level 1 Level 1 (0 points)

    I've reset the router several times now, and I've reset the network on the ATV2 quite a few times.  I've even switched back and forth between wired and wireless (I had always used it wired before, and airplay worked just fine.)  And yes, it is connected to the right wireless network (it's protected, and it takes my password, connects, and everything's cool, except airplay).  I'm about to ready to restore the ATV2 to factory conditions.

  • twesterm Level 1 Level 1 (0 points)

    I've done everything suggested and still no luck.  Sometimes, very rarely, I'll see my air play icon back it rarely lasts long and I haven't been able to find repro steps to getting it back.

     

    Here are the things I've tried--

    • Restarting my ATV
    • Restarting my router
    • Using wireless
    • Using wired
    • toggled air play on my iPhone/iPad
    • Made sure that, yes, it is on the correct network
    • Verified home sharing is turned on for everything I have
    • Verified that air play is enabled
    • re-inputting all network setworks
    • power cycled iPad/iPhone
    • Made sure there were no funny firewall settings on my router
    • restored my ATV to factory conditions
    • Cleared history and data on my safari browser
    • Changed language to French and then back to English (this actually appeared to work at first but doesn't work anymore).
    • updated all my devices (iTunes, ATV, iPad, iPhone, router)
  • Marbono Level 1 Level 1 (0 points)

    I spoke with an AppleTV tech support person  shortly after I posted on here last week. Unfortunately, he wasn't much help. He stated that the problems WE are experiencing have nothing to do with the AppleTV. He suggested it had something to do with the settings on the other devices (iPhone, iPad) and suggested that I contact technical support for the phone. I told him that there have been issues with this problem dating back to 2010 according to this forum and asked why Apple hasn't done anything about it. He stated that the forums aren't monitored by Apple and that only when support calls are logged on repeat issues is it investigated. The problem is certainly hit and miss with me. Sometimes it works flawlessly and others not at all until I toggle the AppleTV Airplay on and off. The last time I got it working really well for a while I pulled the power plug on the ATV for a minute and plugged back in and then it worked great for several days. Not sure what to say. I haven't had a chance to contact iPhone support and go through the whole storey again.

  • pjl123 Level 5 Level 5 (6,160 points)

    Not to sound like i am groping for answers, but something is interfering with the conversation between the router and the atv. 

     

    It is either physical, or software.  Eleimnate the physical.  Move the atv into close proximity to the router.  Find a tv with an input and see what happens.  If it holds the signal there, then it is an obstruction or signal strength issue.

     

    Try a different channel on the router.  Your microwave of cordless phone may be jumping the channel. 

    It is either a problem with the atv, or the router.

     

    If you can, borrow another router from a friend, see what happens then.   Or cart the ayv to somebody elses house, join their network and see if it works there.

     

    Lastly, and i am reaching here, google up the support page for your router.  Sometimes you can find discuiions on common problems that ring a bell.  Qos on, or off, or any number of other router settings lurking around.

     

    So start eliminating stuff as best you can.    Look on this as a treasure hunt.

  • twesterm Level 1 Level 1 (0 points)

    I'm pretty sure it's an Apple TV problem since I've tried four different iPhones (one 3G, 3GS, 4, and 4S) and 2 iPad2's and none of them are actually able to see the Apple TV.

     

    I haven't tried moving the Apple TV itself, I'll try that tonight and see what happens.

  • andrewbrick Level 1 Level 1 (0 points)

    I can't be too certain, but I believe my airplay problem started after I updated the ATV2 last.  I hadn't done it for several months (too many updates get sent out imho), and to the best of my knowledge, airplay had worked fine until then.

  • pjl123 Level 5 Level 5 (6,160 points)

    Its not a problem with the pads or phones.  Either the atv, or the router.     Really, change the channel.

     

    I just came accross this somewhat similar post.  Read the very last entry and see if this makes a difference to you.

     

    https://discussions.apple.com/message/17529173#17529173

Previous 1 2 3 Next