1 Reply Latest reply: Dec 22, 2011 11:20 AM by djhpk
djhpk Level 1 (0 points)

For many years I have been keeping a record of all my appointments and significant events in digital form.


Earlier this year, I transferred such records going back to 2001 from my Palm Tungsten T5 to my iPad using Google Calendar as the intermediate device. However, I now find that events earlier than mid November 2011 that are in the Google calendar have disappeared from my iPad, but new events that I enter on the iPad are appearing in the Google calendar and vice versa, so the sync is still working both ways, except for these older events.


I have tried deleting and resetting the Exchange account used to sync with the google calendar and also made sure that "Mail Days to Sync" is set to "No Limit", but this has not made any difference.


One issue that may have bearing on this is that around the date that the most recent events on the google calendar have disappeared from the iPad, I had a problem with one of my apps which resulted in a totally "bricked" iPad and so I had to resort to recovery mode to get it going again. In getting th iPad going again, iTunes installed iOS 5.0.1 but it was unable to use a previous backup and so I had to "start as a new iPad".


But, the bottom line is that there are 10 years worth of events in my google calendar which had once been synced to my iPad calendar but which are no longer of the iPad. How do I get thes events back on to the iPad?

iPad, iOS 5.0.1
  • djhpk Level 1 (0 points)

    If I may reply to my own question, I have found the solution.


    In Settings "Mail, Conacts, Calendars", if you scroll down the the bottom, there are some Calendar settings, one of which is "Sync".


    This sync setting allows one to restrict the syncing of previous events from 2 weeks ago through 6 months ago to All Events.


    Changing this setting to "All Events" made no immediate difference to my iPad calendar but after I deleted my Exchange account and then recreating it, all my events back to 2001 reappeared in my iPad calendar.


    I guess that this sync setting has a default in iOS 5 to that in iOS 4./