12 Replies Latest reply: Jan 14, 2012 5:59 PM by crunch483
paulas Level 1 Level 1 (0 points)

I've read many other discussions, but I haven't found a solution to my problem.  I just bought a 4th generation Wi-Fi only Kindle, but I can't connect it to my Airport wireless network.  I own a 1TB Dual-Band Time Capsule with firmware version 7.6.  It is configured to connect to my DSL model/router using Ethernet, and Connection Sharing is Off (Bridge mode).  I've tried many different wireless settings without any luck.  Currently, the radio mode is set to "Automatic" (802.11a/n - 802.11b/g/n), Radio Channel Selection is "automatic" (149[5 GHz]/10[2.4GHz]), and Wireless Security is turned off.  Originally I was using WPA2 Personal, but I wanted to eliminate security from the possible problems, so I turned it off, but I still can't connect.  In my log I see the following lines several times:

Dec 21 18:33:21          Severity:5          Disassociated with station f0:a2:25:23:43:dd

Dec 21 18:33:22          Severity:5          Associated with station f0:a2:25:23:43:dd

 

I can successfully connect to my network with a MBP, an iPhone, an iPad, and a Canon wireless printer.  I did have a similar problem with a wireless HP printer, but I thought the problem was with the printer, so I returned it.

 

I am able to connect the Kindle to a friend's Linksys wireless network.

 

Any suggestions?


Time Capsule, Mac OS X (10.7.2)
  • Bob Timmons Level 10 Level 10 (87,615 points)

    Might your wireless network have an apostrophe in the name?

     

    A number of devices will not "read" an apostrophe correctly, so if your wireless network does have an apostrophe or other punctuation mark in the name. try changing it to a single phrase consisting of only letters and numbers with no spaces

  • paulas Level 1 Level 1 (0 points)

    No.  My network name is "Wendy". No special characters.  For what it's worth, the Kindle is able to find the network; it just can't connect.

  • Bob Timmons Level 10 Level 10 (87,615 points)

    Try a different Radio Mode setting on the Time Capsule

     

    Open AirPort Utility - click Manual Setup

    Click the Wireless tab below the row of icons

     

    Hold down the option key on your Mac while you click on the Radio Mode selection box to display an expanded list of selections.

     

    Try the following:

     

    802.11n only (5 GHz)  -- 802.11 n/g/b

     

    or

     

    802.11n only (5 GHz) -- 802.11 b/g

  • paulas Level 1 Level 1 (0 points)

    I tried both, and even restarted both the TC and the Kindle, but it won't connect.  The log just keeps saying "Associated & Disassociated".

  • Bob Timmons Level 10 Level 10 (87,615 points)

    Sorry, I am out of ideas.

     

    A visiting relative's Kindle works just fine on the wireless network here, using the 802.11n only (5 GHz) -- 802.11 n/g/b setting with WPA2 Security enabled on the Time Capsule.

     

    Not sure what to suggest, but maybe another user can help.

  • Bob Timmons Level 10 Level 10 (87,615 points)

    Correction....the security setting is at WPA/WPA2 Personal on the wireless network.

  • paulas Level 1 Level 1 (0 points)

    Thanks for trying.  I'm giving up for now, but maybe I'll take another whack at it later.

  • LaPastenague Level 8 Level 8 (41,745 points)

    Go back to previous firmware.. that is one idea worth a go.. apple do not bother to test new firmware extensively against other devices.. especially competing ones.

     

    And I would simply remove all security.. fix the wireless to a channel.. for 2.4ghz, use 1, 6 and 11 in turn. Once it connects put back the security.. again follow bob's advice for wireless name .. password also should be alphanumeric only with no spaces. As long as it is not a dictionary word it will be fine.

  • paulas Level 1 Level 1 (0 points)

    It's finally fixed, but I'm not sure what did the trick.  I reset my DSL modem, and reset the Time Capsule, and now everything is working.  The problem wasn't with just with my Kindle.  I also tried to connect a new laptop to the Time Capsule, but I couldn't connect anything new.  After I reset everything, I was able to connect my Kindle and my new lapop.

  • LaPastenague Level 8 Level 8 (41,745 points)

    After I reset everything, I was able to connect my Kindle and my new lapop.

    "Did you turn it off and on again?" is just so windows... sorry we forgot that you need to use that with APPLE now as well.

  • paulas Level 1 Level 1 (0 points)

    I guess until Apple makes DSL Modems too, I'll be stuck with some incompatibility.  I don't know if it was the Time Capsule, or the modem, but something was preventing me from assigning more than 7 IP addresses.

  • crunch483 Level 1 Level 1 (5 points)

    Bridge Mode is probably your problem - at first, I couldn't get my Kindle to connect to my Airport Extreme, which is configured in bridge mode because I have Verizon FIOS internet and have to use the FIOS router.

     

    However, I found a workaround:

    1. Unplug your Airport router, and enable the wireless on your DSL, cable, or FIOS router (it may be enabled already; I had turned mine off since I didn't see any point in having it broadcast a wireless network that wasn't being used).

     

    2. Now you should be able to connect from your Kindle - make sure it has the same name and password as the wireless network name you chose for your Airport router

     

    3. You can now turn your Airport router back on, and because your Kindle will remember the network, it should be able to connect successfully from now on, even if you go back and disable wireless on your DSL/cable/FIOS router.

     

    Please also tell Amazon about this problem! All my other wifi-enabled devices have no trouble connecting to my network - the Kindle clearly has a bug that makes it handle routers running in bridge mode incorrectly.