5 Replies Latest reply: Apr 1, 2015 1:05 AM by Pravir
JosephOfNazareth Level 1 Level 1 (0 points)

When I upgraded from 10.6 to 10.7,  Spotlight stopped working in 10.7.  Spotlight was working fine in 10.6.  However, I was managing that feature with Spotless 3.0.

 

I went into the Spotlight System Preference to add and then remove my system volume to trigger a re-index.  However, when I went to add the volume I received the error message "Privacy List Error - The item couldn't be added or removed because you don't have the appropriate permissions."

 

I used DiskUtility 12 to Repair Disc Permissions successfully, then repeated the above step with that same results.

 

My hunch is that Spotless "owns" the file(s) that the Spotlight System Prefernce needs to modify to add a file to the Privacy list, and that is why the system is reporting that error.

 

Spotless 3 is incompatible with 10.7.  And Spotless 4 is being reported on fixamac.com that it is "coming soon" for the several months Lion has been in existence.  (gchgchgchgch, spit)

 

Does anyone know what file(s) the Spotlight System Preference stores its privacy list in so I can research the owner of the file and/or change the owner back to it's appropriate owner.  What should the owner of that file(s) be?  I know "chown" is the command to change it if need be, but I'm not sure of the value to change it to.

 

Thanx.


Spotlight, Mac OS X (10.7.2)
  • JosephOfNazareth Level 1 Level 1 (0 points)

    I resolved my problem after attempting a few things on my own and then with a call to Apple's Tier 2 tech support for further insight.  Here's a summary of what transpired:

     

    I compared the owner of my /.Spotlight-V100 file on the volume where Spotlight was corrupted to a volume on another MacOS devise where Spotlight was working.  The owner of the corrrupted Spotlight was "wheel".  The owner of the functioning Spotlight was "staff".  I chown'd from wheel to staff (chown :staff /.Spotlight-V100), but that still gave me the same permissions error. 

     

    Next step, a call to Apple Tier 2 tech support for further insight as to what other file(s) Spotlight uses.  After several failed sudo mdutil attempts in MacOS and Single User Mode, the following successful command was exectuded in MacOS:

     

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

     

    I followed that command with "sudo mdutil -E /", then did the Spotlight System Preference, Privacy +/- toggle of my internal hard drive, and Spotlight *finally* started to index! 

     

    What a bugger of a problem. 

     

    Word to the wise, uninstall Spotless 3 before updating from 10.6 to 10.7.  Spotless 3 *does* take ownership of files needed by Spotlight, and Spotless 3 is incompatiable (does not run on) system 10.7.  The install of Lion does not reset Spotlight ownership back to MacOS. 

     

    Too, bad fixamac.com does not offer this support/resolution on their website or through emails (which I sent several inquiries of) to their paying customers of Spotless 3.  I will now use extreme caution when dealing with fixamac.com in the future because, and suggest you do as well.

  • chrisburbridge Level 1 Level 1 (0 points)

    Thank you !!! You save the next guy a big lot of work.

  • RadicalxEdward Level 1 Level 1 (0 points)

    Thank you thank you thank you!!! I think I disabled spotlight somehow years ago and couldn't get it working again since. I got the same error as the OP. Followed his steps and it worked perfectly! Now my spotlight and finder search finally work!!! (I am using OS X 10.9 Mavericks)

     

    For a bit of a clearer step by step.

     

    1. Open terminal and go to the root directory by entering:
    cd /

     

    2. Check the user-owner and group-owner of the directory .Spotlight-V100 by entering:

    ls -a -l

     

    It's listed as Permissions, user, group, etc

     

    3. The user should be "root" and the group should be "staff". If it's not, change them by entering (will ask for computers admin password):

    To fix the user:

    sudo chown root /.Spotlight-V100

     

    To fix the group:

    sudo chown :staff /.Spotlight-V100

     

    4. In terminal, enter:

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

     

    5. Then enter:

    sudo mdutil -E /

     

    6. In your system preferences you should now be able to go to the Spotlight preferences, then the privacy tab. Click the + button and add your entire hard drive under devices. You shouldn't get an error.

     

    7. Quit and reopen system preferences. Go back to the privacy tab under Spotlight preferences and this time select your hard drive from the list and hit the - button.

     

    Congratulations. Your mac should begin indexing your drive and some search functions should already be running. Indexing will take several hours depending on the size of your drive.

     

     

    Thanks OP!

  • gpinnyc Level 1 Level 1 (0 points)

    This was VERY helpful. Could anyone post what a new or standard Mavericks ls -a -l permissions should be? Most of my directories are root / hweel   a few are root /admin and one strange invisble file called .IABootFiles is my user name and staff.

  • Pravir Level 1 Level 1 (0 points)

    Thanks you SO MUCH Rad Ed!!

    You have no idea how much I have struggles with this  - it has taken up the best part of 4 days, and all levels of Apple Phone and Chat support were unable to sort it. They were suggesting removing MS Office, OS upgrade etc all of which I did. In the end they wanted me to wipe the comp and do a clean reinstall. But following your advice sorted it! Thank you!!

    PS> Did all this happen because of Clean my Mac or Spotless? I don't think I ever installed it on this machine so can't imagine why it happened to me...