Previous 1 2 Next 25 Replies Latest reply: Jan 4, 2014 2:49 PM by Ralph Landry1
Phlebas81 Level 1 (0 points)

Like a child who can't make up his/her mind in a sweety shop, my iPad 2 keeps dropping my home wifi network and giving me the list of other, close-by wifi networks.


WHY????? I feel betrayed... I have to keep selecting my network from the list, from which I connect quite quickly.  It seems to happen when my signal is lowest. ...Typical, dropping my network at the slightest sniff of another!!


Any way of telling-off/instructing my iPad to ensure it sticks with my network and forgets the rest?  I have tried "forget this network" with 'the others' but it hasn't worked...


P.S. My iPad is Wifi only...

iPad 2, Windows 7, And: iPad1, iPhone 4S
  • Ho Lee MACkeral Level 4 (2,185 points)

    1. Go to the Home Screen.

    2. Tap on Settings.

    3. Tap on General.

    4. Tap on Reset.

    5. Now select Reset Network Settings.

  • Phlebas81 Level 1 (0 points)

    Thanks Ho Lee for the super quick response.. I'm trying now and hope to provide my results within 48 hours... i.e. a good test period!

  • Phlebas81 Level 1 (0 points)

    Hi again.


    I'm afraid that didn't work. It disconnected me within 2mins again offering other networks. And has done ever since we last posted.  I then tried making  minor changes to the router settings, I.e Beacon interval, gave the router the ip addresses for the devices and their network labels... however theproblem is with the iPad. I kow that much.


    Any other tips/advice?  Would manual network configuration on the iPad help?

  • clivefromhigh wycombe Level 1 (0 points)

    Oh thank god someone else has the same problem thought it was just me or perhaps my wireless router (netgear) I am reading through different forums for an update on how to fix the issue, if I see anything that works I will let u know!!

  • Phlebas81 Level 1 (0 points)

    Hi. Just to clarify my minor router changes didn't help. BTW I have a virgin media d-link router, which I curiously swapped for my old linksys.... Anyway.


    Another possible solution was turning OFF General>Wifi>"Ask to join other Networks". This has reduced my iPads disloyal pestering, as my ipad2 won't go off and join another network other than my own. However it STILL disconnects and reconnects one one or two bar from my network... So, at least I've reduced the variables in this little issue. The mystery continues......


    Perhaps Apple have its iPads look for the better nework when signal falls below a certain threshold?  If so, how do we wed or nearest and dearest to our network???!!!

  • Diavonex Level 9 (66,545 points)

    Hope the following will help


    1. If you are using WPA, change to WEP


    2. If you are using channel 6 on the router, try changing to channel 1 or 11


    3. If Bluetooth is ON, turn it OFF


    4. You can also try updating the router firmware

  • Phlebas81 Level 1 (0 points)

    Diavonex, thanks for this. 


    I am already on a higher channel thanks to a small app called WifiPry which identified the local channel congestion... My initial thoughts on trying to address this issue. 


    Second, turned off bluetooth: This will certainly stop my neighbours tethering/personal hotspots being offered.  Should have thought of that atleast - thanks! However, Is there another reason for turning off Bluetooth?  I'm eager to learn. 


    Third, updating the firmware is a good idea. It says it is up to date though.


    Finally, I am very reluctant to change to WEP, as WPA is more secure.  Can you explain why the change is important.  I really appreciate your advice but Im the pestering sort that likes to ask "why", otherwise I could be here forever.


    Thanks, J

  • Diavonex Level 9 (66,545 points)

    Bluetooth can interfer with your WiFi. It interfer with my WiFi Streaming.


    Some laptop and tablet have difficulty working with WPA. If you are not comfortable with WEP, You can use MAC Address Filter for security.

  • Level 8 (41,760 points)

    Phlebas - Second: turning Bluetooth off is a good general thing to do if you are not going to use a Bluetooth device as it saves power...not broadcasting a Bluetooth signal all the time is easier on battery charge life.  It also reduces confusion by not having the signals from other devices available.


    Finally: stay with the WPA security, there have been many many more problems with iDevices and WEP than WPA over the past year.  Some iDevices will not connect at all using is much rarer for a device to prefer WPA.


    Additional point: have you tried power cycling your router?  That quite often helps clear issues and lock in the link.


    You said you switched routers, did this issue occur before the switch or is it only since the switch?  There seem to be certain routers that are more problematic for iDevices than one point some of us on here tried to start a list of wireless routers and problems but gave up...the comginations and permutations were just to great.

  • mckenney27 Level 1 (0 points)

    I am having the exact same issue with my iPad 2. I don't think it is an issue with the routers because I don't have the same issue with my older iPod Touch dropping WiFi. I have had my iPad 2 for almost a year with no issues until the last couple of months. It also happens on other WiFi networks (school, medical center, family, etc) so that makes me believe it is an iPad issue. It appears a lot of people are having this issue so hopefully Apple will be able to resolve it.

  • Level 8 (41,760 points)

    If you are having wireless problems on virtually all wireless networks, then it sounds like an issue inside your iPad.  While there are a number of questions dealing with WiFi on here, one does need to keep in mind that this is really a small cross-section of the entire iPad community...a few dozen problems out of seveeral million sold is not that big except when looking around this grroup where it appears to be widespread.


    I am not trying to defend Apple on this, and they should be addressing concerns, whether a design issue or manufacturing/quality control issue (a number of those recently), but just saying keep a perspective on how what appears on here compares to the total picture.


    Maybe I have been lucky...every Apple product I own has performed as promised...four Macs, MacBook Pro, iPad, iPhone, iPod...and a number of accessories.  I guess that makes me biased, a lot of products and no issues so far.


    With the problems you are having connecting, your best option would be to visit an Apple Retail genius bar and have the techs test your iPad...see exactly what is going on with it.

  • mckenney27 Level 1 (0 points)

    Thank you for putting things into perspective. And yes, the Apple products I have had/used are exceptional with rarely any problems. I'm even considering switching to a Mac when my old PC no longer serves me well. I will check into the Genius Bar locations, I am at least 2 hours away from any major city so I don't know if that will be an option for me or not. Regardless,mthe iPad 2 is a great device!

  • Phlebas81 Level 1 (0 points)

    Thanks everyone for your comments so far.


    I don't want anyone to be discouraged from contributing here. The reason for putting up this forum is not to bash Apple. Afterall, it is only one problem we are focusing on here. 


    We are posting because there are demonstrable issues experienced, albeit in different and often complex environments.  Therefore, the reasons for this post is to hear  many experiences and possible solutions, thereby eliminating as many variables as possible to isolate the issue.  If its my iPad, great as I'll take it back to Apple. If its my router, I'll happily strap it to a firework and send it skyward.  And so on. 


    It's great some folks here have been lucky, but let's not make assumptions readily - as I said, we all use our tech in different and often complex environments.  For example, i've wondered does iPad struggle with being surrounded by 6 neighbours' wireless networks, all of the same ISP using the same router? Probably not, or....?  We'll not know unless we post here.


    Keep posting openly and honestly; we are posting because we love our apple products and want to enhance our experiences. Otherwise, we'd not post...I assume... Im sure the majority of readers can undertsand our comments in context.  And yes, if anyone goes to the Genius bar, list the answers here.... Please :)

  • Tahir Muzaffar Level 1 (0 points)

    Same thing for me, this solved my problem, I am using a linksys WAG160N wifi router



    Set to WPA2 Personal (AES)



    2.4 GHz Radio Mode

    Set to 802.11b/g/n



    2.4 GHz channel width

    Set to 20 MHz

Previous 1 2 Next