12 Replies Latest reply: Dec 30, 2012 7:12 PM by dominicnyc
andrewmcintire Level 1 Level 1 (0 points)

My iPhone will occasionally not play a song when I press play, instead skipping to the next song.  I have noticed that it does it mostly with purchased songs from iTunes.  Any tips or comments are appreciated.

iPhone 4, iOS 5
  • xtremecarbon Level 4 Level 4 (2,235 points)

    Because you're holding it wrong. Both a tip, and a comment.


    Try a restore. I feel like I type this too much but it's possible. Is it only in the Music App or is that area of your screen a bad spot?

  • Morogh Level 1 Level 1 (0 points)

    This sounds similar to my problem, so perhaps I won't start a fresh thread.


    1)  I pick a song and engage it to Pay.

    2)  Roughly a 50-50 chance that actual song will play or some random Shuffle choice.

    3)  I have selected and deselected "Shuffle" about a dozen times.

    4)  The fun continues in that it is not simply shuffling.  It is playing a totally different song while displaying the song I selected.  For example, I chose a "Hard Day's Night" by the Beatles. The screen and album art and title all indicated "Hard Day's Night".  What is playing, however, is "Another One Bites the Dust" by Queen.

    5)  I tried tapping the "FFwd" or "Next" arrow, to scroll thru the songs and see if there was any pattern to this uintended shuffle.  About four songs along, the music stops.  The screen is not locked up or frozen. The play button simply gets no action.  The song will not play.

    6)  In general, it seems to play a half-dozen random songs (staying within the Playlist) and then gets tired and doesn't want to be bothered any longer.

    7)  As I say, I've tried to deactivate Shuffle several times.  I've done a total power off and restart twice.  I've plugged it into iTunes and de-Sync/re-Sync the entire music library twice.  The phone was about 70% charge when this started.  I've brought that up to 100% before experimenting.


    Any thoughts would be appreciated.


    Happy Saturnalia!


    iPhone 4, iOS 5

  • seth42 Level 1 Level 1 (60 points)

    Are you on iOS 5 or iOS 5.0.1?  5.0.1 is the most recent.

  • Morogh Level 1 Level 1 (0 points)

    Sorry, I hoped to cover all the minimum essentials.  iOS 5.0.1.

  • StevenJH Level 1 Level 1 (0 points)

    Having exact same issue as noted by Morogh - except I have a 4S 16GB running the iOS 5.0.1

  • JasonSAuck Level 1 Level 1 (35 points)

    Hi all.


    Possible fix:


    Had this annoying issue, or similar. Songs on my iphone 4 would skip until it found a song it could play, but often left up on the screen a different song to the one playing. It appeared songs hadnt been transferred or were missing causingthe phone to skip the songs.


    I heard that if you get a 'weird' beep noise this is the 'shake to shuffle' feature which can be turned off via Settings>Music.


    If you have a similar issue to mine, I read converting to AAC (right click song in Itunes and choose 'convert to AAC) could work, and did for me, but is time consuming and duplicates the song.


    What worked for me? Turning off 'convert higher bit rate songs to 128 kbps AAC' on the Devices>Your Iphone main menu (device summary page). This reloads all songs to the iphone and appears to fix the issue. I have checked a few songs I knew had issues and they now work, and I can get through 10+ shuffle songs (thats as many as I checked) without a skip.


    Good luck. Let me know if it works.

  • Morogh Level 1 Level 1 (0 points)

    Let the bells ring out!  Let the banners fly!  It's too good to be true, but it worked!  It worked!


    Since you tested to about 10 songs, I went to about two dozen.  Normal song playback.  A fix-patch-juryrig I would never have considered.


    I'd name my firstborn "Jason", but that name is already in the family.  I wonder if the wife will allow the first born to be "Auk"?



  • JasonSAuck Level 1 Level 1 (35 points)

    I'm glad it worked. It bugged me all weekend this issue so I spent some time on it last night. I first came accross the aac fix which worked, but I wasnt going to apply that to my whole song list. I had a look for other options around the phone and found that on the summary page and then it clicked to try turning it off. It appears songs will take more room as they are not compressed, but I managed to play for an over an hour last night with no issues.


    Glad it also worked for you

  • sahalt Level 1 Level 1 (0 points)

    This worked for me, too, and I am very grateful.  I had searched for a solution for some time!  Interestingly, I had to turn ON the conversion to the lower bit-rate, but the effect was exactly the same - all of the files were re-loaded, and the problem was solved.  So if you are need to conserve space, you can probably convert your files back to the lower bit-rate by turning on the conversion again, allowing all of the files to re-load, and then I am guessing that all will be well.


    In any case, my sincere thanks for this interesting work-around.


    Now, if only Apple would add the functionality into iTunes to re-load individual files, that is, fix the problem that is already noted by virtue of the "!" when you try to play the file from iTunes directly from your iPhone.

  • Dominar Level 1 Level 1 (15 points)

    I have this issue.  Started when I was on 5.0.1 hoped that upgrading to 5.1.1 would help but it doesn't.


    I've tried restoring with no luck.  Then I read unchecking Sync Music in iTunes, then applying it and then rechecking, Sync Music was supposed to work.  It didn't.


    Now, I'm erasing all content which is probably going to suck.  If that doesn't work I'll try the above fix.


    Its gotten so bad I cant play any music.


    This seems fairly prevelant why hasnt Apple addressed it?

  • Dominar Level 1 Level 1 (15 points)

    Didn't work at all.


    Phone locked up when I tried erasing all content. Forced Reboot after about 15 minutes and all my stuff was still on the phone!!

  • dominicnyc Level 1 Level 1 (0 points)

    This fix helped me get to where I needed to fix this myself, but I had to take a couple of detours to get there. I'm using an iPhone 4S and am up to date with the iOS 6.0.1 (10A523) and am not a Match customer. I first tried to convert a song to AAC and this worked after synching. Yeah! Then I tried the whole album and then deleted the duplicate so that only the converted songs synched to my iPhone 4s. This only worked for some songs. Boo! So I took the next step by trying to fix this from the settings.


    In the iTunes Info screen the AAC conversion box was already unchecked, so I checked it and first selected the lowest 128 kbps option. iTunes then determined what to sync in whole library. This could take a while depending on how much music you have. I don't have more than 2,000 songs and it must've taken a 1/2 hour or so. This worked and i was able to play all songs! Woohoo! But I didn't want degraded sound, so upgraded to the highest 256 kbps and all songs still played. So I then decided to go back to unchecking the conversion of higher bit rate songs to 256 kbps and ALL songs are still playing!


    This was such an incredibly laborious process and it only affected songs that I had bought off of iTunes (I think over the air). I am also trying to remember when these songs were affected since I know that I had downloaded and played them with no problem around the time that I purchased them. I am thinking that it must have been after I physically synched my phone to my Mac and a problem with how the songs were converted must have occurred then. I need to recreate this scenario again. Additionally, when I downloaded those same songs from the cloud onto my iPad 3 (wifi + AT&T data). They played immediately without any problems.


    I'm just wondering if it is only a matter of time before the songs get corrupted again and I have to repeat the conversion steps again and again. Very disappointing and buggy.... You'd think Apple would be able to deliver files that could be used by hardware that is supported with the latest iOS. But I am very happy that this fix that was posted worked for me too.