1 Reply Latest reply: Dec 22, 2011 11:44 PM by Mac Medic (be@MacOSG.com)
Rheverie Level 1 Level 1

So I decided to restore and update my iPod touch 4th gen from iOS 5.0 to iOS 5.0.1 through the latest iTunes. But, I got an error 14 message (something wrong with USB or something like that). And now my iPod shows a blank white screen. I've tried to turn it off through several method, like entering DFU mode and sleep/wake+home button. But neither has worked. It stucks on the blank white screen. Also, I've tried to connect it to iTunes on my computer, but iTunes didn't show any device, and now I can't even retry to restore my iPod. I also have read many threads with the same problem but none of them could help me.

It still in waranty but there is no Apple Store here. The nearest Apple Store is... far far away from my town (and the town nearby).

 

Is there any way to fix it without having to take it to the Apple Store to get a replacement? Any suggestions?

 

Thanks for your help.


iPod touch, iOS 5, 4th generation
Reply by Mac Medic (be@MacOSG.com) on Dec 22, 2011 11:44 PM Helpful
Call Apple. You can send it in for repair. They will pay for shipping both ways via UPS.  Basic troubleshooting steps        17" 2.2GHz i7 Quad-Core MacBook Pro  8G RAM  750G HD + OCZ Vertex 3 SSD Boot HD  Got problems with your Apple iDevice-like iPhone, iPad or iPod touch? Try Troubleshooting 101 In Memory of Steve Jobs 

All replies