Previous 1 2 3 Next 88 Replies Latest reply: Oct 16, 2013 3:29 PM by bjwilson22
emm102 Level 1 (0 points)

Hello! So I reciently tried to download a rented movie. It got about a quarter of the way through downloading when the error message occured "There was an error downloading your purchased music. An unknown error occurred (-50)." I found the help page and followed the instructions in removing the file, but when I went to sign in and redownload it, I got the same error. Is there another solution to this issue?

Mac OS X (10.6.8), regarding itunes
  • Carolyn Samit Level 10 (103,365 points)

    Try this...



    Launch iTunes on your Mac.


    From the iTunes menu bar click iTunes > Preferences then select the Advanced tab.


    Click: Reset warnings and Reset cache


    Click OK


    Restart your Mac, launch iTunes, try again.

  • emm102 Level 1 (0 points)

    the first time i tried it, the movie restarted downloading and it seemed to be working. Toward the end of downloading though, the error appeared all over again. I restarted my computer, then went through the steps on the apple support page and your solution and it still wont finish downloading. am i doing something wrong?

  • FastTJR Level 1 (5 points)

    I am having the exact same issue.

    I have been trying for 24 hours to download two tv show series. There is a total of 15 episodes and, because of iTunes crazy approach of downloading both HD and SD versions, a total of 30 files.

    After numerous attempts (probably more than 40) I have now got 25 of the 30 files to download, but the remaining 5 repeatedly give me error -50.

    I have deleted the cache, deleted the .tmp files using Finder. Rebooted my modem, router and my machines (I have tried on three different machines using two different accounts).

    I have done a speedtest on my internet connection and am repeatedly getting 30Mbps down and 3Mbps up, so I don't think it is my connection!

    I believe that Apple is having issues with their video content servers -- perhaps too many people trying to download for the holidays...  I downloaded two music albums without any problems, but video seems to be a lost cause at the moment.

  • lefthandmac Level 1 (0 points)

    Same issue - reposting this from the (now) multiple reports of this issue over the past 24 hours!



    It's looking like the problem is pretty widespread. I can't get Pirates of the Carribbean: Stranger Tides to download to either my desktop or iPad. On the desktop, it doesn't get past 10MB, starts over and then issues an error - either -50 or 8008. On the iPad, it downloads completely and then restarts the download and never shows up in my purchased content (and will continue to re-download infinitely it seems unless I pause it - but it still shows up there waiting to be re-downloaded. For what it's worth, I'm able to download music and apps without issue and just last week downloaded Cars 2 using the same computers/settings/internet connection.


    I tried all the tricks - On the desktop... clearing the iTunes cache/history, removing the tmp movies files in downloads folders, restarting desktop, signing in/out of iTunes store, etc. etc. On the iPad... reset the iPad, signed in/out of iTunes store, downloaded movie trailer, etc. etc. Nothing works.


    So, my guess is that their movie/video servers are likely overwhelmed right now. I contacted customer support and all they did was issue me a refund.

  • vizzy123 Level 1 (0 points)

    Just replying to this thread to report that I have also been getting Error (-50) and nothing on Google or iTunes support forums has helped.


    I'm temped to try again in a couple of days or during the wee hours of the morning to see if it is indeed iTunes' movie servers being overwhelmed.


    I tried to download a Podcast and it downloaded just fine, with no errors.

  • FastTJR Level 1 (5 points)

    The situation seems to have improved. I was fianlly able to download the balance of the episodes that I was missing and the last two (HD, ~1.4GB each) downloaded without interruption.

  • tonyedwards Level 1 (0 points)

    Had the same issue, but with downloading from the App Store. This worked for me. Thanks!

  • jasonfromosu Level 1 (0 points)

    I'm having this issue as well. It's driving me nuts. Anybody heard anything concrete about a solution? Are people still having the problem?

  • tonyedwards Level 1 (0 points)

    I had the same issue, but I seemed to resolve it by going to iTunes preferences, choosing "Advanced", then clicking the butto to reset. the iTunes Store cache.

  • jasonfromosu Level 1 (0 points)

    This does not fix it for me.

  • vizzy123 Level 1 (0 points)

    Yes, apparently people are still having this problem. And nothing on this help page seems to help me at all:




    I have cleared my cache many times, re-installed iTunes many times, deleted the files in my Downloads folder many times. I am not behind any firewalls that block the iTunes store because I can download Podcasts from the iTunes store just fine. This is extremely frustrating and iTunes support wasn't any help at all. They simply directed me to the aforementioned help article.


    I really wish they would come up with a solution for this because as it stands right now I cannot download the movies I redeemed with a code from the Bluray Disc.

  • jjmk Level 1 (0 points)

    We are having the same issue.  We have been to AppleStore twice.   They are clueless and even indicated that it isn't an Applestore problem, but is an Itunes issue and that we should contact them.  Very frustrating!!

  • lefthandmac Level 1 (0 points)

    Just an update from me. I finally got a movie download to work after downloading the new iTunes update (10.5.3). I'm not sure if it mattered, but I also deleted the .tmp file and reset the cache and all of that before trying the download again (in the updated iTunes). None of these steps (removing .tmp file or reseting error/cache) worked before, so I'm assuming that my iTunes update is what did it. iTunes support lead me on a wild goose chase including creating a new account, downloading to different computers on different internet connections. None of that worked. Anyway, good luck to all - I'm off to watch a movie (finally!).

  • Marc Winkens Level 1 (0 points)

    Hi everyone,



    I just noticed that I get my downloads from an Akamai server instead an Apple server. Some forum posts - and if I am not mistaken an Apple support article - says something about accelerators messing with downloads. Well, there we could be.



    Can anybody having this problem persistently confirm that she/he gets the files from an accelerator as well? Do a wireshark or tcpdump while downloading, get the IP address and do a ripe query.



    I never looked into this accelerator stuff and I do not know who is responsible for putting such a service in between (the ISP or Apple).





Previous 1 2 3 Next