iMessage wont work on my ipod touch!

Previous 1 2 3 Next 34 Replies Latest reply: Oct 4, 2015 1:53 PM by Josh+
michaela.96 Level 1 (0 points)
Anyone else having a problem with iMessage? So far everything else seems ok. I have tried several times to log in and eventually get a error message saying "PLEASE CHECK YOUR NETWORK CONNECTION AND TRY AGAIN LATER". There is no problem with my network connection and I've been online on several websites which appear to be working correctly. I have also checked in settings to turn ON iMessage but when I click on settings and then Messages, there is only the sign up fields, no activation buttons to slide across etc. Anyone out there with some help?

iPod touch
  • rrachelruckus Level 1 (0 points)

    I just got my daughter a new ipod touch - can't get the imessage to work

    everything works but the imessage which is what she is the most excited for

    I can get on the internet, i cloud works, facebook works, skype works,

    EVERYTHING but the imessage.... in settings its set up  - anyone have any ideas or suggestions to get the imessage to work?

  • Rysz Level 6 (8,132 points)

    Just in case you are not aware of it...

    iMessages only work between iOS devices. That is, the other person must also have an iPhone, etc, running iOS 5 and iMessage enabled.

  • STfromLR Level 1 (0 points)

    I am having the same problem.  My daughter has an old iPod Touch, and the iMessage still works fine on the old one. We can't get it to work on the new one.  I get the same message about the network connection, and I can't set up her account. 

  • Rysz Level 6 (8,132 points)

    Considering how many millions of people are trying to set-up their iDevices received for the holidays, I wouldn't be surpriced if Apple activation servers were a bit overloaded...

  • PinakbetSupreme Level 1 (10 points)

    People have been having the same error during the initial setup for FaceTime.  The general consensus is to change the network settings, specifically the DNS numbers.  The default should be your wireless router, edit it and use google's public DNS 8.8.8.8 and retry the activation process.

     

    Hope this helps!

     

    Aloha,

    -bp

  • michaela.96 Level 1 (0 points)

    @ PinakbetSupreme -

     

    Thanks so much! I just tried what you suggested and it worked like a charm! Do you know how I can mark this as the best answer to my post?

     

    Thanks again, you're a legend!!!

  • michaela.96 Level 1 (0 points)

    @ rrachelruckus -

     

    I just tried what PinakbetSupreme said and it worked for me so hopefull it'll work for you too!

     

    Go to Settings > Wi-Fi- > Your network > Scroll down to where it says DNS > Delete what is there and type in Gogle's public DNS "8.8.8.8"  (Including the dots) > And then retry to activate iMessage!

     

    Good Luck!

  • Rysz Level 6 (8,132 points)

    To mark answers, just click on the green or orange text within the same box.

  • michaela.96 Level 1 (0 points)

    Sorry for my ignorance Rysz, but I can't see what you're talking about. Can you explain any further? Sorry

  • Rysz Level 6 (8,132 points)

    As the OP (original poster) of this discussion, you should see each discussion cloud/text  box with two options at the bottom of the answer: Correct Answer (green text) and Helpful Answer (orange text). You can mark one answer as correct and two answers as helpful by clicking on these texts. Do you not see them?

  • christina97 Level 1 (0 points)

    Hey, I'm new to the conversation but I am having the same problem where everything except for iMessage is working on my new iPod. I tried what y'all said earlier in the conversation by changing the DNS code but when I went to try and log in again, I got the same "try your network connection again" message. I was wondering if there was any other problems with trying to activate it. Thanks!

  • jdbelk Level 1 (0 points)

    I too, am having the same problem as original post. I also did the changing of the DNS numbers to 8.8.8.8. but still got the same msg-- could not sign in please check your network connection & try again. HELP! this is driving me insane!!!

  • emily2452 Level 1 (0 points)

    yes i do

  • lllaass Level 10 (176,163 points)

    If you go to Settings>General>Time&Date is it set to Automatic?

Previous 1 2 3 Next