9 Replies Latest reply: Apr 19, 2012 4:41 PM by ladybug1713
lauren1317 Level 1 Level 1 (0 points)

I have the 5th generation ipod touch. The problem I am having is when I chose my Wi-Fi network and put in my password it just keeps loading (the loading circle) It never actually connects. Yet in the left hand corner I get the signal strength as if it is connected! It Just constantly tries to join the network but never actually does until I get so bored of waiting that I give up (like hours later). I've tried resetting me ipod, resetting the network settings, turning my router off and on (I have a netgear router). I have also tried to access my netgear router to add my ipod to the access list and then tried to access the internet on my ipod but that didn't work either! My security is WEP but whenever I try to put this in it just dismisses it so instead I put the password in for our wireless and it seems to like that but then just stays on the loading circle.

I don't understand why though because my dad has a 3g Ipod touch and the recent Iphone and they all connect fine, just not mine Please help!


iPod touch, iOS 5.0.1