1 2 3 4 5 Previous Next 66 Replies Latest reply: Nov 4, 2013 4:15 AM by xirb Go to original post
  • 15. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    fikoko Level 1 Level 1 (0 points)

    The SSD doesn't work perfectly.

    There is some I/O Errors that make install impossible :'(

    I remove one memory stick of both, so I now have 4Go of RAM, and remove and put back SATA cable.

    Now it seems tor works, this could work with Samsung 830

  • 16. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    clintonfrombirmingham Level 7 Level 7 (28,655 points)

    It's flubbed up somehow, then (the SSD). You should be able to see it in Disk Utilities and be able to format it from there. I'd return it and get another - and start the process all over again.

     

    Sorry,

     

    Clinton

  • 17. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    clintonfrombirmingham Level 7 Level 7 (28,655 points)

    But you shouldn't have to downgrade your memory to install a working SSD. I had 16GB in mine when I upgraded to the Crucial m4 512GB. Not one problem getting it up and running in a very short period of time.

     

    I think some of you are having trouble with the SSDs themselves - I'd return them (and keep returning if needed) until I got one that worked.

     

    Clinton

  • 18. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    fikoko Level 1 Level 1 (0 points)

    For the OCZ problem, I have activate TRIM with "TRIM Enabler" and I have no more problems : even with all RAM, no IO errors. I filled SSD with zero data (dd if=/dev/zero of=zero) with no errors.

    I hope this will be useful fore someone else.

  • 19. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    Expirobo Level 1 Level 1 (0 points)

    Just to beat a dead horse (seems like you got the OCZ working), it appears that you have some issues around your MBP. I have a mid-2011 13" mbp, OSX Lion, 16 gb DDR3-1333 ram and a Samsung 830 SSD (256gb) all running very harmoniously. I had no problems with the ssd install, however, about 2 months ago I started getting beachballs and complete system lag for several seconds or more. The ssd was only 3 months old. I upgraded to the new Samsung 830 firmware and the problem went away. I have beligerantly pushed the thing to make sure it wont cause problems again and it hasn't.

     

    I have trim off, although I had it on originally. However, even after I reinstalled Lion the beachballs still existed until the firmware upgrade. I really hate to say it, but your MBP may have a Sata 3 shielding problem, causing issues recognizing the ssd's at their intended bandwidth. Although they should be backwards compatible, if the speed negotiation is flipping around, this can cause exactly the issues you are having. Check your system profiler to see if you are at full 6gbs bandwidth.

     

    Also, just to mention it, the new MBP (retina) have the same exact Samsung controller from the 830 in their SSD drives now. So any qwirks with them should be worked out on the next firmware update.

     

     

  • 20. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    fikoko Level 1 Level 1 (0 points)

    Yeah, I think you're right.

    However, here is what is said by system profiler :

     

    Intel 6 Series Chipset

    Fournisseur: Intel

    Produit: 6 Series Chipset

    Vitesse de la liaison : 6 Gigabits

    Vitesse de la liaison négociée : 6 Gigabits

    Description : AHCI Version 1.30 Supported

     

    OCZ-VERTEX4

    [...]

    TRIM : No

    SMART : Checked

     

    And now works with no IO/Errors even if I shut down computer because of kernel panic.

    Note : I removed sata cable of MBP and clean with a air spray.

  • 21. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    Expirobo Level 1 Level 1 (0 points)

    iFixIt.com sells replacement shielded cables for the MBP. I don't condone 3rd party equipment for non user-upgradeable parts, however, with this issue you may look into it. Other than that, I am out of ideas. I have never had a kernel panic with the SSD. When I installed Crucial memory in the MBP, initially I got kernel panics. Then I RMA'd back to NewEgg and got Kingston (my favorite brand of memory) and have had none.

     

    Kernel panics are usually a symptom of clock timing issues, where the bus or memory clocks hang and dont allow the kernel to complete the required processing within the current clock cycle. The hard drive should not cause this unless it hangs during communication without warning, caused by hardware problems on your computer.

  • 22. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    fikoko Level 1 Level 1 (0 points)

    Finally returned the MBP (mid-2011) for maintenance.

    IO errors came back, on the OCZ Vertex 4.

    OCZ Agility 3 not recognized (I wanted to try older SSD generation).

    As soon I have the MBP back, I will try again try with Samsung 830.

  • 23. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    fikoko Level 1 Level 1 (0 points)

    Retried an other Samsung 830 256G : failed to be recognized from new installer.

    Note : Agility 3 performance really poor if filevault 2 enabled.

  • 24. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    zayub Level 1 Level 1 (0 points)

    Have been using the Samsung 830 in a Macbook Pro Late 2008 for about 8 months now without any problem.

     

    NVidia MCP79 AHCI:

     

      Vendor:          NVidia

      Product:          MCP79 AHCI

      Link Speed:          3 Gigabit

      Negotiated Link Speed:          3 Gigabit

      Description:          AHCI Version 1.20 Supported

     

    SAMSUNG SSD 830 Series:

     

      Capacity:          128.04 GB (128,035,676,160 bytes)

      Model:          SAMSUNG SSD 830 Series                 

      Revision:          CXM03B1Q

      Serial Number: XXXXXXXXXXXXX     

      Native Command Queuing:          Yes

      Queue Depth:          32

      Removable Media:          No

      Detachable Drive:          No

      BSD Name:          disk0

      Medium Type:          Solid State

      TRIM Support:          Yes

      Partition Map Type:          GPT (GUID Partition Table)

      S.M.A.R.T. status:          Verified

  • 25. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    will_dale_ Level 1 Level 1 (0 points)

    I have just bought the samsung 830 series online waiting to be delivered.  I still have applecare on my mbp, will their tech support phone help me through any problems I encounter or is that a stupid question because its a third party hardware (although I hear they are using these drives in the new retina model anyway).

  • 26. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    Bimmer 7 Series Level 6 Level 6 (10,270 points)

    will_dale_ wrote:

     

    is that a stupid question because its a third party hardware (although I hear they are using these drives in the new retina model anyway).

    I think you've answered your own question.

     

    in any event, do not expect to get the same issue as others are having....different factors play on why one is having issues while others aren't having any.

     

    good luck.....the 830 seires is a good drive and it's the one being used in the Retina Macbook PRO

  • 27. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    Mini-Mac Level 3 Level 3 (785 points)

    My 2cents:

     

    I had the Samsung 830 and had issue with it (beachballs).  I really thought Samsung was the king of SSD's and may very well be, but not for me.  So I returned the Samsung 830 to Amazon for a refund.  After a little more reasearch I decided on the Crucial M4 series SSD.   I've had NO issues at all with the M4 (5 months of use).  In fact I like Crucial M4 SSD's so well I purchased (10 days ago) one for my new 2012 MBP 2.6GHz i7, HR antiglare WS (USB 3.0).

     

    One thing I learned about SSD's that I instutited from the get go was to disable "Put Hard Drive to Sleep When Possible" in "System Preferences" "Energy Settings".  Others have disabled sudden motion sensor via Terminal but I think my method is better....IMO.

     

    BTW, Im getting 285 write and 502 read, 17.6 second (average) startup in the 2012 MBP.  A real screamer, the fastest computer I've ever owned and Im 54.  Geekbench score 12096. 

     

    P.S.  Almost forgot Crucial firmware upgrade is easy using MBP, not sure about Samsung.  I upgraded the first M4 firmware from 0309 to 000F (no problems with firmware 0309).  My newest M4 came with firmware 000F.

  • 28. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    Bimmer 7 Series Level 6 Level 6 (10,270 points)

    I own 2 Crucial M4 SSD - 256GB in my late 2011 Macbook PRO 13 inch and a 512GB in my late 2011 Macbook Pro 15 Inch with no issues either.....

     

    in any event, thread was about Samsung 830 Series...

  • 29. Re: Problem with Samsung SSD 830 in MacBook Pro 5,3
    Mini-Mac Level 3 Level 3 (785 points)

    BTW, my 633CSi is the best of the 6 series.  In any event, this thread is about the Samsung 830.....sorry you already said that......my bad.