Previous 1 2 3 4 5 Next 66 Replies Latest reply: Nov 4, 2013 4:15 AM by xirb Go to original post
  • Reddyzinho Level 1 Level 1

    You have to isolate the sata cable. I've done it with my ssd Samsung 830 and it works. Think about change the cable. Apple doesn't isolate it very well on MacBook pro 2009. Best regards


    Tiago Cunha

  • darrylyoung Level 1 Level 1

    How do you know what the latest firmware version is for this SSD? I bought a 128GB one for my 2009 MacBook Pro a couple of weeks ago and I just set it up without thinking. I'm wondering know if the firmware is out of date. Thanks in advance!


    Edit: I found it here on the Samsung site under the Firmware tab. Thanks anyway. It seems as though it's not been updated since January.

  • Alex550 Level 1 Level 1

    I just got my SSD drive for my Macbook pro (2010).  I am using Leopard osx.  At first it didn't recognize the internal drive either.  However, on the installation menu, I use the disk utilites to format the drive and after that, it was able to recognize the drive and works perfectly.


    Hope it helps

  • ceraf Level 1 Level 1

    I installed a Samsung 830 128GB SSD in my 2009 Macbook Pro 13" with EFI 1.7 about a month ago. System profiler (or whatever it's called now) reported a negotiated speed of 3.0 Gbps.


    I had no issues installing OSX Leopard, and then upgrading to Snow Leopard, then Lion, and then Mountain Lion.

  • andreinoSI Level 1 Level 1

    I have just bought a Samsung 830 ssd! Everything SEEMS to work perfectly. I installed mac os 10.8.2 and the system boot in a while. AFTER, when I'm working the system freezes for 5/10 sec every 10/20 secs... I often have issues writing files as well (for example I often have an "unrecognised error -5" while I'm copying file into the desktop).


    What advice do you have for me?!? :-(


    Pleeeaseee help me! :(

  • clintonfrombirmingham Level 7 Level 7
    Mac OS X

    First, I would boot into your Recovery partition (holding down the Command and R keys on boot) and, using Disk Utility, verify and repair permissions and then verify the SSD. If errors occur, try repairing the volume.


    I would also check to make certain that you have the latest firmware for your SSD. I don't know how it works with Samsung, but with Crucial you can update the firmware on your Mac (with Samsung you may have to do so using a Windows machine - I honestly don't know).


    If neither the repair disk or making sure that your firmware is up-to-date, I don't know what else to tell you. You may just have a defective unit.



  • andreinoSI Level 1 Level 1

    Yes, I already tried to very the volume and no problem appear to be in the ssd. I also check the firmware (yes, from a Windows machine) but I already have the latest one! Now I'm trying to read/write some file into the ssd from windows and the device seems to work perfectly! :-(


    I am very out of ideas!!!!! :-(

  • NoBo Mac Level 1 Level 1

    Did you enable TRIM via the TRIMEnabler app?


    I recently put the Samsung 830 in my Macbook Pro. I was getting occasional hangs of about 30 seconds as well. I did use TRIMEnabler. But, I did make a copy of the kext before running it, so, I reinstalled the original kext. Computer was back to running smoothly.


    So, I turned TRIM back on via a script. Several out there. I used the instruction on the following link. So far, no hangs:


  • andreinoSI Level 1 Level 1

    Yes, of course I enabled it. Anyway It seems a compatibility issue, so I send back the SSD to the shop and it will give me a new one with Sata II instead of Sata III!

  • Mini-Mac Level 3 Level 3

    I've had my Crucial M4 SSD 256GB installed in a late 2012 MBP now for more than 3 months without TRIM enabled (firmware 000F).  My drive is working as if it were NEW. 


    Before you enable TRIM on your Mac you might to want check with the manufacture first, otherwise you could get degraded operations and OS issues which could result in data loss.


    Many people jump the gun thinking TRIM is required (it's NOT always) if the manufacture has a solution built-in to the drives firmware (Crucial does).  Actuall if you enable TRIM with this function already there your setting yourself up for issues and degraded operations.


    If you are the opinion that Apple intentionally left out the ability to keep your SSD in good condition by not supporting TRIM on 3rd part SSD's you'd be wrong.  The reason Apple's SSD's have TRIM supported is because the SSD's installed are either Toshiba or Samsung specifically for Apple without the manufactures garbage collection firmware (they have Apple firmware) and Apple lets the OS handle garbage collection.


    If you have a Mac with an Apple SSD installed reboot your computer with the option key held down at start up and select Recovery disk hit enter and then go to Disk Utility and repair your Macintosh HD.  After the repair has completed, and above the green line that says your The volume Macintosh HD appears to be OK, it will tell you Trimming unused blocks.  Trimming unused block message won't appear if you've enabled TRIM on 3rd party SSD's.


    Most modern (2010 and after) SSD's from the top manufactures apply their own tools for handling garbage collection.  That's one of the reasons manufactures push out firmware updates (some good and not so good).  For example Crucial's recent firmware (010G) update caused problems with there SSD's.


    Also some have reported that disabling Sudden Motion Sensor (SMS) is needed.  I haven't done it and like I said above no problems.


    BTW,  my SSD speeds have been 265 and 501 respectfully.

  • geirole Level 1 Level 1



    I ordered a 512 GB Samsung 830 SSD for my 17" mid 2009 Macbook Pro after having heard/read good things about it. But then, when I read the comments here on this forum, I got pretty worried.


    I put the SSD into a 3.5" usb 3 enclosure and connected it to the USB 2 port of my MacBook. The 3.5" enclosure worked fine as the cables and connectors are the same. After formatting and partitioning with DiskUtility, I copied the old "Macintosh HD" over to the SSD with SuperDuper!. It took quite  a few hours and the average copying speed was hovering around 10 MB/sec. After about 8 hours it was done. During the partitioning of the SSD I gave it the name "Macintosh HD", just so that it should look as similar as possible to the old one. This maybe has no importance. When the copying from the old HD to the SSD was done I took it out of the 3.5" enclosure, opened the Macbook, disconnected the cable that connects the battery to the motherboard, took out the old 500 GB 5400 rpm Hitachi drive and put the SSD in. It fit very snugly. Back on with the bottom plate and then I turned the computer on, holding the "alt" key down. After a few seconds the HD icon showed up and I hit enter. Big was my relief when the login window suddenly appeared, with the same photo as usual. After entering the password, the computer came up really fast, and everything looked as before. Puuhhhh!!   :-)


    I have now played around for a few hours and the computer is really snappy compared to before. Heavy applications, such as Adobe Photoshop and InDesign start up much faster than before. Mail works faster. I thought before that Mail was slow due to some bottlenecks somewhere on the internet, but now I realise that it might have been the Hitachi HD that was just slow. The best thing so far is when I scroll through large and image rich InDesign documents, like a 64 page document with 268 eps and ai figures that I am working on right now. Before it was a pretty annoying process to scroll through that document with the computer hanging after a few pages before it would srcoll further. Now, with the SSD, I can scroll back and forth as fast as I wish, and I can't make the computer hang. This is really nice. :-)


    I had one problem though, and that was with MS Office 2011. It obviously sees my installation as a new one since the disk is different. It said that I already had used the maximum number of installations allowed with my license, which probably is correct. On the other hand, Office 2008, which I had kept, runs fine, so I am not in big trouble. The Adobe Creative Suite works fine, and so does IDL, which is also licensed software.


    My old disk was the 500 GB Hitachi 5400 rpm that came with the computer when I bought it in June 2009.

    In the system report it said that the Link Speed was 3 Gigabit and the negotiated Link speed was 1.5 Gbit. I guess this was a limitation of the Hitachi drive. Now, with the SSD in place it says:


      Link Speed:          3 Gigabit

      Negotiated Link Speed:          3 Gigabit



    Of course, I don't get the full SATA III 6 Gbit capacity of the Samsung 830 SSD, but I get SATA II, which is not bad.


    With the Black Magic Disk Speed Test I get about 190 MByte/sec write speed and 250 MByte/sec read speed.

    That is pretty close to half of what SATA III SSD drives are capable of.


    I also downloaded the Trim application and turned it on. It says the patch is active and that "Everything looks super". :-)


    Below is info on my 17" Macbook.

    I run OS X Version 10.8.2.

    It is clear from the output below that the Samsung disk is completely recognised with its serial number and everything.











    Model Name:          MacBook Pro

      Model Identifier:          MacBookPro5,2

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2.8 GHz

      Number of Processors:          1

      Total Number of Cores:          2

      L2 Cache:          6 MB

      Memory:          8 GB

      Bus Speed:          1.07 GHz

      Boot ROM Version:          MBP52.008E.B05

      SMC Version (system):          1.42f4

      Serial Number (system):          W89226XW8YA

      Hardware UUID:          9F9B2814-801B-585C-9C05-577CABAC11F8

      Sudden Motion Sensor:

      State:          Enabled



    Here is info on the SATA interface and disk:


    NVidia MCP79 AHCI:


      Vendor:          NVidia

      Product:          MCP79 AHCI

      Link Speed:          3 Gigabit

      Negotiated Link Speed:          3 Gigabit

      Description:          AHCI Version 1.20 Supported


    SAMSUNG SSD 830 Series:


      Capacity:          512.11 GB (512,110,190,592 bytes)

      Model:          SAMSUNG SSD 830 Series                 

      Revision:          CXM03B1Q

      Serial Number:          S0W0NYAC200196     

      Native Command Queuing:          Yes

      Queue Depth:          32

      Removable Media:          No

      Detachable Drive:          No

      BSD Name:          disk0

      Medium Type:          Solid State

      TRIM Support:          Yes

      Partition Map Type:          GPT (GUID Partition Table)

      S.M.A.R.T. status:          Verified



      Capacity:          209.7 MB (209,715,200 bytes)

      BSD Name:          disk0s1

      Content:          EFI

    Macintosh HD:

      Capacity:          511.77 GB (511,766,216,704 bytes)

      Available:          230.67 GB (230,673,137,664 bytes)

      Writable:          Yes

      File System:          Journaled HFS+

      BSD Name:          disk0s2

      Mount Point:          /

      Content:          Apple_HFS

      Volume UUID:          3E0254F3-77A2-3B85-81C9-4638D11D8840

  • geirole Level 1 Level 1

    Just an update to what I said above: I called the Microsoft customer service and explained the problem with Office 2011. They gave me a new product key and now it works fine.


    Another application/command that works much faster now is "purge". It used to take 20-30 seconds. Now it finishes in 5 seconds or so.

  • msim20 Level 1 Level 1

    To Rune Jenson - or anybody else who has used Samsung 830 in MB Pro 2009 model -


    Were you able to get it to work eventually?


    I recently purchased the same SSD. Does not work. I am getting ready to send it back - I think the problem is with the Sata Cable shielding - I tried the Aluminum foil method of shielding - some improvement. But it was still unreliable setup.

  • geirole Level 1 Level 1

    Hello again,


    It is weird why it works in some MacBook models and not in others. As you see from the above, I had no problems. Mine is a 17" mid 2009 model (5,2).

    The SSD talks to the Mac at 3 Gbit/sec.

    The MacBooks with problems, are they 15" models? Maybe the internal layout and cabling is different. Is the SATA interface card the same? It would be great to understand what is causing the problem.





  • Rune Jensen Level 1 Level 1

    Nope, I never got it to work. I think the problem is hardware related, maybe the cable shielding. I am still interested in getting a SSD working in my Macbook Pro 5,3 (the 15" model), so please let us know, if you have any luck with any other SSD.


    Does anyone else have a full working SSD in their Macbook Pro 5,3 (the 15" model)?



    Rune Schmidt Jensen