Previous 1 2 Next 16 Replies Latest reply: Mar 29, 2015 8:07 PM by Queenslander_0411
gojiragirl Level 1 Level 1

I just installed the latest version of Microsoft Silverlight on Netflix.  When I try to watch a movie, the screen stays black and there is no spinning icon or anything.  I've tried restarting everything: the browser, Netflix, and the computer.  I've also tried removing and reinstalling.  Any help would be appreciated!


MacBook Pro, Mac OS X (10.6.8)
  • OrangeMarlin Level 5 Level 5
    expertise.peripherals
    Peripherals

    There are a lot of reasons for this.  Just google "Mac silverlight netflix" or search here.

     

    One fix that a lot of people mention is to make sure you're using the discrete video card rather than the integrated Intel HD. 

  • gojiragirl Level 1 Level 1

    Thanks, but I'm not quite sure how to access that or use it to fix my problem.  This is just frustrating because I've had my macbook for 2 years and never had a problem with any of the updates.

  • pjboyle1 Level 1 Level 1

    I'm having the same problem. And as of yet, I've found no fixes or anything helpful. Has anyone else?

  • tatibbot Level 1 Level 1

    Try to download the new silverlight ...i believe its silverlight 5 but before you do this go into your harddrive and then Library and then internet plug-ins and you should have a folder that says silverlight and its the old one delete that and then clear your trash then download the other silverlight open the package file and then install it...it should work then.

  • Ziatron Level 4 Level 4
    expertise.desktops
    Desktops

    Any help would be appreciated!

     

    Buy the DVD.   Zero hassles then.

  • pjboyle1 Level 1 Level 1

    This isn't exactly a fix, but you can just download the firefox Aurora beta. Netflix works there. The problem is with firefox 9. I suppose you could also downgrade to firefox 8. Either would work.

  • Dansyacht Level 4 Level 4

    Hey girl, you didn't say but are you using Firefox to access Netflix?  Firefox 9 and Silverlight 5 do not play well together.

     

    You can use Safari to access Netflix or you can revert to Silverlight 4.  See my previous post on this subject.

  • kaj79 Level 1 Level 1

    I know this is a little late, but I'll post for people who have problems in the future.

     

    I had this exact same problem.  Thanks to Dansyacht, I got an idea.  Maybe the plug-ins were not enabled in Firefox.  Bingo.  I was able to fix it SUPER QUICKLY and now I'm watching Netflix on Firefox!

     

    Solution:

    Go to Firefox Preferences. Click on the "General" tab.  Click on the "Manage Add-ons" on the bottom right.  This will take you to another page called "Add-ons Manager."  Click the tab (on the left side of the screen) titled "Plugins."  Look for the Silverlight Plug-in.  Check to see if Silverlight says "Disabled" on the right side. Click "disabled" which will enable Silverlight.  Bam!  You're done! 

  • myswilouis Level 1 Level 1

    Finally! This did it! I had to create a support community profile JUST to thank you!

    Blessings!

  • korysal Level 1 Level 1

    that was nearly the ticket, thank you.  The only difference I came across was that the Add-ons choice was in tools, not Preferences.  but i see your response was from 2012 so maybe it's changed since then.  either way, it was managing Add-ons that was the key. 

     

    Go to Tools

    click Add-ons

    choose Plug-ins

    look for the one you're dealing with (seems we were all struggling with microsoft sliverlight)

    look to see if active or not (disabled) was in () and the whole plug in was shaded. 

    click at the right to make active.

     

    thank you so much!  that was sooooo aggrivating!!

  • LeahMarie Level 1 Level 1

    THANK YOU SO MUCH!!

  • Binkie the Bee Level 1 Level 1

    If the problem is in Safari, with latest version of Safari and Silverlight downloaded, Open Netflix, go to Safari > Preferences > Security. Check "Allow Plug-ins" and click on Manage Website Settings ... Find Silverlight in left sidebar and select. See Netlix listed in window on right under "Currently Open Websites" Toggle menu to Allow Always. Click Done.

  • hunGaga Level 1 Level 1

    Thank you SO much Binkie the Bee .  You really helped me, simple and to the point. For the past 2 hrs, I checked many websites and read forums, tried to solve it but couldn't. Finally, found yours and it nailed it. 

     

    Last night, I gave up watching netflex or youtube, and created a blog & spent time writing life experience LOL! Thank you, now I can watch NETFLEX and also YOUTUBE (it was aksing me to installe AdobeFlash player).

     

    Thank you again for making me HAPPY !!!

  • Binkie the Bee Level 1 Level 1

    I am happy that you are HAPPY, hunGaga!!!

Previous 1 2 Next