Previous 1 2 3 Next 31 Replies Latest reply: Nov 1, 2015 12:04 PM by mgeorge20
sailing70 Level 1 (0 points)

Hi, I'm new in Logic, downloaded Logic Pro 9 yesterday from App Store, downloaded tonight all additional contents. I interrupted download and restarted one time, Logic seemed to realize that I had already downloaded part of the contents, without no error message .

I've iMac mid 2011 intel core i3 with internal hd 500 gb, the base version.

I tried to search in threads without any result.


Each time I launch Logic, I receive these messages:


EXS24 instrument “Steinway Piano.exs”:

Audio file “Stw ped v1 024.AIF” not found!


(Note: The file “Steinway Piano.exs” is here: /Library/Application Support/Logic/Sampler Instruments/01 Acoustic Pianos. The file “Stw ped v1 024.AIF” instead is not in mi hd.)


EXS24 instrument “Liverpool Bass.exs”:

Audio file “IL Btl Bass bomb 08.aif” not found!


(Note: The file “Liverpool Bass.exs” is here: /Library/Application Support/Logic/Sampler Instruments/02 Bass/02 Electric Bass. The file “IL Btl Bass bomb 08.aif” instead is not in mi hd.)


EXS24 instrument “Seventies Kit.exs”:

Audio file “DC Tit Hat 08.aif” not found!


(Note: The file “Seventies Kit.exs” is here: /Library/Application Support/Logic/Sampler Instruments/03 Drums & Percussion/01 Acoustic Drum Kits. The file “DC Tit Hat 08.aif” instead is not in mi hd.)



If I try to consolidate a project, Logic can't find hundreds audio (.aif) EXS24 files.


I also have the same *.exs files in the Garageband location.

Logic Pro, rel. 9
  • CCTM Level 6 (10,590 points)



    The particular EXS instruments mentioned use samples that are included in the 'Garageband' content (either the main GB elements or as part of the Jampacks).


    Have a look in Library:Application Support:Garageband:Instrument Library:Sampler:Sampler Files. (Liverpool Bass/ Steinway Grand)



    If the files are there, you may have a Spotlight index problem, if not, you may need to download again.




  • sailing70 Level 1 (0 points)

    The files aren't there, I solved the problem by installing again the Garageband Jam Packs. I don't explain what's happened during Logic Pro download and installation, I didn't anything wrong or "customized". But now It works.



  • lokeswari Level 1 (0 points)

    Something similar happened to me with a new install.  All of the missing files (including Steinway Piano, Liverpool Bass, and Seventies Kit) were actually under "Logic Pro & Mainstage Essential Content" and not Garage Band.  If you're having the same problem, re-download those first to save yourself some time:


    Logic Pro > Download Additional Content > Logic Pro & Mainstage Essential Content > Install

  • joek128 Level 1 (0 points)

    lokeswari is exaclty right.  I downloaded Logic Pro & Mainstage Essential Content.  I was still missing some pianos, so downloaded the Logic Pro & Mainstage Additional Content and now all is well. 

  • RYRYMARIMBA Level 1 (5 points)

    I had this exact same problem but I found it was caused by incomplete downloads. I clicked on Logic>download additional content and then selected each package individually and attempted to download them again, I did not click on 'only install new packages' but on 'install'. What I found is that most of them began the download all over again but some of them started half or two thirds into the progress bar suggesting that the download had not completed. If you can find which packages didn't finish it should fix it.

  • HypnotiqRose Level 1 (0 points)

    I was having the same issue. I was missing Sampler Instruments and the Sampler Files. I redownloaded the Essential Content and the Additional Content. The Sampler Instruments are now all accounted for, the but the Sampler Files are still missing. I am missing Orchestral files, so I redownloaded the Orchestra Jam Pack. Still did not work. So I redownloaded the Additional and Essential content again. Still no luck.


    What else can I do? Has anyone figured out how else to find their missing content?

  • Pancenter Level 6 (9,440 points)

    Don't be a passive Apple user, call Apple and complain, users shouldn't have to jump through hoops like this to get a working product.

  • db_3 Level 1 (0 points)

    Same issue here, new Logic 9 install from app store but lots of missing samples from exs files. I managed to fix some by re-downloading packs but I still have some drum sounds which I'm not sure which pack they may be from. The crazy thing is I know for sure that some of these sounds were working at some point and the samples have gone missing over the last day. I'm currently working my way through the packs again but it's taking a very long time even on my fibre connection as there seems to be some bandwidth issue with Apple. Very annoyed!

  • db_3 Level 1 (0 points)

    All missing samples were eventually resolved by re-downloading additional content packs. DL bandwidth improved the following day.

  • bb-15 Level 1 (0 points)

    I am surprised that this disappearing instrument problem is happening with a professional level program like Logic Pro 9; especially when it's produced by Apple.


    A couple of days ago I had several instruments disappear. They included Dark Choir, Hip Hop Strings, Warm String Section, Beatnik Guitar, Heavy Metal Guitar and Tie Dye Lead.

    I couldn't find files for these instruments in the Library. I assumed that the Logic program was combining samples in some way to create the instruments.


    I redownloaded all the Additional Content Packages. The instruments came back. I am keeping my fingers crossed.


    (Logic Pro 9.1.7, OS X 10.8, iMac 2.7 GHz i5)

  • Dr Macca Level 1 (0 points)

    Hi folks,

    yeah I have just discovered the same problem - but this time the problem has come on a new iMac I've just set up, which I used setup assistant to migrate my logic from a BlackBook the other day. I have Logic physical media so might have to do a re-istall. Anyway - details - the reality of this is, and as we say round here, pardon my language,  just f***ing t*ts - what are Apple doing - their downloads don't work and their setup assistant doesn't work. How do we complain to Apple?


    Graham Macca

  • coxorange Level 1 (45 points)

    Hi, I just found this thread where others had a similar problem - though mine is a bit different.

    Maybe someone can help...?

    Many thanks.

  • thatnanothing Level 1 (0 points)

    I have a new imac and new Logic. Same issue. Hangs on trying to load DC tit hat 08.aif and EXS24. Very disappointing for any vendor, but especially  Apple. I keep trying to redownload additional content, but it seems to make no difference.

  • bendikjohnsgard Level 1 (0 points)

    I had pretty much the exact same problem, but I solved it this way:


    • Open Logic Pro 9 > "Download Additional Content" > select all of them > "Install".

              - Press install even though Logic says; "You are about to install one or more already installed items".

                   - Let the download finish (it might take some time), and close all applications.


    • Open Disk Utility > select your harddrive > "Repair disk permissions".


    • Restart your Mac > open Logic Pro 9 > when you now select your instrument / plugin that didn't work it should find the files and work perfectly.



    It was an easy and quick fix and I hope it works for others as well as it did for me.

Previous 1 2 3 Next