2 Replies Latest reply: Jan 13, 2013 12:57 PM by SQL
jim Melo Level 1 Level 1

Hello I'm a newbie to servers so please try to be as basic and gentle as possible. 

I setup  up a Lion Server 10.7.2 on a mac mini and I enabled Open Directory.  This is a server for my small office.  We have 2 iMacs and 2 Macbook Pro's.  I have set up mobile users and mobile log in.  Things were going great until recently so I am not sure what happened.


The problem is only occuring on my personal macbook pro which is even more interesting.  This happens when I am at home or in the office.  I have a dedicated IP address and my own domain name,  firm.xxxxx.com for the server.  Well the router has a dedicated IP address and then I have DHCP set up but the server has a static internal IP address and port forwarding set up on the router for all of the relevant ports and services for when I am out of the office.  I am able to browse the server's shared folders and save documents on the server, open them, etc from within the office and at home on the macbook pro.  As I said, none of the other computers or users have this issue.


My "network account server" in the Users and Groups system's preference of the macbook has the green light.  I am not using Active Directory as I am only in a pure Mac environment.  I am an admin on the server and I have full priveleges on the server. 


Now when my Home Sync does its thing I always get the error "Your home directory did not finish syncing because a problem occured.  Please try again later"  This does not occur when I log into one of the iMacs as myself. 


The logs on the server say:

Dec 27 14:49:51 office AppleFileServer[351]: received message with invalid client_id 4995

Dec 27 14:49:51 office AppleFileServer[351]: received message with invalid client_id 4996

Dec 27 14:52:44 office fseventsd[68]: SLOWDOWN: client 0x7fdeba80a400 (pid 30) sleeping due to too many errors (num usleeps 46221)

Dec 27 14:57:54 office fseventsd[68]: SLOWDOWN: client 0x7fdeba80a400 (pid 30) sleeping due to too many errors (num usleeps 46233)

Dec 27 14:58:11 office mdworker32[76985]: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.


Any ideas?  I have no idea what client_id 4995 or 4996 refer to and I am unable to find any such client_id in Server Admin or workgroup manager.  Although perhaps I don't know how to look. 


I have also been getting some random errors when I try to open a document inside MS word or I try to save a document inside MS word.  Something to the effect that the path file name is incorrect, even though I've used the word dialogue box to open the document and find it on the folder ont he server.  This doesn't always happen and it is not happening today so I can't seem to recreate the error today.  Not sure if that's related but thought I would mention it in case it helps diagnose the issue.


Thanks for any help or suggestions you can offer.



MacBook Pro, Mac OS X (10.7.2)
  • jim Melo Level 1 Level 1

    So I found the solution and thought I would post for others that might be having the same problem.  Although I was authenticated I was not "completely" authenticated to the server.  Why this changed I am not sure.  I started my server after the big 10.7.2 push so no real major releases recently except the cloud.  Anyway, I had to bind my laptop to the server, even though I was logging on to the server and getting the green light.


    Here is how you do this. System Preferences/Users & Groups


    Then Login Options (authenticate likely neccessary)

    Then where it says Network Account Server click on Edit

    Select server and then Open Directory Utility

    Select LDAPv3 and click on the pencil icon

    Select the server again and click on edit

    and now login as the Directory Admin and Bind to the server.  Not sure if I was "unbound" at some point or if this was added as part of some release but since doing this my problem has gone away and I am having no problems home syncing again.

  • SQL Level 1 Level 1

    Excellent. This solved my problem.