7 Replies Latest reply: Sep 9, 2013 9:45 PM by Budijoe
macdudepro Level 1 Level 1 (0 points)

Hey guys!

 

So recently I installed AutoCAD and it was giving me a bit of grief with graphics so I uninstalled it. Upon doing so I've noticed that when I entered Launchpad, going from page to page lagged going back and forth. ALSO, ive noticed that entering Mission Control that it is no longer smooth. The best way I can explain the latter is that everytime I swipe up (4 fingers) the windows don't transition smoothly into the Mission Control screen, rather it just suddenly resizes. Impulsively, I have reinstalled Lion and it (not surprisingly) has not resolved it and now I'm hoping you guys can help!

 

Thanks!


MacBook Pro, Mac OS X (10.7.2), Early 2011 15" i7 2.2GHz
  • softwater Level 5 Level 5 (5,370 points)

    Have a look in Activity Monitor and see if any autocad processes are running. Alternatively, open Terminal.app

    and type (or cut and paste)

     

    launchctl list

     

    to see what launch daemons are running.

  • macdudepro Level 1 Level 1 (0 points)

    I gave that a shot, didn't find anything...

    I've also used Onyx to clear some cache out prior to discovering these problems if that helps. but ive defaulted everything in Onyx since and problems still persist

  • softwater Level 5 Level 5 (5,370 points)

    Best thing I can suggest is to post the output to these commands (paste them into Terminal). Take each at a time, and copy the output into a file and paste here.

     

    1.

    kextstat -kl | awk ' !/apple/ { print $6 $7 } '

     

     

    2.

    sudo launchctl list | sed 1d | awk ' !/0x|apple|com\.vix|edu\.|org\./ { print $3 } '

     

    (you will need to enter an admin password after this, which will be invisible when you type it)

     

    3.

    launchctl list | sed 1d | awk ' !/0x|apple|edu\.|org\./ { print $3 } '

     

     

    4.

    ls -1A {,/}Library/{Ad,Compon,Ex,Fram,In,La,Mail/Bu,P*P,Priv,Qu,Scripti,Ser,Sta}* 2> /dev/null

     

     

    If you have a mobile.me account, be sure to replace your mobile.me email with a dummy (it will be shown in the output)

  • macdudepro Level 1 Level 1 (0 points)

    So I've done as you've suggested (I've sensored my real name and mobile me with ******) and this is the output right after i put in my password and step 3&4

     

    ================================================================================ ===

     

    com.microsoft.office.licensing.helper

    com.google.keystone.daemon

    com.adobe.SwitchBoard

    ******-MacBook-Pro:~ ******$

    ******-MacBook-Pro:~ ******$ launchctl list | sed 1d | awk ' !/0x|apple|edu\.|org\./ { print $3 } '

    com.google.keystone.root.agent

    com.adobe.CS5ServiceManager

    com.google.Chrome.framework.service_process/Users/******/Library/Application_Sup port/Google/Chrome

    com.divx.agent.postinstall

    ******-MacBook-Pro:~ ******$ ls -1A {,/}Library/{Ad,Compon,Ex,Fram,In,La,Mail/Bu,P*P,Priv,Qu,Scripti,Ser,Sta}* 2> /dev/null

    /Library/Components:

     

     

    /Library/Extensions:

     

     

    /Library/Frameworks:

    AEProfiling.framework

    AERegistration.framework

    Adlm.framework

    Adobe AIR.framework

    ApplicationEnhancer.framework

    AudioMixEngine.framework

    DivX Toolkit.framework

    EWSMac.framework

    NyxAudioAnalysis.framework

    PluginManager.framework

    XSKey.framework

    iLifeFaceRecognition.framework

    iLifeKit.framework

    iLifePageLayout.framework

    iLifeSQLAccess.framework

    iLifeSlideshow.framework

     

     

    /Library/Input Methods:

     

     

    /Library/Internet Plug-Ins:

    AdobePDFViewer.plugin

    DivXBrowserPlugin.plugin

    Flash Player.plugin

    JavaAppletPlugin.plugin

    OVSHelper.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin

    SharePointBrowserPlugin.plugin

    SharePointWebKitPlugin.webplugin

    flashplayer.xpt

    iPhotoPhotocast.plugin

    nsIQTScriptablePlugin.xpt

     

     

    /Library/LaunchAgents:

    com.adobe.AAM.Updater-1.0.plist

    com.adobe.CS5ServiceManager.plist

    com.google.keystone.agent.plist

     

     

    /Library/LaunchDaemons:

    com.adobe.SwitchBoard.plist

    com.apple.aelwriter.plist

    com.apple.remotepairtool.plist

    com.google.keystone.daemon.plist

    com.microsoft.office.licensing.helper.plist

     

     

    /Library/PreferencePanes:

    Application Enhancer.prefPane

    DivX.prefPane

    Flash Player.prefPane

    Growl.prefPane

     

     

    /Library/PrivilegedHelperTools:

    com.microsoft.office.licensing.helper

     

     

    /Library/QuickLook:

    iWork.qlgenerator

     

     

    /Library/QuickTime:

    AC3 Codec.component

    AppleIntermediateCodec.component

    AppleMPEG2Codec.component

    DivX Decoder.component

    DivX Encoder.component

     

     

    /Library/ScriptingAdditions:

    Adobe Unit Types.osax

     

     

    /Library/Server:

    Mail

     

     

    /Library/StartupItems:

     

     

    Library/Address Book Plug-Ins:

    SkypeABDialer.bundle

    SkypeABSMS.bundle

     

     

    Library/Frameworks:

    EWSMac.framework

     

     

    Library/Input Methods:

    .localized

     

     

    Library/Internet Plug-Ins:

     

     

    Library/LaunchAgents:

    com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.29E1C53B-0B3A-446A-B721-00F 86D6CF5CF.plist

    com.apple.CSConfigDotMacCert-******@me.com-SharedServices.Agent.plist

    com.divx.agent.postinstall.plist

    com.google.Chrome.framework.plist

     

     

    Library/PreferencePanes:

    SwitchResX.prefPane

     

     

    Library/ScriptingAdditions:

    SwitchResX Menu.osax

    ================================================================================ ===

  • softwater Level 5 Level 5 (5,370 points)

    Have a look at that SwitchResX app. Return any prefs to default. Disable any scripts (if you've set any up). Better still, remove it completely.

  • MaxDerBlau Level 1 Level 1 (0 points)

    Hey you, and others,

     

    I had the same problems (mission control not running smooth) and read this hypothesis that AutoCAD might be to blame. I have a macbook pro, i7 processor, running mountain lion (installed off the app store, no disc), and a few of heavy graphic programs and AutoCAD.

     

    My solution: I simply opened and quit AutoCAD and voilà! The problem has been resolved ever since. Hopefully it will stay this way.

     

    To me its like if my computer was stuck in the "AutoCAD mode". I hadn't used autocad since this problem appeared, which is probably when it first appeared. I had been using autocad long before and didn't have that problem ever. And then it just started one day. Maybe my autocad hadn't shut down properly last time i had used it?

     

    Hope this is the simple solution to your, and others, problem!

  • Budijoe Level 1 Level 1 (0 points)

    Hi Max.

    Your solution work like a charm.

    In my case, not only Launchpad and Mission Control which laggy, but the Dock animation as well.

    I can confirm this is work for me. Others who have the same issue should try it.

    Thank you.