5 Replies Latest reply: Dec 29, 2011 1:43 PM by Frank Caggiano
BobCotter Level 1 Level 1 (10 points)

Sometimes I err in choosing the project to import to as there are a few photos that do not belong in that particular project. To correct this, I drag and drop the wrong photos to the correct project. That system does not work consistently. Sometimes it does the move, and sometimes it does a copy. I'm not holding down any modifier keys such as the command or option key when dragging. It is frustrating, and for some photos, they simply won't move.

 

Operating System - 10.7.2

Aperture version - 3.2.2

 

Any ideas other than being more careful when I import a number of camera shots?


Aperture 3, Mac OS X (10.7)
  • Frank Caggiano Level 7 Level 7 (25,720 points)

    If you drag an image out of a project into another project and don't have the option key held down then Aperture will always do move. 

     

    One thing to look for if you're doing a move when you drag to the new project the project will highlight, if you are doing a copy the project will highlight AND you will see a green plus sign. You can observe this by dragging without the option key and while hovering over the new project press the option key, you'll see the  green plus sign.

     

    If you see other behavior you should start with Aperture 3: Troubleshooting Basics

     

     

    regards

  • Kirby Krieger Level 6 Level 6 (12,510 points)

    Weren't there reports of this behavior changing when an Image that had been posted to an on-line site was dragged and dropped?

     

    If not, ignore.

  • Frank Caggiano Level 7 Level 7 (25,720 points)

    That's true, if an image was sent to flickr, facebook or mobileme then the original in the project can't be moved only copied.

     

    But as the OP was discussing this happen on newly imported images I don't think it will apply. But it is something to look out for, thanks.

  • BobCotter Level 1 Level 1 (10 points)

    Thank Frank and Kirby...

     

    I missed that point in my OP ... thus the "randomness". I had sent the files to Facebook after import as all the photos fit the subject at that time. Then, afterwards, I wanted to move the files from the Project where they did not really belong to another project and that is when they would not move... so, the answer seems to be the problem is a result of sending them to FB.

     

    I do know about the difference between the highlight and the highlight with the + sign. It is interesting in this case that the action generates highlight only, but does do a copy. That is likely again because of the FB thing.

     

    So, I can copy the images, but I guess the originals are simply stuck in the wrong project.

     

    Would removing them from FB make any difference?

  • Frank Caggiano Level 7 Level 7 (25,720 points)

    If you remove them from FB and the FB album in Aperture that should allow you to move the images from the project. I honestly can't say as I only tried this once just to see what it did.

     

    And give the thanks to Kirby, he remember this, totally slipped my mind.

     

    regards