1 Reply Latest reply: Dec 29, 2011 3:49 PM by LaPastenague
mdavenport Level 1 Level 1 (0 points)

I am trying to setup file sharing to my time capsule over the internet but having problems getting this working.  I have my TC plugged into the my Virgin media router/modem and on the airport screen I can see my external ip address.

 

All my internal clients get a 10. Address from dhcp but share one Internet facing ip address.

 

On the disks tab I have enabled file sharing, with a disk password and have tried having both Share disk over WAN both on and off - with no joy..

 

To test this I am using FileBrowser app on my iPhone (available in the app store) and have created a new machine with the following information:-

 

Address: my external ip address assigned by virgin media \\[hostname]

Username:

Password: as assigned to the disk setup on the TC

 

I then disconnect my iPhone from my wifi so I am not part of my internal network.  I have a 3G connection but when I try to connect the app error with Connection Failed, windows SMB may not be anabled,

 

I have setup the same connection but for the internal ip address \\10.0.0.1 and this works fine without issue so figure this must be something blocked on my TC or need port forwarding setting up.

 

I then tried to setup port forwarding for the following ports:-

 

139

445

 

These were the ports configured for both public and private ip addresses (private set to 10.0.0.1) but I get an error saying "the public tcp port conflicts with a file sharing port on the base station.  Disable file sharing or choose a different port".  The only way I can stop this to disable file sharing which stops me access the disk all together.

 

Can anyone offer any ideas on how to get this working.  I suspect that I need port forwarding setting up but when file sharing is enable it won,t let me setup port forwarding???

 

Hope you can help.

 

Thanks

Mark