Previous 1 2 Next 16 Replies Latest reply: Mar 27, 2014 8:41 AM by Stanley22
Robbie Byrne Level 1 (5 points)

When I begin to write a text message my iPhone indicates I am using iMessage. I send it and the text is blue. When I look at the message ten minutes later it has turned green. So now I am being charged for a message I was told I was sending for free. This is happening on 3G and Wifi. What should I do?

I am using the latest version of iOS.

  • pvonk Level 6 (13,722 points)

    If the recipient's device is not connected to wifi or data, the message changes to SMS.

  • The Huntress Level 4 (3,590 points)

    To avoid being charged for an SMS you can disable the Send As SMS in Settings>Messages>Send As SMS and turn OFF

  • Allan Sampson Level 10 (123,405 points)

    Settings > Messages > Send as SMS > Off.

     

    When iMessage is not available, it will not be sent as an SMS.

  • Robbie Byrne Level 1 (5 points)

    I cannot be 100 percent certain that the recipient is connected to Wifi or Data. Though I would be very surprised if this is always the case. Either way the phone should not be telling me it's an iMessage when it's not. The phone tells me I am sending an iMessage, the text remains in blue after the message is sent. But a few minutes later turns green and I am charged. This is extremely misleading.

  • The Huntress Level 4 (3,590 points)

    This article may help you: http://support.apple.com/kb/HT3529

  • pvonk Level 6 (13,722 points)

    From a review I found on the web...

     

    If you send a message to a fellow iMessage user who has their data switched off, the phone attempts to send it via the data channel at first, but if it can’t get through after five minutes or so, the message turns green and is sent via the traditional SMS channel instead.

    This could mean that you’re charged for sending an SMS message that you thought you were sending for “free” via iMessage – there’s no prompt to ask whether you want to send via SMS, it just does it automatically.

  • Robbie Byrne Level 1 (5 points)

    Thats very disappointing.

     

    We should get a prompt if we are going to be charged after been originally told it was free.

  • Allan Sampson Level 10 (123,405 points)

    Do this as already provided and then you don't have to be concerned about it. If the message cannot be sent as an iMessage or after being sent cannot be received as an iMessage by the recipient, there will be a red indicator on the message indicating it could not be sent. It won't be sent as an SMS under any circumstances.

     

    Settings > Messages > Send as SMS > Off.

     

    When iMessage is not available, it will not be sent as an SMS.

  • Robbie Byrne Level 1 (5 points)

    So everytime I want to send a SMS I will Settings > Messages > Send as SMS > On. When I want to send an iMessage I will Settings > Messages > Send as SMS > Off. Thanks for your help.

  • Allan Sampson Level 10 (123,405 points)

    No.

     

    The option at Settings > Messages > Send as SMS > Off means an iMessage will not be sent as an SMS if iMessage is not available.

     

    If the message cannot be sent as an iMessage or after being sent cannot be received as an iMessage by the recipient, there will be a red indicator on the message indicating it could not be sent. It won't be sent as an SMS under any circumstances - for an iMessage ONLY.

     

    When sending a message or SMS to a non-iPhone user, it will be sent as an SMS regardless the setting at Settings > Messages > Send as SMS, which is for iMessages ONLY when iMessage is not available for you as the sender or for the recipient for whatever reason.

  • Californiasunshine Level 1 (0 points)

    I have the exact same problem, which makes me furious! I absolutely don't want to turn text messages off the whole time, so I can make sure it is really sent with imessage, because I text a lot of people who don't have an IPhone and switching Imessage off and on is way too anoying! Apple should definitely fix this problem quickly!

    That's why I went back to using Whatsapp the whole time and no Imessage at all. =)

  • Allan Sampson Level 10 (123,405 points)

    You do not have to turn text messages off the whole time.

     

    The Send as SMS on/off selection for iMessages does not affect your ability to exchange SMS/MMS with non-iPhones. When Send as SMS is off for your iMessages setting, if an iMessage cannot be sent for whatever reason the message will not be sent as an SMS - it won't be sent. This has nothing to do with being able to send an SMS to a non-iPhone.

  • Californiasunshine Level 1 (0 points)

    Really? That's great, I had no idea. I'll probably stick to whatsapp anyways... but thanks for the remark!

  • Nerock Level 1 (0 points)

    I turned the option to off - but sometimes when my connection is bad, iMessage is still sending as SMS! So no red indicator, the message is sent as SMS automatically!

     

    Is this an iOS 6 bug? With iOS 5 I never had this problem!

     

    I have the problems on my iPhone 4 and iPhone 3GS.

Previous 1 2 Next