4 Replies Latest reply: Sep 7, 2013 1:56 AM by 7stud
JustAMan Level 1 (0 points)

I have an Apple tv2(mc572Ll/a) running version 4.4.4 of the software, connecting to an older Sharp Aquos LCD-26d6u TVvia a regular HDMI cable.

I used to be able to watch a rented movie until my onsitel technician/ teenager adjusted something.

Now when the preview plays the sound works. When a video is displayed using AirPlay from the iPhone the sound works.

But when the HD movie plays the message "an incompatible audio signal has been received. Check the output device settings" and there is no sound.

When I connect this to a newer HDTV the movie sound works.

Any suggestions on what Apple tv or tv settings to use to get the sound back (other than upgrading my technician/teenager/tv)?


AppleTV 2
  • Winston Churchill Level 10 (95,576 points)

    Try adjusting the audio out and/or Dolby digital settings (settings > audio & video)

  • JustAMan Level 1 (0 points)

    Thanks Winston-Dolby digital settings was the answer!

  • byronmiller Level 1 (0 points)

    Thanks this fixed my issues too even after months of me not getting it to work & calling apple a few time :-)

  • 7stud Level 1 (25 points)

    Thanks!  I changed the Dolby setting from On to Auto, and the sound started working for Netflix TV shows.  Before I was getting the message:

     

         Incompatible audio format received check output device settings

     

    and there was no sound. 

     

    The Settings are accessed through Apple TV.   When you have Apple TV on, and you see all the colored rectangles for Netflix, huluplus, HBO etc., (which can be accessed by repeatedly hitting the Menu button on the remote), the top row shows:

     

       Movies   TV Shows  Music  Computers  Settings

     

    Use the 4 way controller to choose Settings, then press the button in the center of the 4 way controller to select Settings.  Then select Audio Video.  Then scroll down to Dolby Digital.  When you are on Dolby Digital and you push the button in the center of the 4 way controller, the setting will change.  I changed the Dolby Digital setting to Auto.