Previous 1 2 Next 19 Replies Latest reply: Sep 21, 2012 6:02 AM by Kirk Wedge
judsonfromrichmond Level 1 Level 1 (0 points)

I continue to get a message from Ical saying "ICal can't log into your "Google" account because your password may be incorrect".  I have gone to preference in ICal and checked the passwords as well as rechecking Google login passwords.  Everything is correct.  I have rebooted numerous times and always get this message when ICal is starts.

 

How can I fix this problem.


MacBook Air, Mac OS X (10.7.2)
  • _quagmire Level 1 Level 1 (5 points)

    Same problem here, any ideas???

     

    Tried to remove all Google calendar entries altogether as I no longer need them, but am unable since I can sync with iCloud.  Went manually through iCal prefs and also via ~Library/Calendars.  No luck.  My gmail password hasn't changed but I re-entered anyway.

     

    Please help.

  • dwb Level 7 Level 7 (21,805 points)

    Is this happening all the time or specifically after waking up your computer? (For that matter have you ever been able to sync your Google calendar?) I ask for a couple reasons. First, iCal isn't giving me any trouble with my Google calendar. Second, the error message about a bad password is actually generic. If your computer fails to connect for any reason this is the message you are likely to get.

  • judsonfromrichmond Level 1 Level 1 (0 points)

    This happens all the time.  I just entered a Test entry on my google calendar.  I clicked on my ICal and the error message returned and the Test entry failed to show up.

     

    Any thoughts?  Thanks for your help.

  • dwb Level 7 Level 7 (21,805 points)

    Open iCal preferences and delete the google account. Then enter it again. That's the only thing I can think of.

  • judsonfromrichmond Level 1 Level 1 (0 points)

    Ok.  Here's the answer.  Google has a new two step login.  You need to go into your google setting and cancel this two step process. (If you are logging into google from outside your computer it will ask you for a security code.  You need to cancel this process).

     

    Evidently, because ICal is trying to login from outside your normal site, the two step login prevents the connection.  (Go Figure).  Anyway, just go into google settings and terminate the two step login and everythihg will sync with ICal.

     

    Let me know if this helps.

     

    Best,

     

    J

  • judsonfromrichmond Level 1 Level 1 (0 points)

    Ok.  Here's the answer.  Google has a new two step login.  You need to go into your google setting and cancel this two step process. (If you are logging into google from outside your computer it will ask you for a security code.  You need to cancel this process).

     

    Evidently, because ICal is trying to login from outside your normal site, the two step login prevents the connection.  (Go Figure).  Anyway, just go into google settings and terminate the two step login and everythihg will sync with ICal.

     

    Let me know if this helps.

     

    Best,

     

    J

  • lupus247 Level 1 Level 1 (10 points)

    Actually there's a better way. If you have 2-factor authentication turned on, leave it on! You're much better off, especially if a goodly proportion of your life inhabits the Googleverse. A badguy crashes into that, you are seriously boinked (see for example James Fallows on the topic).

     

    Instead, generate an application-specific password for iCal:

     

    1. Follow the directions for setting up iCal to sync with Google up until the point where you're going to enter your Google password -- but don't yet!
    2. Switch to your favorite browser, and sign into Google as you normally do.
    3. Click your name in the upper right, and click "Account settings" from the pulldown that appears.
    4. Under "Security", "2-step verification" should be "on". (If it isn't, then we're on the wrong track entirely, and you should just stop here to try something else.)
    5. Beside"2-step verification", click the "Edit" link. That will bring you to a page that includes an "Application-specific passwords" heading.
    6. Click "Manage application-specific passwords", authenticate (again), and (if you like) read up on them to your heart's content -- there's even a video.
    7. Enter a prompt like "For iCal on my Air" in the box and click the "Generate Password" button.
    8. When the box appears with the new password (on my browser, it's yellow), select and copy the nonsense text that has been generated. Don't worry about copying the spaces too, they're not significant.
    9. Now, back in iCal Preferences | Accounts | +, paste the password into the box. That will login successfully, and away you go!

     

    Thanks to Judson for the hint about 2-step verification, I was driving myself crazy trying to figure this out and your suggestion to turn it off is what made the lightbulb come on!

  • judsonfromrichmond Level 1 Level 1 (0 points)

    Works like a charm Lupus.  I turned 2 Step back on and went through your sets.  Very NICE!

  • lupus247 Level 1 Level 1 (10 points)

    Now if someone can just figure out how to tell Google that they need to put this on the page of directions for CalendarDAV -- grrr!

  • fknandrew Level 1 Level 1 (0 points)

    Correct answer didnt work for me.  I created a 2-step verificaiton process got the new password but same result.

     

    At first I had no problems.  Problems came out when I changed my google password.

  • Mahoggin Level 1 Level 1 (0 points)

    fk,

     

    Did you find a resolution?  Had same issue after password change and used Google's instructions for iCal 5.x here to resolve it:  http://support.google.com/calendar/bin/answer.py?hl=en&answer=99358#ical

  • Kvantti Level 1 Level 1 (0 points)

    This was driving me nuts, but I managed to fix it. Nowhere does it say that:

     

    You have to delete your Gmail account from under the iCal Accounts tab and recreate it again using the application specific password.

     

    Hope that helps!

  • gabe.g Level 1 Level 1 (0 points)

    This helped me! Thanks!

  • help me help me help me please Level 1 Level 1 (0 points)

    Thanks Gabe.g   I had created my account in Mail, contacts and calendars.  When I deleted the account in iCal and then recreated it using an application specific password it seems to have fixed the issue.  lets hope it sticks... what a pain!

    Kvantti wrote:

     

    This was driving me nuts, but I managed to fix it. Nowhere does it say that:

     

    You have to delete your Gmail account from under the iCal Accounts tab and recreate it again using the application specific password.

     

    Hope that helps!

Previous 1 2 Next