9 Replies Latest reply: Jun 27, 2014 7:11 PM by Loner T
CaseyKT Level 1 Level 1 (0 points)

I have an external hard drive that i was using last week to back up iphoto, now can't be mounted.  I have gone into disk utility and both verified and repaired the drive but it won't let me mount it. I am using Mac OSX 10.7.2. 

 

I am not sure what else to do without reformatting the drive and losing all the data.


AppleTV 2, Mac OS X (10.6.8)
  • CaseyKT Level 1 Level 1 (0 points)

    Hi All,

     

    Lot's of people are looking but no replies yet!!

     

    I hope someone can provide me with some guidance on how to mount the device, and if not, what can i do with the external drive to ensure I get the data from it.  Is it possible to copy it from the external drive, through disk utility to my iMac, or can i take it somewhere to be recovered?

     

    Thanks.

  • CaseyKT Level 1 Level 1 (0 points)

    Is there any way to recover the data on a damaged external hard drive that won't mount?

  • lbernstein821 Level 1 Level 1 (0 points)

    Hi Casey.  I have the same problem.  My external hd, formated for mac os journaled, used exclusively as a time machine backup drive will not mount.  The drive is visable in disk utility and verifys and repairs ok.  For reasons unknown the drive will not mount.  I tried the drive on two other macs and found the same result, appears in disk utility and will not mount.

     

    Did you find a solution?

  • CaseyKT Level 1 Level 1 (0 points)

    I never found a direct solution...I was able to copy the bulk of the contents of the drive to my iMac using disk utility.  From there I was able to check and see what I was able to recover on my own and luckily the bulk of the data was there.  I did lose some info, but not the important stuff, my iphoto library was there.   If this had not worked I was going to go to a disk recover centre and pay a lot of money to them to recover all the lost data for me.

     

    after the data was recovered I was able to reformat the hard drive and it has been working fine ever since, I just don't trust any important data back ups on that one.

  • lbernstein821 Level 1 Level 1 (0 points)

    Thanks.  Appreciate the quick response. 

     

    Happy Thanksgiving, 

    Larry from Miami

  • FredNashville Level 1 Level 1 (0 points)

    I have the same problem disk repair was run, but the drive partition will not mount.

  • Sjorsbob Level 1 Level 1 (0 points)

    How did you copy the "bulk of contents" from this hard drive?

     

    i'm experiencing the same problem.

  • minia623 Level 1 Level 1 (0 points)

    I also am having the same problem and would like to copy any contents possible from the hard drive through disk utility. How did you do that? Thanks for your help!

  • Loner T Level 5 Level 5 (7,290 points)

    One option that I have seen work in some cases, is to create an image (.dmg) from the disk using Disk Utility, instead of trying to mounting it. Unix dd command can be an option, which is available in MAC OS X Terminal.

     

    If the drive is damaged at hardware level, YMMV.

     

    You can also search for HFS+ filesystem corruption issues if you need details of possible issues in your favorite search engine.