3 Replies Latest reply: Nov 5, 2012 11:17 AM by Vero-D
m.c.popester Level 1 Level 1 (0 points)

When I type google.com into the URL box of Firefox or Safari on my 2008 Macbook, I get atumoatically redirected to a Yahoo website with the following URL - http://developer.yahoo.com/yql/console/

I can still search in the Google search box in the top right, but I get similarly redirected if I search for Google and click on the Google link.


I was having a similar problem yesterday trying to get to ESPN's website.  Every time I clicked on an ESPN link or typed in the URL I got redirected to a website called Ooyala.  Now I'm not having this problem.  I downloaded all new updates a few days ago, and am currently scanning my computer (I have Sophos Anti-Virus software, not sure how good it is).  I expect that I have some sort of malware, but I know next to nothing about computers.


Can anyone help with this?

MacBook, Mac OS X (10.5.8)
  • Seaspider1 Level 1 Level 1 (0 points)

    I too was having this issue recently.  I decided to look into it and discovered that www.google.com and all of the search results accessed through using a google search engine toolbar were currupt.  I believe I solved this problem by updating my firmware of my router. 


    Type in your IP address in your Address Bar (search using Yahoo what your default IP router address is if you haven't changed it since you got it.)  You'll then need to navigate to your router's website (ex: I search Cisco and Linksys and found mine).


    Most logins to the router are

    Name: admin

    Password: password


    You will then download a .bin file and go to your administrator page in your router's control panel and go to Firmware Upgrade.  Click the "find file" (or whatever it says) and click upgrade.  This worked for me.


    If this doesn't solve it, reset the router to it's default settings by either using it's control panel or holding the reset button on the back of it in for several seconds.  This will reset any port forwarding you may have set up as well as your Wifi password.


    Hope this helps,


  • GTrotter4 Level 1 Level 1 (5 points)

    updating my routers firmware fixed my yql console forwarding problem. Thanks!

  • Vero-D Level 1 Level 1 (0 points)



    I have the same problem. I follow every step but get stuck in "updating my router firmware". I have a motorola router with AT&T. Once I get to my router's website I don't see anyware a tab or an option for "Firmware". Any tips?


    My problem is that ii'm being redirected at anytime, it can be from a bookmark, from typing on the address bar, form a research, it doesn't matter but it is getting annoying. I will appreciate any help.