7 Replies Latest reply: Oct 22, 2013 5:18 PM by mhamilton_
Lucas Holt Level 1 (10 points)

I'm running Mac OS 10.7.2.  It was an upgrade install from Snow Leopard.  Several times a day, I am unable to resolve any hosts via DNS.  Tried different DNS servers. Release and renew the DHCP release sometimes fixes it.  ping always works with IPs. 


I've tried flushing the dns cache using this command: dscacheutil -flushcache


My network setup is a bit pecular in that I have a switch then a network run to a Airport Extreme wireless router (but using wired connection) which is in bridge mode then a netscreen firewall that gives out DHCP leases.


Changing the DNS servers doesn't seem to help.  I've tried my ISPs, Google, OpenDNS and even running one on a system here. Another system shows some strange ARP traffic where the system thinks the Airport router and the Mac Pro have the same IP address even though they don't (airport is hard coded below the DHCP range) and the MAC addresses aren't even close to identical.  I've tested the network cables with a cable tester and they all test good. 


I don't have any problems with other computers including another Mac, a Windows based PC and a BSD laptop so I suspect something with the Mac Pro.


I've read online that there have been other reports of DNS lookup problems on upgrades from Snow Leopard, but no resolutions.  I'm sure it's possible that it's some other device on the network but I'm at a loss on what to try next.  Any ideas would be greatly appreciated.

Mac Pro, Mac OS X (10.7.2), First Gen 2.0Ghz Xeon (2x2) 5GB RAM