7 Replies Latest reply: Apr 11, 2012 10:46 AM by ricardoricardo
LaurenTaylorr Level 1 Level 1 (0 points)

I just got an iPhone through Verizon today, and when I send text messages, some people see the messages from my email address (my apple id) instead of my phone number or my contact name. I went into my messaging settings and made sure the iMessage was turned on and the SMS was on, and the send read receipts was turned on. under Messages>Recieve at; it tells me i have two addresses where I can be reached for messages at, one being my Apple ID email address, and the other being my phone number. How can I make sure my iMessages and text messages are coming from my cell phone number or my contact name rather than my email address?


iPhone 4S