Previous 1 2 3 4 5 Next 62 Replies Latest reply: Oct 15, 2014 7:17 AM by ClaireJo Go to original post
  • techcafe Level 1 Level 1 (20 points)

    your solution seems to have worked, so far. i just hope it persists across reboots. Apple engineers BREAK THINGS all the time, it's incredibly annoying.

  • Mokoni Level 1 Level 1 (0 points)

    At least you can get yours -to- work.

  • zegeli Level 1 Level 1 (0 points)

    Hey Man,


    I am with you on this topic, I am having a lot of problems with this and I just Googled the issue and saw this post.


    I work a lot on Skype and I write fast, my work requires a lot of typing through out the day, I am constantly getting this CAPS issues, it looked like CAPS button either not pressed or it gets activated a bit late so that insted of where I want CAPS I get it somewhere else in the text.


    First I blamed myself, I thought I am getting rusty or something but then when I started testing the buttom it is not functioning properly, on every 5 clicks it is missing 1 or 2. This is a 3 months old mac air so its very clean and new.


    It is really affecting my work since constantly I have to go back and edit my text.


    Some people advised to adapt this buts its been 3 months and there is no way you can adapt to an issue that does not have a clear pattern, so since this is a random issue adapting to it is not an issue.


    I am not sure how to solve this issue so please if someone who has the same issue and solved it let me know.


    P.S: I respect the Apple community taking their time to help people here, you guys are awsome, and without you life would be harder for all Apple users but more and more I am realising that there are bunch of Apple funboys here (the pattern is mostly level 5 and above) jumping on every compaint and blindly trying to defend Apple by getting aggrasive and all. They almost take these complaints personal and get defensive right away. Not sure if they are being paid by Apple to do this but at times this is getting very annoying. Almost every discussion i engage someone Fanboy gets all agrasive blaming users for blaming Apple (Almost like hey this is Apple, apple cannot have problems, who do you think you are critisizing its products). Every software and harware has its problems and we as consumers know that even the best and the most expensive brands have issues and errors and when that happens users who paid a lot of money gets upset and write their frustrations, this is super normal, this is human nature, thats why companies have PR departments.


    I just want to tell them relax unles they are being paid for this, Not sure why you guys take it so serious, Apple might have defective products too, none of us are perfect.

  • zegeli Level 1 Level 1 (0 points)

    Hey Basham,


    I just did what you said and looks like its working now, I am super exited right now, its only been 5 minutes so hope is not a placebo affect but all of a sudden the button become more sensitive and responsive, before it was skipping now it presses and functions every time.


    For now looks like the problem is solved.








    So, I've been searching for an answer to this forever, and I seem to have found one (though I haven't restarted my computer yet, so fingers crossed).


    1.  System Preferences > Keyboard > Modifier Keys

    2.  Click on Caps Lock and set it to No Action

    3.  Make sure the key is no longer working (I actually exited system prefs and reopened)

    4.  Click on it again and set it back to Caps Lock


    Voila!  Hope it worked for you as well!  I'm so happy it doesn't require some hack!  Still, though, shame on apple.

  • specklepilot Level 1 Level 1 (0 points)

    Brilliant!  That actually works. 


    I am so relieved. I have lost count of the amount of time I have wasted typing what i intende were CAPS, only to find that the caps lock key had not responded. This will save me hours in the coming years!  I agree entirely with 'shame on Apple'.  It's shocking that they think they have the right to impose their will on people like this.

  • specklepilot Level 1 Level 1 (0 points)

    It's just a shame you have to go to Preferences to do this procedure every morning.  It's like going back to the dark ages!  Apple gives you thousands of Preferences that you're never gloing to need and have no idea what most of them mean anyway, and something as basic as this, which obviously doesn't suit most people at all, they fail to give you control opver.  It's so silly.

  • zegeli Level 1 Level 1 (0 points)

    I agree,


    I thought I solved this once and for all from references but looks like I have to constantly do this everyday to solve the problem, not sure why I think after the computer hybernates or something the settings automatically changes back again to the buggy one. Its sad that I have to deal with this every day. It is really affecting my work.

  • zegeli Level 1 Level 1 (0 points)

    Hi All,


    This issue is really really affecting my work and my typing so I did some testing on my Mac Air 2013, here is what I found after playing with it a bit. Caps button is not functioning as it should be by default (This is how my computer came out of the box), this means if I keep clicking on the button constantly out of every 10 click I get 2 to 3 approximate misses, meaning clicking on Caps button I get random skips.


    There is a short term solution for this, If I go to "System preferences" ----> Keyboard ------> Modifier Keys and turn off and on Caps lock key (Click on No action save and then turn it on again) all of a sudden It starts working perfect. When I do the same testing I dont get any skips on Caps anymore. Caps button gets very responsive. This somehow gets messed up I believe after hibernation though. So you need to do this constantly to be able to solve the issue.


    Now what is the problem here? Why is my Caps lock not working correct by default and why do I have to constantly fix it manually? If anyone found a permanent solution for this please let me know.


    I find this issue very wiered and confusing, This issue basically came with the computer by default. Please share your knowledge on this issue.



  • Al_ofthe_North Level 1 Level 1 (0 points)

    Hi Zegeli


    If you read back through the comments you will see this is "a feature not a bug". To enable caps by pressing the caps lock you need to hold the key down for a moment, a 'long press' rather than just a tap -this is supposed to be to guard against accidental pressing. They make it this way because most people learn to type capitals by using the shift key (hold shift while typing the letter you want) -the caps lock key is only supposed to be used   to 'permanently' turn on caps. But some ppl, like me, who taught themselves to type, use the caps lock key "inefficiently" by switching it on and off repeatedly, rather than just holding down shift when needed.


    As you say, this setting can be changed, but it resets after shut down or hibernation. You can write a script to run on start up, which automatically retweaks the settings in a second. You might be able to find such an AppleScript by googling for it. I lost my copy.



  • MartinJSteven Level 1 Level 1 (0 points)

    Third-party software required

    You'll need to download and install the following two files first. They're here on my Dropbox for you, in case the original pages go down at any point.


    Key Remap 4 MacBook and PC Keyboard Hack


    When you've installed them both you'll need to reboot your Mac.




    1) Go into System Preferences -> Keyboard, click on Modifier Keys… and changeCaps Lock Key to No Action.



    2) Repeat for each keyboard, then click on OK and Show All

    3) Click on PC Keyboard Hack in the Other section at the bottom of System Preferences


    4) Make sure the Setting pane looks like this, with Change Caps Lock checked and the keycode set to 110



    5) Click on "Show All" at the top, then go into KeyRemap4MacBook, again located in the Other section


    6) Scroll down till you find the entry that reads For PC Users

    7) Click on the right arrow to show the contents and, inside this, open up Change PC Application Key and make sure the option that reads Application Key to CapsLock is checked, like this :-


    8) Close preferences.  That was easy, right ?
  • Rysz Level 6 Level 6 (8,010 points)

    The caps lock function on your computer is designed to reduce accidental activation. You must press and hold down the key slightly longer to activate the caps lock function.


    Check your System Preferences for Keyboard and Accessibility settings.


    Take your Mac to an Apple Genius to have it tested.

  • GrandStrateguerre Level 1 Level 1 (5 points)

    Rysz you don't understand. They're nothing under Accessibility settings for the caps lock key. The caps locks key  have a delay by default and it can't be modified except using a bug explained above or the 3rd party software posted by MartinJSteven. Please read the thread before posting.

  • Rysz Level 6 Level 6 (8,010 points)

    I could have sworn I'm the one who wrote:


    "The caps lock function on your computer is designed to reduce accidental activation. You must press and hold down the key slightly longer to activate the caps lock function."


    For touch typists that "slighly longer" delay is unintuitive and slows them down. I get it. However, if the caps key is not working when held down "slightly longer," then the issue is elsewhere. The poster that I responded to, did not complain specifically about the delay, but about the cops key not working "as designed."

  • sebbiep Level 1 Level 1 (0 points)

    Thanks Basham, works like a treat!

  • MartinJSteven Level 1 Level 1 (0 points)

    @sebbiep Basham's fix does work like a treat.  Until you reboot...


    You can only make it work permanently by using the third party software solution unfortunately.