Previous 1 2 Next 27 Replies Latest reply: May 11, 2015 4:33 AM by pisur2
bennett76 Level 1 (0 points)



So like everyone else as it seems, I am have a few peculiarities with Match. Having resolved most (by restoring all of my devices!) I am just now down to more of an irritation but just wondered if it was happening to anyone else.


When I sync my iPhone, for some reason in the "Music" Folder under my phone in iTunes, it says that there are a number of tracks but they show up as still pending sync and greyed out (picture attached - ignore the Voice Memo's as I expect to see those);


Screen Shot 2012-01-06 at 12.28.13.png


When I go to my phone and turn off "Show all Music" there is nothing on the phone so I'm wondering why these show up? Now what I do know is that these are tracks that I have tested i.e. played on the device and then subsequently DELETED from the phone (swipe delete). So I'm guessing that this is probably a bug?? I have also turned off iTunes Match on the phone, turned on Manually Manage Music etc. via iTunes and have been able to delete them that way but they come running back as soon as everything is re-enabled! Odd.


I have also tested this on my iPad 2 and get exactly the same result.


The behaviour I would expect it to have this folder completely clear (other than the Voice Memos) & any other tracks that I have downloaded to the device via Match (not ones that have been deleted!!).


Any thoughts / suggestions would be most welcome!




iPhone 4, Mac OS X (10.7.2)
  • JiminMissouri Level 2 (465 points)

    if you have a song locally stored on your iPHone and you swipe to delete it, that song is still available to you in the cloud in case you want to play it at a later date.  Thus the title will be there, but grayed out.  If you are trying to manually sync your phone via USB after having subscribed to iTunes Match, there can be issues with that.  If you think that's what's happening, that you are trying to do USB syncs, someone else will have to help you with that one.  Once I got iTunes Match, I stopped using USB sync.

  • bennett76 Level 1 (0 points)



    Yep that's the behavior I get i.e. swipe delete and then the little cloud reappears on the iPhone which is fine. The weird part is the fact that that even after deletion, they appear in the Music folder as per my screen-shot above which is the part for me that makes no sense (& have tried using both air & cable sync but it gives the same result).


    What IS very interesting is that during a sync, the "Purchased" playlist flashes up for a few seconds and it contains these exact songs! Then it dissappears again so definitely something weird going on...does anyone else get these "Phantom" songs appearing in Music folder after a sync once they have been played / downloaded to the device and then swipe deleted??

  • TheJapa Level 1 (0 points)

    I'm having exactly the same behavior.


    What's worse, these songs I cannot seem to get to my iPhone no matter what.


    I enabled iTunes match on the iphone, but it was taking too long to download it all, so I disabled Match, hoping to copy the tunes via iTunes. The music that wasn't grayed out copied fine.


    Those that were grayed out, I cannot copy to my iPhone no matter what. I tried enabling and copying it via Match, and it downloads. But the entry remains duplicated. If I disable Match again, I return to the original issue.


    This is really annoying.


    I'm hoping a restore will clear it out. Downloading music from Match takes too long for me, I'd rather keep the Match only on my PC, as it has it's obvious uses.

  • carltonfrombedford Level 2 (365 points)

    You will find where Michael and I both have experienced this problem and the files are not actual on the device, but we cannot get them to erase out of that folder.


    The only fix we've found for this so far is to restore from a backup.


    I found these files to be either ones that I download but the download didn't finish on the iphone or ones that I downloaded and stopped.

  • TheJapa Level 1 (0 points)



    Well, after losing so much time with a restore, yes, it's fixed.


    I don't feel I found a fix, I feel I found a workaround. A very tiresome one.


    Remember to backup your iPhone (iDevice) to your PC/Mac instead of iCloud. It's faster too. I disabled wifi syncing and plugged in the cable. You guys may think wireless is good, but faster is better!


    Good luck y'all.

  • MDAdler Level 1 (0 points)

    HI all (I am new to the Apple world and the change over is **** - but I am getting it).


    I have a slightly different spin on this same issue.  I know exactly how I ended up with phantom songs.  Before I knew what I was doing I used the "Add folder" in iTunes to pick up songs from my home network. The sync crashed (fault of my old media PC) and that's when I realised that iTunes was just setting up links to my home network.


    Now the music sits there all grey, unsyncable and undeletable.


    So here is my first question if anyone has an answer (remember PC/Android cripple) "If you just use the File drop down to Add Files and Add Folder to iTunes, how do I remover them???


    Further more, I just went through a backup and restore as a result of up dating iOS which is all well and good for the iPhone but the phantom songs are still sitting in iTunes. So @TheJapa what are the exact steps that you went through are am I dealing with something different?

  • Michael Allbritton Level 6 (16,785 points)

    You have posted to the iTunes Match forum, in a thread about "ghost tracks" on an iOS device. You'll probably get a better response by posting in the iTunes for Windows forum.

  • AppaHolic Level 1 (0 points)

    With that restore, did you do a clean restore, or a restore from backup? Also has anybody with a jailbreak tried to delete/rename the iTunes_Control folder to see if that has any effects on the way things show up?

  • GeekDad3 Level 1 (0 points)

    I had a similar thing.  This is not related to iTunes Match (as far as I can tell), however, it did happen to me after I had enabled iTunes Match on my iPhone.  Then again, I also upgraded my client to the beta version to fix a duplicate scrobling issue so that could have b0rked my device.  Anyway.....


    Issue:  iOS Music application either has items listed in the library that will not play; or has an empty library but iTunes reports that music is present on the device and taking up space; or a combination of these issues coupled with the inability to resolve the problem through the standard resolution steps of disabling music syncing to remove all music and then re-enabling or by enabling "manually manage library" and removing the items.

    Additionally, attempting to restore from a back-up does not resolve the issue and the default response from the Apple Support Community is to factory restore the device and treat as new device, resulting in loss of all settings and basically starting from scratch.


    Cause of issue:  Corrupted iOS device iTunes library (MediaLibrary.sqlitedb).  This database stores the iTunes Media records and related information such as playcount, lyrics etc.  It does not store information and settings regarding iOS Applications as far as I am aware so this should be safe.


    Resolution Steps:

    1. Perform a back-up to your local computer rather than iCloud if practical.  This will be quicker in the event of issues.
    2. Download a iOS device manager such as Phone View ( which will allow you to directly access the file structure of the device.
    3. Enable the Advanced View mode so the entire disk structure is accessible.
    4. Browse to the following file:  iTunes_Control/iTunes/MediaLibrary.sqlitedb
    5. Rename MediaLibrary.sqlitedb to MediaLibrary.sqlitedb-backup or similar
    6. Hold down POWER and HOME on your iOS device until the Apple logo appears.  Release both buttons.
    7. When device has rebooted, connect to iTunes and synchronise it.
    8. iTunes will detect that the Media Library on the device is missing and recreate it based on the items that it has listed in the iTunes synchronisation record for the device.
  • F-Sharp Level 1 (0 points)

    Hi GeekDad3,


    I was reaching the end of my tether with 'ghost' tracks on my iPhone. About 6 months ago when synching I noticed that the yellow "other" portion in the capacity band at the bottom of iTunes kept growing and reached 9.2GB On checking the iPhone music library,  I could see nearly 2,000 grey-out tracks in the voice memo folder that accurately accounted for the unexplained used capacity.


    I tried your suggestion of using the Phone View device manager software and the problem got worse; the yellow portion suddenly expanded to 14GB! However, Phone View allowed me to look through the directories and I was able to locate where those 2,000 tracks were and deleted most of them; I thought I'd leave a few just in case. Anyhow, it's cured the problem, I've liberated tons of capacity and the phone works works/syncs perfectly.



  • SFUser1 Level 1 (0 points)

    I did what GeekDad3 did, but that did not work for me.  But it got me thinking ... So I kept looking for an answer to my issue using iExplorer.  I knew my problem had to do with my iPhone, and not iTunes, because no matter what PC I connected my iPhone to, the "ghost" tracks showed up.


    My symptoms were as follows:

    1. I do not use iTunes Match, so I don't know how the "ghost" tracks showed up in the first place, and I knew all the fixes related to Match would not help me.  My problem started after a restore when I upgraded my iPhone.
    2. The "ghost" tracks do not show up on my iPhone.  They only show up greyed out in iTunes when I am browsing my music on the iPhone.
    3. The "ghost" tracks will not play in iTunes, nor can I delete them through iTunes.  That said, they do seem to disappear when I try to delete them, but then they reappear when I reconnect the iPhone.


    So here's what I did...


    1. In iTunes, I deleted all of the music from my iPhone, leaving only the "ghost" tracks.  I did this so that I knew that if I found any "music" related data on the iPhone, it must be related to the "ghost" tracks, and not my real music.
    2. Using iExplorer, I search all the folders under the main directory labeled "Media".
    3. I found a directory that contained album art and a bunch of cryptic files with a '.plist' extension.  This directory was labeled "Purchased".  The full path was "Media/Purchased".  This had to be the offending folder, because I should not have any album art or associated files if I deleted all my music.
    4. I deleted that entire folder "Media/Purchased".
    5. The moment I deleted that folder, all my "ghost" tracks disappeared.  I also had a "ghost" movie that cleared up as well!
    6. I rebooted the iPhone, reconnected it to iTunes, verified the "ghost" tracks were still gone, and then reloaded my music.  Everything works great.



    My problem is solved!  After months of trolling the boards, and with a little help from GeekDad3, my problem is solved without the need for doing a restore.  Believe me...I was very close to sucking it up and doing the restore until I stumbled on this fix.


    Anyone who decides to try this fix should understand that I don't know if the "Purchased" folder that I deleted will be the same folder for you.  But I can tell you that if you follow the process of first removing the good music and leaving just the "ghost" tracks on your iPhone, you will probably be able to quickly find the folder that contains your "ghost" tracks using iExplorer, and can then delete that folder to solve your issue.


    Hope this helps those who had a similiar problem as I.

  • Jimzgoldfinch Level 5 (7,120 points)


    I was going to follow your suggestion but before doing this I deleted a playlist called Purchased that I had not created.

    I synced with iTunes - hey presto all the ghost tracks had disappeared.



  • SFUser1 Level 1 (0 points)

    Awesome!  I guess that is an even easier (and probably less dangerous) way to do it.

  • Jimzgoldfinch Level 5 (7,120 points)


    Spoke too soon! Phantom tracks back again. Deleted them using iExplorer.



Previous 1 2 Next