11 Replies Latest reply: Dec 26, 2012 3:17 PM by margaret.miz
jake65 Level 1 Level 1 (0 points)

I seem to have a corrupt file(s) which cause my MacBook Pro to freeze inexplicably (and randomly) upon start-up. I've been told that this is a symptom of having a corrupt file.


Is there an an for finding/deleting corrupt files on OS X 10.7?


I'm pretty much bound to my computer and simply don't have the time to go through it manually.


Thank you.

MacBook Pro, Mac OS X (10.7.2)
  • Frank Caggiano Level 7 Level 7 (25,715 points)

    If a corrupt file was causing this then it most likely would be part of the OS. I would just try a re-install of Lion. If it is a corrupt file that should fix it.

  • Barney-15E Level 8 Level 8 (44,330 points)

    Nothing I know of. You just have to run some troubleshooting steps to figure out what it is.


    Is it crashing or just freezing?


    Is there a CrashReport or HangReport in Console?


    Try starting up in Safe Mode by holding down the shift key when you hear startup chime and hold until the gray screen. It will do some disk checks, so it takes a while. When it boots, it will show the login screen, even if you have it set for auto login. 


    See how it works in safe mode. Then restart normally.

  • Cattus Thraex Level 4 Level 4 (1,715 points)

    How can you tell a ‘corrupt file’ from a non-corrupt file?

    ‘I seem to have a corrupt file(s) which cause my MacBook Pro to freeze inexplicably (and randomly) upon start-up.’

    I am afraid you were told erroneously. If this occurs upon logging in, then de-activate all non-Apple apps / utilities which start up at logging-in. Anti-virus software too. You describe a frequent behavior of all those, who have such outdated apps, some of them incompatible with Lion. Go to System Preferences/Users, select logged-in user (you), and deactivate all. Have a look at the attached screenshot. I have there only two non-Apple apps, one is Shades (for seting brightness of the external monitor, checked it first), the other one is HP driver activation.

    Screen Shot 2012-01-07 at 16.51.15.png

  • jake65 Level 1 Level 1 (0 points)

    I reinstalled Lion and it still freezes.

  • Cattus Thraex Level 4 Level 4 (1,715 points)

    Yes, if you reinstalled by putting the new system aside the old one, the problems persist, because the new system imported the old settings and log-in apps, so this in NOT a solution. A solution would be, on thie route, to make an erase-and-install of Lion, which implies a solid backup of all data to be later restored.

    You do not have a corrupt system, you probably have incompatible apps, which startup at login and badly behave in Lion. This is the typical situation.

  • jake65 Level 1 Level 1 (0 points)

    Ran disk utility and got the below message:


    Repairing permissions for “Macintosh HD”

    Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent” has been modified and will not be repaired.


    Serious problem? An issue which may have something to do with the freezing?


    So far, I have deleted my non-Apple apps from logging in at start-up. No freezing problem so far...

  • Barney-15E Level 8 Level 8 (44,330 points)

    First, we have to figure out where the problem exists, in the system space or in the user space.

    Please boot into safe mode and see if you still have the problem.


    Second step is to log into another account and see what happens there.

  • Cattus Thraex Level 4 Level 4 (1,715 points)

    ‘So far, I have deleted my non-Apple apps from logging in at start-up. No freezing problem so far...’

    I think you are on the good way.


    Repairing permissions is something useful before and  after Apple updates, but are not critical in most instances, freezing is not probably due to that minor issue.

  • Barney-15E Level 8 Level 8 (44,330 points)

    No, those are normal.


    You need to figure out which of the third-party apps are causing the freeze. Any crash or hang reports might indicate which, but it is likely a trial and error process.

  • Linc Davis Level 10 Level 10 (178,440 points)

    Please read this whole message before doing anything.


    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.


    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software -- potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions -- they’re easy to carry out and won’t change anything on your Mac.


    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.


    Below are several lines of text in monospaced type, which are UNIX shell commands. They’re harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of running these commands, search this site for other discussions in which they’ve been used without any report of ill effects.


    Some of the commands will line-wrap in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.


    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.


    To begin, launch the Terminal application; e.g., by entering the first few letters of its name in a Spotlight search. A text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” (without the quotes) and press return. You should then get a new line ending in a dollar sign.


    Step 1


    Copy or drag -- do not type -- the line below into the Terminal window, then press return:


    kextstat -kl | awk '!/com\.apple/ {print $6 $7}'


    Post the lines of output (if any) that appear below what you just entered (the text, please, not a screenshot.)


    Step 2


    Repeat with this line:


    sudo launchctl list | sed 1d | awk '!/0x|com\.apple/ {print $3}'


    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning.


    Step 3


    launchctl list | sed 1d | awk '!/0x|com\.apple/ {print $3}'


    Step 4


    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Sta}* L*/Fonts 2> /dev/null


    Important: If you synchronize with a MobileMe account, your me.com email address may appear in the output of the above command. If so, change it to something like “user@me.com” before posting.


    Step 5


    osascript -e 'tell application "System Events" to get the name of every login item'


    Remember, steps 1-5 are all drag-and-drop or copy-and-paste, whichever you prefer -- no typing, except your password.


    You can then quit Terminal.

  • margaret.miz Level 1 Level 1 (10 points)

    This is an old post and I am not the person who posted the original query, but I ran your terminal diagnostic and am hoping you are still attending to this forum. I have a mid 2011 macbook Air 11", 256 GB SSD, 1.8 GHz Intel Core i7, 4 GB  1333 MHz DDR3, Mac OS X v. 10.7.5 Lion. I have had various problems in my user homefolder for a while. I have gone through quite a few other troubleshooting and fixing steps, the most extensive following a posting here "Step by Step to fix your mac" by ds store in the Apple forums. These steps helped a lot. I did remove some 3rd party software as part of this process.


    My computer is running well in general now, but one thing that has been a recurring problem is problems with move/cut-paste. I researched this online and ACL's being present where they're not supposed to be seems to be an issue. I have used terminal commands to remove ACL's, used Onyx to repair user permissions, rebooted with command-r to reset password screen and reset user permissions. They all help, but then a some point later on the problem recurs. When I run repair disk permissions with either disk utility or onyx I always get this message:

    Repairing permissions for “maggieairHD”

    Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent” has been modified and will not be repaired.

    ACL found but not expected on “Users”

    Repaired “Users”


    Permissions repair complete

    This ALWAYS comes up, even if I run it immediately after running it and haven't done anything else on the computer in between.


    I created another user and did not have the same problems I was having at the time with some programs, although I haven't used it that much to be able to really compare. The home folder permissions repair in Onyx comes out the same in that user, though.


    Here are my results from your diagnostic terminal commands:

    Last login: Wed Dec 26 09:36:47 on console

    Maggies-MacBook-Air:~ maggieair$ kextstat -kl | awk '!/com\.apple/ {print $6 $7}'









    Maggies-MacBook-Air:~ maggieair$ sudo launchctl list | sed 1d | awk '!/0x|com\.apple/ {print $3}'












    Maggies-MacBook-Air:~ maggieair$ launchctl list | sed 1d | awk '!/0x|com\.apple/ {print $3}'







    Maggies-MacBook-Air:~ maggieair$ ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Sta}* L*/Fonts 2> /dev/null

    /Library/Address Book Plug-Ins:










    Adobe AIR.framework










    /Library/Input Methods:


    /Library/Internet Plug-Ins:



    Flash Player.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin







    /Library/Keyboard Layouts:

















    Flash Player.prefPane





    Google Drive Icon Helper
















    AScrEd • New Script for Frontmost Application.workflow

    AScrEd • Open Application Scripting Dictionary.workflow

    AScrEd • Open Dictionary of Frontmost Application.workflow

    AScrEd • Open with AppleScript Editor.workflow

    Audio • Encode to iTunes Format.workflow

    Browse Movie Library.workflow

    Browse Photo Library.workflow

    Browse iTunes Library.workflow

    Disk Item • Rename Selected Items.workflow

    Disk Item • Set Spotlight Comments.workflow

    Image • Add Metadata to JPEGs.workflow

    Image • Change File Type.workflow

    Image • Import into iPhoto.workflow

    Image • Print Image Files.workflow

    Image • Rotate Clockwise.workflow

    Image • Rotate Counter-Clockwise.workflow

    Launch Terminal.workflow

    PDF • Encrypt File.workflow

    PDF • Set Metadata.workflow

    Terminal • Get Manual for Command.workflow

    Terminal • Insert Current Finder Directory.workflow

    Terminal • Insert Selected Finder Items.workflow

    UNIX • Apply Command to Selected Items.workflow

    UNIX • New Terminal Window to Insertion Location.workflow

    iPhoto • Spotlight Search for Detected People.workflow











    Library/Address Book Plug-Ins:







    Library/Input Methods:



    Library/Internet Plug-Ins:


    Google Earth Web Plug-in.plugin



    Library/Keyboard Layouts:



    com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.7D3946E8-ADA6-4982-87CA-565 69B042BAC.plist















    Sync with MacDropAny.workflow

    Maggies-MacBook-Air:~ maggieair$ osascript -e 'tell application "System Events" to get the name of every login item'

    NoSleep, iTunesHelper, Caffeine, Dropbox

    Maggies-MacBook-Air:~ maggieair$

    I have removed NoSleep, Caffeine, itunesHelper and Dropbox from login items before and didn't notice any difference, so I put them back. Some of these I know I don't want, like rim/blackberry, adobe AIR. Skype has never worked consistently on this computer. I don't use most of these Services, and I know I had trouble with some that were not compatible with Lion before. I am not using Parallels much now, have been thinking about taking it off as it uses a chunk of my SSD. But I don't feel confident about getting rid of .frameworks etc safely.


    I am glad to remove anything I don't use if I know how to do it safely. I am willing to remove anything I do use if it's necessary, but obviously would prefer to find a way to keep things that I find helpful.


    I appreciate any suggestions!

  • Csound1 Level 8 Level 8 (45,320 points)

    I suggest that you start a new thread, you have a better chance of being noticed than adding to a year old one.