Previous 1 2 3 4 Next 48 Replies Latest reply: May 29, 2015 12:29 PM by MiniManda Go to original post
  • RLestina Level 1 (0 points)

    Just one little thing that I had to change. My username for Incoming Settings was just my user name without the "" or ""  Worked like a charm

  • andynick Level 5 (4,925 points)

    I'd just like to join all the others in thanking you for taking the time to make this post. I spent hours trying to get my iCloud email set up on my phone.

    Thanks Brenman2 it's working now!


  • radiodave Level 1 (0 points)

    Big up and thanks to Brenman2. Your info on this thread got my wife's email working again on her Galaxy Ace. It had been working just fine since the day it was bought until last week when it started to display 'cannot connect to the server' message.


    Brenman2's settings are radically different to the previous ones. Why her email settings should change overnight is a mystery but, I'm sorry to say, too typical of Apple these days. It's like the bad old days of Windows


    Anyway, thanks again. We appreciate the time and trouble you've taken to post on here.

  • RLestina Level 1 (0 points)

    I'm no computer savant, but I've checked with multiple people on this issue with Androids and Apple.  From what I understand, this is not an Apple issue, but an Android issue.  Because there are so many different operating systems that Androids use, they easily get all "kaflooey." (Techinical term )  Since writing my original post, I've dumped the Android and have seamless service on my new iPhone.  This whole problem reminds me of the early days of Apple when Steve Jobs refused to let other computer makers use his Operating System. He felt it would lead to nothing but problems. Apple almost went under because of this, but, it's one of the big reasons why Apple computers have fewer problems -- the OS was built for the machine.  Anyway, I really appreciated all the help with getting my email configured properly.  I'm a happy camper now that I have my iPhone and don't have to deal with email craziness any longer.  Thanks to everyone!!

  • radiodave Level 1 (0 points)

    I'm happy for you - and I'm okay for us as the email's working again - but I can't see how this is an android issue as nothing has changed on the Galaxy Ace for over two years. Nothing on the phone's been updated since the day we got it from the store and set up the email account. Whatever flavour of android it is running has stayed the same, my wife's email account with Apple has stayed the same and yet the original settings suddenly were useless. All else on the phone was working fine so I can only see that it was a change on Apple's mail servers. If it hadn't been for the advice and information in this thread, I would have gone to plan B, which was to change my wife over to Gmail which, of course, works almost natively in android. Thankfully for joint bank account, I didn't need to go near plan C -  migrating her to a much more expensive iPhone ;-)

  • samtennorbu Level 1 (0 points)

    Thank you, lufromsonoma.


    It's a year and a half since you posted, but it was the settings you recorded that did the trick for me.


    I have an HTC Amaze running Android 4.0.3. Out of the blue my .mac email account stopped syncing on my Mail app. Like others who have posted here, I spent a lot of time trying to re-configure the settings manually. I spent a half hour at my local T-Mobile store, too, but the rep there had no more success than I had.


    As usual, there is no explanation to these kinds of problems. You just have to hit on the precise settings.


    Thank you for taking the time to post the details of your experience to this forum.



  • Jamaican123abc Level 1 (0 points)

    Worked like a charm thanks for the help if anyone trying to set up there iCloud email on device like LG Optimus G, Pro, G2 works flawlessly with those settings.


    You want to make sure to find out want server your icloud mail is on by looking under your calender settings on then the share set it to public you will recieve a url that you can use to share your calender. The first part of that url tells you what server you are on  ("p01" "p02"etc).


    So when you put in the info for imap4 under incoming server settings as listed above you would enter "" was my setting for example. 

  • Sturgy76 Level 1 (0 points)

    Im in the same boat as many others, bought the origianl iPad, use the email address that comes with it, now want to switch to the Samsung note.  I've been using a Galaxy 3s phone for about a year and love it but couldn't get the email to work.  I found this discussion and got all exicted but wasn't sure which email app to download.  Randomly, I decided on AquaMail and it is works great.  The only setting I had to enter though was my username and password!  When I hit go, the app said setting up IMAP, and viola, my email was there! 


    Thanks for the settings!


  • martycee Level 1 (0 points)



    Spanner in the works? I have a new Samsung Galaxy Note 8 tablet running Android 4.2.2 that won't set up my mail account if its life depended on it. I've tried every possible combination of suggestions on these discussion pages and nothing works. I mainly can't get past the incoming mail settings page that reports 'cannot connect to server'. All my settings and password formats are correct. I even changed my Apple ID password as suggested by some to no avail.


    My Samsung Galaxy Note phone running Android 4.1.2 had no problem at all before and after I changed the password and set up automatically from just the address and password. No further settings were needed.


    Android 4.2.2 bugs perhaps?


    Anyone have suggestions?



  • DFMM19 Level 1 (0 points)

    Hi Brenden....


    I am EXTREMELY GRATFUL for your post. I have been trying so many different options since my RAZR MAXX dropped my Mac Mail with an upgrade a while ago. THIS WORKED!


    Any other tricks up your sleeve? Have you figured an efficient way to get Contacts from Mac to a Droid?




  • markfromnorthville Level 1 (0 points)

    A little tick that I didn't see metnioned here yet, is that for the AOSP mail app on Android (at least 4.4.2) the setting for the outgoing smtp server security shlut be STARTTLS instead of the SSL/TLS settiing which was used for incoming connections.  Also, although I suppose YMMV, i did not find it neccesary to add a pXX section in front of the any of the server settings. 

  • Pete Kockritz Level 2 (155 points)



    Is this still working for you? There is a growing thread here:


    Of folks whose iCloud logins from Android devices just started failing earlier today.

  • markfromnorthville Level 1 (0 points)

    Oddly enough, I just set it up today;  At least the last time I checked, (about 7:00 EST) all was well.

  • Brats22 Level 1 (0 points)

    I found an app available on Google Play called CloudMagic which works wonderfully for me.  I have my gmail, icloud, and work all coming into this app.  Arranges nicely and replies from the correct email account.

  • 2advanced Level 1 (0 points)

    i ended up just using cloudmagic and gave up.


    No matter which settings i tried on my xiaomi mi3 i can only receive and not send. And the funny thing is it actually seems to accept the outgoing server settings without any error (when the login/password or other settings are incorrect it does display an error).