Skip navigation

Why am I getting a disk not ejected properly message?

10556 Views 107 Replies Latest reply: Mar 27, 2014 5:13 PM by longtimeuser RSS
1 2 3 ... 8 Previous Next
palh1980 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 7, 2012 10:56 PM

I get frequent and annoying messages telling me I have not ejected a disk properly. It may or may not be be related to the computer going to sleep and the external drives remaining on.

iMac, Mac OS X (10.7.2)
  • geminifm Level 1 Level 1 (0 points)

    I get this aswell, i found out it is when the computer goes to sleep with the external hard drive still turned on!

  • WZZZ Level 6 Level 6 (11,880 points)

    geminifm wrote:

     

    I get this aswell, i found out it is when the computer goes to sleep with the external hard drive still turned on!

    That shouldn't cause it. Only a bandaid, but try disabling "Put the hard disks to sleep whenever possible" in Energy Saver.

  • geminifm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2012 11:00 AM (in response to WZZZ)

    thats what causes mine! as if i go into finder and eject the disk and turn it off, it wont happen the next time the computer sleeps!

  • Marty.MacPhail Level 1 Level 1 (0 points)

    I have been experiencing this same issue as well. I have a new MBP with a Apple Thunderbolt Display and two external drives connected via USB.

     

    Every time the computer wakes from sleep I get the error message and on numerous occassions Time Machine fails because it can't find its backup drive.

     

    And adding to the frustration .. after I click thru the error message Finder shows the drives are mounted and then TIme Machine starts but it uses the wrong drive for backup.

     

    The error still occurs regardless of whether the  Energy Saver option to "Put the hard disk(s) to sleep when possible" is selected or not.

  • Brunsworks Level 1 Level 1 (0 points)

    I have a similar situation.  I'm running a Late 2011 Mac mini with Lion 10.7.3, and a Western Digital My Book Essential 2GB, and I made the mistake of trying to use it with both the mini and a Late 2006 Macbook White with Lion 10.7.3.  It backed up successfully for about three weeks, and is now consistently displaying the ridiculous error message, despite being formatted the exact same as the drives it's (trying to) backup: Mac OS X Extended (Journaled).

     

    I have also verified that the error still occurs regardless of whether the Energy Saver option to "Put the hard disk(s) to sleep when possible" is selected or not.

     

    Apple and Western Digital need to admit that this drive is simply not compatible, at least in USB.  I've heard that the mini doesn't provide sufficient power to its USB ports to run this and other drives (even though the My Book has external AC).  Does anyone have any suggestions as to what to do to fix this?  Am I just going to have to buy two other drives (one for each computer), and if so, what drives are the best way to go?

  • cricketernot Level 1 Level 1 (135 points)

    I ONLY use FireWire drives, have four, all Iomega, both 400 and 800 types. Work perfectly even when daisychained together (OK, famous last words!). One of the drives has its own power supply, the others bus powered. A lot of people report problems with Western Digital, seems it depends on the exact model. I have no problem making bootable clones using Iomega, but as "Dr Smoke" says "It will never tell you on the box" if this is going to work when you buy a hard drive. It's no good asking Apple staff about bootable clones, I've tried, they don't want to know.

  • JeffinOC Level 1 Level 1 (0 points)

    I'm having the same issue with a WD 2T external drive that I use for Time Machine.

  • HarveyBirdman Level 1 Level 1 (0 points)

    I have the same problem.  I have a ProBox 8 bay enclosure, and when I wake my mid-2011 model iMac from sleep, it says that I did not eject the disks properly, and none of them appear on the desktop.  Within a second or two, they all start to appear one by one.

     

    I have the "put the hard disks to sleep" option unchecked.  There is also an option on the enclosure itself to put all the drives to sleep when it detects that the computer has gone to sleep, and that is also turned off.  The whole thing is a mystery to me.

     

    As best I can tell, it hasn't affected my drives in a negative way, although I wonder if it will after I keep going through this, day after day for years.

  • mikepsn Level 1 Level 1 (0 points)

    Same problem here. I have a late 2010 i3 iMac running 10.7.4 with an external 1 TB WD drive with its own power supply which I use with Time Machine for backups. I've been getting "disk was not ejected properly" when I wake up the iMac from sleep in the morning and the drive is unmounted. The iMac can no longer see it. After turning the power off for a few minutes then back on, the drive remounts. But then the next morning the same thing.

  • Bart57266 Level 1 Level 1 (0 points)

    I was getting the message "The disk was not ejected properly..."  all day long, sometimes a few seconds after re-mounting the external Thunderbolt hard drive.

     

    Exchanged my Thunderbolt cable at the Apple Store yesterday. Today the drive remained mounted, with no errors, for 8 hours.

     

    We'll see how it goes over time, because the first cable also worked perfectly when new, but so far so good.

  • Bart57266 Level 1 Level 1 (0 points)

    After one full week with a new cable, NOT ONE single eject message.

     

    Maybe the old cable's contacts were damaged from plugging this disk in every day (it stays at work, the MacBook goes home).

     

    Bart

  • The Dark Knight Level 1 Level 1 (0 points)

    I am one of those who had experienced this kind of problem.  My former Time Machine disk used to automatically eject itself when my iMac sleeps, hence upon waking up my iMac. i always get the error message that the disk was not properly ejected.

     

    From what I was able to gather from my experience, until the time that I found a workable solution, I think I can say that the problem is most probably caused by the incompatibility of certain external drives with how the iMac operates when on sleep and upon waking up.  Some external drives are just not able to cope with how the iMac tries to remount a connected disk after it wakes up from sleep.  There are just some external drives that cannot continue to be mounted after the iMac wakes from sleep.  There are just some external drives that are not responsive enough. In other words, the existence of the problem lies with the type of external drive you are using.

     

    My former Time Machine disk, the problematic one, was an Imation M300 Apollo 1 TB external disk.  It unmounts everytime my iMac went to sleep, but does not remount after waking up the iMac.  The disk will continue to be unmounted until I physically remove its USB connector and replug it in the iMac.

     

    I replaced my former Time Machine disk with my current one, a Transcend Storejet 1 TB.  And the problem went away.  The Transcend disk continue to be mounted after the iMac is woken up even from the longest of sleep.  I have even the energy saving option "put the hard disk to sleep..." checked.  The Transcend disk comes with a Y cable, i.e. it has two USB connectors, but I only connect the one for both data and power--and it still remains mounted even after waking the iMac from sleep.

     

    The sad realization, however, is that since there are only some external drives that are not able to work with the iMac, no matter how many those some may seem to be, it will be highly unlikely for Apple to itself fix this kind of a problem.

     

    I, therefore, make the following recommendations:

     

    1.  Check first if your problematic disk has a firmware upgrade available.  In some cases, the firmware upgrade may be enough to make the disk more responsive to the iMac waking up.

     

    2.  If there is no firmware upgrade available, check if your power/data USB cable is properly working.

     

    3.  If your power/data USB cable is in order, and the problem still persists, I think it is inevitable that you have to replace the problematic disk with a newer one that could respond well with the iMac's wake/sleep operation.  With what disk will you replace your problematic one?  I can only recommend from my personal experience the Transcend disk I mentioned earlier.  You may also search this forum on other brands of disks that may also work.

     

    Regards.

  • s0j0roman Level 1 Level 1 (0 points)

    I, too, had this problem, and I think The Dark Knight's solution is right.  There seems to be some problem with USB drives and sleep, etc.  I switched to a Thunderbold drive and have not had the problem since (several weeks now).

     

    Steve

  • Bart57266 Level 1 Level 1 (0 points)

    I still think it's a cable issue, because it's now been six months without one single problem since replacing my Thunderbolt cable. And, if I read Dark Knight's post correctly, he, too, switched cables when he switched drives.

     

    Then again, these problems likely can come from many different sources, so it's hard to tell.

     

    If you have an extra cable available, it sure is  easy  to test.

     

    Bart

1 2 3 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.