1 2 Previous Next 16 Replies Latest reply: Jun 15, 2012 10:18 AM by Scimos
David314159 Level 1 Level 1 (0 points)

I've noticed recently that while watching netflix on my imac (iMac 11.1, osx 10.6.8) that CPU use jumps up to near 100% and stays there.

 

This happens using both safari and chrome browser.

 

I can't think of anything that I've changed on the machine to have caused this. It worked fine for the longest time. I tried clearing out temp browser files, reinstalling the silverlight plugin, rebooting, etc. and nothing helps.

 

This is very frustrating because now the machine is unuseable while a netflix video is playing and the high CPU causes it to really heat up, crank up fans, etc.

 

Any ideas on what I can do to fix this?


iMac, Mac OS X (10.6.8), iMac version 11.1
  • 1. Re: Why does netflix suddenly use 100% CPU?
    rkaufmann87 Level 8 Level 8 (42,145 points)

    Video by nature is CPU intensive, that being the case it's not surprise Netflix is using a lot of CPU.  As for making your system unusable, things I'd look at are the amount of RAM in the computer. You didn't mention which iMac you have but one thing to look at is is  open Activity Monitor - System Memory and check the amount of Free RAM. As a general rule of thumb if it's 500MB or less your system could probably use a RAM upgrade. Do this when running Netflix or when you see a system slow-down. 

  • 2. Re: Why does netflix suddenly use 100% CPU?
    David314159 Level 1 Level 1 (0 points)

    Thank you for the reply. I understand the video is CPU intense, but my point was that something has recently changed because just weeks ago I was able to do the same activities (netflix + other apps running) without the maxed out CPU.

     

    I did mention which imac I have (11.1 which is a 27" with i5 cpu). It has 4gigs of ram installed and looking at the system monitor just now ... 1.68 gigs free.

  • 3. Re: Why does netflix suddenly use 100% CPU?
    rkaufmann87 Level 8 Level 8 (42,145 points)

    It has 4gigs of ram installed and looking at the system monitor just now ... 1.68 gigs free.

    Were you running Netflix when you had 1.68GB free? To be honest 4GB isn't that much RAM these days, so you may want to still consider upgrading it. It's inexpensive if you buy from reputable sources such as www.macsales.com (OWC) or Crucial. Do not buy RAM directly from Apple!

     

    If you think something recently changed you can do some basic resets. Rebooting in Safe Mode will clear some caches, it's possible one or more may have become corrupt.

  • 4. Re: Why does netflix suddenly use 100% CPU?
    David314159 Level 1 Level 1 (0 points)

    Yes I was running netflix and some other apps at the time.

     

    I really don't think a lack of RAM is the problem though since I was able to run things just fine with the same rig just a few weeks ago.

     

    I tried the reboot in safe mode but it didn't help.

  • 5. Re: Why does netflix suddenly use 100% CPU?
    rkaufmann87 Level 8 Level 8 (42,145 points)

    You can also do some other resets but I don't know if they will affect your situation. You can reset both the SMC and PRAM, it not a bad idea to each reset 2x. Please follow these instructions closely:

     

    SMC RESET

     

    • Shut down the computer.
    • Unplug the computer's power cord and all peripherals.
    • Wait 15 seconds.
    • Attach the computers power cable.
    • Wait another 5 seconds and press the power button to turn on the computer.

     

     

    PRAM RESET

     

    • Shut down the computer.
    • Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    • Turn on the computer.
    • Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    • Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    • Release the keys.
  • 6. Re: Why does netflix suddenly use 100% CPU?
    Ziatron Level 4 Level 4 (3,265 points)

    This happens using both safari and chrome browser.

     

    I had the same problem, Firefox took me down to about 40%.

  • 7. Re: Why does netflix suddenly use 100% CPU?
    David314159 Level 1 Level 1 (0 points)

    Thanks. I tried both resets and now help.

     

    I've tried running netflix on internet explorer running on a virtual machine inside VMware fusion. the free memory goes down to 100megs (definitely need to do that memory upgrade) but even running it that way the osx apps are more responsive and it's using less CPU than if I ran netflix inside safari. Something isn't working right.

  • 8. Re: Why does netflix suddenly use 100% CPU?
    rkaufmann87 Level 8 Level 8 (42,145 points)

    If the machine is covered by AppleCare give them a ring, if it's not covered by AppleCare AND is less than  a year old buy AppleCare!

  • 9. Re: Why does netflix suddenly use 100% CPU?
    Bethesda20816 Level 1 Level 1 (0 points)

    I had a similar problem with iTunes.

     

    Here's the link to what fixed my problem immediately.  Please note: my problem was resolved following just the three steps pasted below.  The original link has additional steps that may be necessary, although I did not employ them, and my problem of 100% CPU USAGE is gone!!!  Thank God!

     

    URL source:     http://www.hotcomm.com/faq/FAQ_ResetWinsock.asp

     

    Good Luck

     

    Copyright (c) 2009 1stWorks Corporation. All rights reserved.

    This article gives instructions for resetting Winsock on Windows XP and Windows Vista: 

     

    Reset Winsock (Vista) 

     

    To reset Winsock in Vista: 

     

    1.Click the Windows Start button. 

     

    2. Type Cmd in the Start Search text box and press Ctrl-Shift-Enter (keyboard shortcut to run Command Prompt as Administrator). Click Continue to allow elevation request. 

     

    3. Type netsh winsock reset in the Command Prompt shell, and then press the Enter key. 

     

    URL source:     http://www.hotcomm.com/faq/FAQ_ResetWinsock.asp

  • 10. Re: Why does netflix suddenly use 100% CPU?
    Bryanm18 Level 1 Level 1 (0 points)

    I haven't tried Bethesdas steps yet, but I figured I would mention that within the past couple of days Netflix has been doing the same thing to me. I don't have an Apple computer, but this is the only post anywhere I found about this.

     

    So usually when watching Netflix I'm only running about 40% cpu (I believe), but now suddenly it's running in the high 80's up to 100. The only reason I noticed is because suddenly now when I go to a different tab, the video stops and starts buffering, but can't buffer all the way up until going back to the Netflix tab. This is really annoying, by the way. Also, now about 50% of the time when I open fullscreen, everything but the audio stops, so I have to exit fullscreen and then go back in... Also the video is starting to get a bit choppy which is what prompted me to start looking for an answer.


    I can't say for sure, but this has to be Netflix. Had I not found this post I would've assumed my computer was crapping out or something, but this kinda confirms it.

     

    Not sure this post is needed lol, but if anyone has any ideas... I don't think Bethesdas idea will work especially since it's not even relevant to the OP.

  • 11. Re: Why does netflix suddenly use 100% CPU?
    thereisnoname Level 1 Level 1 (0 points)

    I have the same issues here. This only happened after I updated to the latest version of Silverlight.

  • 12. Re: Why does netflix suddenly use 100% CPU?
    pwales Level 1 Level 1 (0 points)

    I have noticed this as well. The Silverlight plug-in didn't used to take up all the CPU usage. Oddly, if I go to full screen mode (I have dual monitors) I can see the CPU usage drops to about 50% exactly the opposite of what you would think should happen (More pixels are being pused to the screen so it should run slower) I think this is an error in the way the Silverlight plugin handles video on the Apple OS.

  • 13. Re: Why does netflix suddenly use 100% CPU?
    thereisnoname Level 1 Level 1 (0 points)

    You can still get Silverlight 4 here.

     

    http://www.mydigitallife.info/download-silverlight-4-for-windows-and-mac-os-x-of ficial-links/

     

    I removed SL5 and installed SL4 again. Problem went away.

  • 14. Re: Why does netflix suddenly use 100% CPU?
    David314159 Level 1 Level 1 (0 points)

    Thanks, do you know if silverlight 4 is available direct from microsoft anyware? I'm a little leery of downloads from unfamiliar domains.

     

     

    I'm still plagued by this problem and have resorted to running windows 7 in a vmware fusion window anytime I need to use silverlight plugin.

1 2 Previous Next