3 Replies Latest reply: Jan 14, 2012 5:53 PM by aknh
aknh Level 1 (0 points)

I've had this MacBook Pro for at least 5 years now. Despite a few hiccups, it has continued to fare well. I've also had it checked out, hard drive erased and reinstalled, etc., many years back when it leapt off a high desk and dented itself on the hardwood floor.


Recently, it's been working fine. No issues. However, this past week it included a "Guest" login with sharing privileges, which made me doubt its security. I limited access for the guest account by choosing "No access" and it continued to work fine, login okay, etc. I realize the guest account with sharing privileges may have been there due to the machine being networked to one other computer in the house to attain wifi access.


Anyway, today, as I started it up to log on, it launched a blue screen and went no further. I held its power button down to restart it and, when restarted, was again met with a blue screen and without the login screen i usually see.


Does this mean it's dead, deeply troubled, or is it something to do with the change I made to that mysterious guest account - despite never seeing the guest account at login screen before?


Hoping this is not the end of the road for it. Help!



Thanks - any info extremely appreciated.

MacBook Pro, Mac OS X (10.6.2), 15" bought in US, now in Canada
  • OrangeMarlin Level 5 (5,145 points)

    See this article for help.  If you still have issues, drop a note back here.

  • aknh Level 1 (0 points)

    Thanks for your reply!


    As suggested, I have tried to boot it up in safe mode, and when I held the shift key down for that very short period between startup tone and when the grey Apple logo appears, I did see (on one of the tries) a progress bar instead of just the logo and a spinning progress indicator or, as on one of the first tries, just a spinning progress indicator without the apple logo either.


    The one time I saw the progress bar mentioned above, which was solid and not made of a series of strokes, like the  usual booting up or restart from sleep progress bar that appears, it filled in to about 35% of the bar, but then stopped and disappeared, once again leaving me with a blue screen.


    After I've attempted to safe boot these various tries, I continue to see a blue screen that shows a spinning gear progress indicator that then is interrupted by a quick flash returning to a blue screen with no spinning indicator, that then, very quickly, again displays the spinning gear progress indicator. It repeats this flash, disappearance of spinning gear, and then reappearance of spinning gear all on blue screen over and over until I shut it back down via the power key.


    I realize I could command-S when trying to boot up, but am unsure of what to do in UNIX to either properly investigate or actually solve the problem.

  • aknh Level 1 (0 points)

    Still stuck. I've now followed instructions OrangeMarlin suggested above mentioned at http://docs.info.apple.com/article.html?path=Mac/10.7/en/mchlp2887.html and pages related, and also:


    Tried to boot in UNIX by command-S ( http://docs.info.apple.com/article.html?path=Mac/10.7/en/mchlp1720.html ) which allowed it to run through a start-up in white on black UNIX screen, but, being totally ignorant about using UNIX or performing checks through it, I didn't actually command it to do anything, except to "reboot" which did allow it to restart but, as usual, again didn't fully bootup and stopped at a bluescreen after chime and gray screen with apple logo, but without progress indicator, progress bar, or periodic flashing in the bluescreen I'd mentioned in above post.


    Tried suggestings about restarting before resetting PMU through instructions at http://support.apple.com/kb/HT1431 using keyboard command steps for force quit, restart, force shutdown, but it wouldn't force quit anyway, and I didn't go on to try resetting PMU aware I could make a bigger mess of things.


    Tried also to command-control-P-R for PRAM and it started up, but again didn't complete and left me with a bluescreen.


    It is now only blue without any indicators, flashes, changes, icons (though gray screen and apple logo still show before it turns to bluescreen) until I force it to power down by holding down the power button.


    Any suggestions before I officially give up and bring it in to the shop?

    Any help is appreciated.