6 Replies Latest reply: Jan 12, 2012 1:57 PM by léonie
mamster37 Level 1 Level 1 (0 points)

I just returned from a trip to Vietnam bringing along home 2000 photos, approx. 50 GB, and having started my editing them, I discover an unacceptably, and so far not observed, slow rendering, f.inst. when dodging and burning. Therefore I would appreciate any hint given to me about what to do to change this unbearable situation - thus, it may take up to 5 seconds to render f. inst in a burning process. Here are my my technical details, being hopefully of some use.

Operating System: Mac OS X 10.7.2 Lion

My hardware:

Macbook Pro Intel, 8GB, HD: 500GB, Free: 142GB, 28%, 142GB pictures contained on the hard drive - and a great deal of previously relocated masterfiles to external disks.

5 Nik software plugins installed, but they are NOT in use all of them at the same time.

Have tried to shift from 32 to 64 bit, but without a remarkable effect.

  • léonie Level 9 Level 9 (77,840 points)

    Can you tell us more about your set up, please?

    • Your processor (which Intel MBP)
    • The format and size of your images (rwa &jpeg pairs?)
    • Where are the master image files located, you want to render - your external or intrenal drive?
    • How full is your external drive?
    • What does the Activity window show, when you are editing? (Aperture Application menu -> Window -> Show Activity)
    • Can it be, that Aperture is still busy with rendering Previews and scanning for Faces?
    • Do you have the PhotoStream turned on?
    • Any other Applications running in the background, that need much RAM, like Safari or GarageBand?
    • And just to make sure you are using the Aperture built-in "Dodge" and "Burn" adjustments, not the old "Dodge & Burn" plug-in from Aperture 2, right?

    Regards

    Léonie

  • mamster37 Level 1 Level 1 (0 points)

    Thanks a lot for coming back. Here you have supplementary details:

     

    Processor: 2.66 Ghz, Intel Core i7

    Always Raws

    The files are at present stored in project libraries WITHIN Aperture on the internal drive

    The External drive (1TB) is used by ONLY 22%

     

    I have not a deepgoing knowledge about using the "Activity instrument", but here is what I seem to have got when activativating it while dodging and burning a chosen photo:

     

    Pct. (max registered): 111%, threads 53, real memory: 743MB

     

    "Faces" UNSELECTED, PHOTOSTREAM turned OFF

     

    I have tried to close SAFARI, without remarcable effect, GARAGEBAND not installed, but "GROWL" installed

     

    Confirm using built-in Dodge- and Burn native Aperture

     

    Set as: New Projects automatically generate previews

     

    Don't hessitate asking more info, if necessary for tracing the problem...

     

    Thanks again for helping!

  • léonie Level 9 Level 9 (77,840 points)

    Anyone?  Hmm, your MBP seems to be very similar to my 17" MBP, and I do not have those performance issues, maybe my graphics card is faster.

     

    I still think Aperture might be doing some basic maintainance work after importing your images.

    Please start the Activity Viewer once again from the Aperture Application Window:

         Window -> Show Activity

     

    If Aperture is doing something in the background, you should see something like this:

     

    activity.png

    Is there any activity going on?

     

    Regards

    Léonie

     

    Added: if you do not see any activity that explains the sluggish behaviour, create a small sample library, and try if Aperture is as slow on a brand new test library. If that is not the case, repair or rebuild your main library, as outlined in the

    Aperture 3: Troubleshooting Basics: http://support.apple.com/kb/HT3805

  • mamster37 Level 1 Level 1 (0 points)

    Thanks again for your patience. I realized that apparently I had opened the "Activity" pogram itself, thus I could not see your above illustration, but now I found the right place as a menu point with Aperture, activated Aperture, and the proper activity window, and here is what was said, re my screen dump below. I noticed also when burning a chosen image that the small rainbow wheel kept running constantly, so that I could not have any visuable effect of my adjustments....So, I will try out your good proposal and repair/rebuild the main library. I believe to remember that it's done (the repair) by starting up Aperture by some keyboard combination, but can't remember which one, but maybe it is described in the link which you kindly sent me....

     

    file://localhost/Users/perhildebrant/Desktop/Activity%20Window%20shown.tiff

  • mamster37 Level 1 Level 1 (0 points)

    Thanks a lot to LeonieDF for great help. It WORKS fine after a "Rebuild" of the database - the two first repair-options did not change things to the better!

  • léonie Level 9 Level 9 (77,840 points)

    It WORKS fine after a "Rebuild" of the database -

    Good to know you could solve the problem. Enjoy Aperture!