Previous 1 2 Next 17 Replies Latest reply: Nov 19, 2012 12:19 PM by MacDaddi
pcottrell Level 1 Level 1 (0 points)

Screen flashes, remote client window is listed (in WIndow Menu), but not visible.   It is as if it is off-screen somewhere.  Any ideas?  I have tried deleteing from the all computer list and reconnecting with no luck.  Unfortunately it is a co-located Mini in a secure location - I can't easily get to it to put a real monitor on it.

  • pcottrell Level 1 Level 1 (0 points)

    I should have mentioned that this is Lion to Snow Leopard Server, and using current ARD.  THe issue seems to be related to the Fast User Switching issue back in the 10.4 days. but even a reboot in this case does not repair it.  Is it possible that damaged prcesses can survive a reboot?

     

    Do I need to do a kickstart even after re-booting?

  • TeenTitan Level 4 Level 4 (2,410 points)

    Hi Pcotrell,

     

    If I understand you. Your in ARD, The server is listed in your all comptuer list. You select the server from the computer list, and then try to view the screen. The ARD computer windows breifely opens and then closes by itself without warning?

  • pcottrell Level 1 Level 1 (0 points)

    Thanks for the reply.

     

    It doesn't ever open, but it is listed in the Window menu as being open.

     

    I have tried the suggestion of deleting the computer from the All Computer list and re-entering its IP in the scanner.  This has no effect - still hidden.

     

    I should mention that I am also not able to connect by VNC (Chicken of the VNC) or Apple's ScreenSharing, though I was able to do so before yesterday.

     

    I have a feeling it may be related to the fact that I used Fast User Switching via ARD - but I would have thought a reboot would set things right.

     

    I am able to interact with the remote computer through ARD in all other ways- (reporting, restart, UNIX) but I cannot see the screen.

  • TeenTitan Level 4 Level 4 (2,410 points)

    Have you tried connecting to the client using a diffrent computer? if so dose it have the same issue? was it a clean machine with no omputers in ARD all comptuer list, or a previusly used computer?

     

    assuming it dose have the same issue, and it was a clean computer:

     

    Have you checked to see if the firewall is on.  If it's off, it's worth turning it on, and then off agian.(but not via ARD, becasuse you could lock yourself out)

     

    When your trying to view the comptuers, have you made sure no other comptuers are currently being viewed?

     

    Have you tried viewing the secure log of the client when you connect?

    ie: SSH into the client. use "tail -f /var/log/secure.log" to view the secure log. While viewing the log, try connecting via ARD. You could try the same thing with the system log.

  • pcottrell Level 1 Level 1 (0 points)

    Thanks for the advice - I will try those things..  I have tried from multiple computers with the same result.  I can't easily go to the machine in question since it is in a secure hosted facility.  I should be able to test the log using SSH, though I am not terribly familiar with terminal (unix) commands..

     

    The firewall is not on, and as I say  it should only be the one port that is in use, and it is working in every way except feeding the screen view.

  • TeenTitan Level 4 Level 4 (2,410 points)

    well to try the terminal thing:

    1) Open terminal

    2) type "ssh username@serverIPaddress.

    3) yous hould be prompted for your password

    4) ones logged in, you should be able ot use "tail -f /var/log/secure.log"

     

    while connected you could also try restarting ARD Agent: (from Apple Remote Desktop: Configuring remotely via command line (kickstart))

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -restart -agent

     

    There are also commands like, let all users connect, and have full acccess.

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on -restart -agent -privs -all

     

    Or give full access to a specific user account:

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on -users shortUserName -privs -all -restart -agent -menu

     

    Is there any thing between the server and the internet? Also have you tried connecting from a diffrent ISP? (incase the issues is some how releated to your ISP)

  • Gordon Jones Level 2 Level 2 (155 points)

    i'm experiencing the same issue - attempting to control a mac mini from macbook pro - both on 10.7.2, ARD 3.51.

     

    when i attempt to conrtol the mini it seems to "take" but the window does not appear on the laptop. the mini is listed as an active window, but for the life of me, i can't find it.

     

    any thoughts most welcome.

  • Gordon Jones Level 2 Level 2 (155 points)

    ok, this fixed worked for me:

     

    https://discussions.apple.com/thread/3191199?tstart=60

     

    "The fix seems to be pretty simple, it looks like if you go to the sharing preference pane on the client machine, and then uncheck and check again the Remote Management option the screen control feature comes back to life."

     

    hope that helps someone else too.

  • pcottrell Level 1 Level 1 (0 points)

    Unfortunately I do not have physical access to the machine as it is in a data centre.  Does anyone know if it is possible to turn REmoteManagement on and off through SSH?

  • pcottrell Level 1 Level 1 (0 points)

    I have tried the kickstart routine and get the following on screen - does it look correct?

     

    <re -access -on -users admin -privs -all -restart -agent -menu              

    Password:

    Starting...

    Activated Remote Management.

    Stopped ARD Agent.

    Stopped VNC Server.

    Stopped RFB Register MDNS

    admin: Set user remote control privileges.

    admin: Set user remote access.

    Restarted Menu Extra (System UI Server).

    Done.

    savantadev:~ admin$

  • pcottrell Level 1 Level 1 (0 points)

    One of the suggestions is to turn off several items in the Sharing panel of System PReferences.  Does anyone know if running the kickstart routine does the same thing?  IE does it turn off all Remote Mangement, Screen Sharing, REmote Access?

  • pcottrell Level 1 Level 1 (0 points)

    I was able to see the log and these are the entries after I ran the kickstart routine.  Is there anything unusual in there?.:

     

    savantadev:admin admin$ tail -f /var/log/secure.log

    Feb  2 13:57:15 savantadev /System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/Ma cOS/AppleVNCServer[88972]: Authentication: SUCCEEDED :: User Name: pcottrell :: Viewer Address: xxx.xxx.xxx.xxx :: Type: DH

    Feb  2 14:19:47 savantadev /System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/Ma cOS/AppleVNCServer[88972]: Authentication: SUCCEEDED :: User Name: admin :: Viewer Address: xxx.xxx.xxx.xxx :: Type: DH

    Feb  2 15:47:20 savantadev sshd[91196]: in pam_sm_authenticate(): Failed to determine Kerberos principal name.

    Feb  2 15:47:25 savantadev sshd[91194]: Accepted keyboard-interactive/pam for admin from xxx.xxx.xxx.xxx port 55603 ssh2

    Feb  2 15:47:25 savantadev com.apple.SecurityServer[46]: Session 0x2f394d created

    Feb  2 15:47:25 savantadev com.apple.SecurityServer[46]: Session 0x2f394d attributes 0x20

    Feb  2 15:57:10 savantadev com.apple.SecurityServer[46]: Session 0x2f04f4 dead

    Feb  2 15:57:10 savantadev com.apple.SecurityServer[46]: Killing auth hosts

    Feb  2 15:57:10 savantadev com.apple.SecurityServer[46]: Session 0x2f04f4 destroyed

    Feb  2 16:01:58 savantadev /System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/Ma cOS/AppleVNCServer[91468]: Authentication: SUCCEEDED :: User Name: pcottrell :: Viewer Address: xxx.xxx.xxx.xxx:: Type: DH

  • TeenTitan Level 4 Level 4 (2,410 points)

    Remote Login is SSH. And the fact you can SSH in, tells us 'remote login' is working fine. Cosndiering Remote login is a seperate service that is working properly. turning it off would just make you have another issue.

     

    Kickstart has to do with Remote Management. (ARDAgent) Kick start can be used to start and stop Remote Management. WItch is the same thing as uncheck, and then re-checking Remote Remote Management.

    /System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/Ma cOS/AppleVNCServer[91468]: Authentication: SUCCEEDED :: User Name: pcottrell :: Viewer Address: xxx.xxx.xxx.xxx:: Type: DH

    This is the normal response for a suecesfull connection VIA ARD.

     

    Have you tried using connect to server to conenct to the server using the finder instead of ARD?

     

    ie:

    go to dock

    click on finder

    go to menu bar

    click on go menu

    chose connect to server

    for the address type in vnc://serverAddress

  • pcottrell Level 1 Level 1 (0 points)

    Thanks for sticking with the issue - I appreciate your efforts.

     

    However, same issue with ScreenSharing via Safari or Connect to Server.  I get an active session, but no visible screen..

     

    I simply can not believe that there is not a know solution to this issue. There must be a way to delete whatever preferences have been corrupted on the remote machine without physically attending.

Previous 1 2 Next