0 Replies Latest reply: Jan 12, 2012 7:50 PM by Michael4824
Michael4824 Level 1 Level 1 (0 points)

So, I was sitting in the hall way, waiting for class to start, browsing the internet on my laptop.  Once the bell rang, I closed the lid of my laptop, walked inside my class room, and sat down.  When I opened the lid, the screen was black, but the "indicator light" on the front right corner was a solid color.  Occasionally my computer won't come back on (not too often, but enough to know that I've seen it before), so I held the power button down, waited to hear that "click", and attempted to turn it back on.  The computer attempted to turn back on, but after a little bit, the Apple logo disappeared, and was replaced with a circle with a dash through it.  The "wheel" on the bottom remained spinning.

 

I didn't drop the computer, or make any abrupt movements, but I think it's the disk that died.  My main goal is just to get a solid "yes", it's only the disk, before I go and spend the money to replace it.  I didn't have any warning signs before hand that the disk was about to die.  I'm a Computer Science major, so I'm almost always on my laptop.

 

I've tried resetting PRAM and SMC.  Single user mode and verbose mode both fail, usually with the last few lines something like:

[code][IOSATA WARNING: Enable auto=active failed.

AppleAHCIDiskQueueManager::setPowerState(0xffffff800b897000, 2 -> 1) timed out after 100540 ms.[/code]

 

I've tried booting into Lion's recovery partition, but the same thing happens.  Circle with a line through it.

 

I've tried Snow Leopard upgrade DVD, but after 5 minutes or so, the screen freezes (DVD quits spinning), and the wheel stops mid circle.

On the Leopard recovery disk that shipped with the computer, it freezes at a light blue screen.

With the Lion recovery DVD I made.  The disk eventually loads, but the built in mouse and keyboard fail (both of which work in the boot loader menu (option on boot)).  If I use an external mouse, nothing happens when I choose a language to use.

 

I purchased a Firewire cable earlier today, and I'm hoping to hook it up to my Mac Mini to see if I can get anything.  I just finished a program for one of my classes last night, and unfortunatly, my last Time Machine backup is about 2 days too old...

 

Thanks for any help.


MacBook Pro 13inch (2.53GHz), MacMini, Mac OS X (10.7.1)