Previous 1 2 3 Next 42 Replies Latest reply: Jul 18, 2015 9:41 PM by Evan C.T. Go to original post
  • FrankiLogan Level 1 Level 1 (0 points)

    Thanks for the reply, I totally missed that entry. I had those issues (skipping, artwork, etc) before, let's see what happens now. Wish me luck :)

  • dpx Level 2 Level 2 (245 points)

    I have just successfully deleted my greyed out songs.

     

    If you turn on 'Manually manage music and videos' in the Summary page then right click the songs; you are then given the option to delete them.

     

    This sorted them out for me.

  • rockmyplimsoul Level 5 Level 5 (6,260 points)

    Although that is not related to my issue (from 2 years ago on iOS 5) I did have a similar problem when first installing iOS 7.

     

    After the iOS 7 installation I had to do as you said above, changed to manual sync and manually deleted.  But to really get the ghost entries to stay away I had to take it a few steps further:  In manual mode I had to delete all songs, perform a backup once everything was deleted, restored to the backup, then changed back to auto-sync to my specific playlists.  Only then were these rogue songs permanently deleted.

  • dpx Level 2 Level 2 (245 points)

    My grey songs came back as soon as I auto-synced. The songs in question were from the 12 days of christmas app, they were deleted and hidden but still were stuck in my phone, greyed out. They were more of an annoyance than anything. I found other threads about this and I followed the advice from this one...

     

    https://discussions.apple.com/thread/5369825?start=0&tstart=0

     

    ...and now they have gone forever, hopefully.

  • Olivier Barrellier Level 1 Level 1 (0 points)

    Worked for me (just the Purchase dir).

     

    Thanks leeg330

  • michaelc Level 2 Level 2 (155 points)

    leeg330's suggestion worked! Holy moly, this has bugged me for over a year. THANK YOU!!!!

  • xoxoboi24 Level 1 Level 1 (0 points)

    Leeg30 - thank you! i think this issue is finally done with! 

  • landm4 Level 1 Level 1 (0 points)

    I had this problem syncing music or movies to ipad2. Had ghost circles of whatever I tried to sync. Problem fixed by unchecking all songs, movies, books on itunes on imac, applying to ensure all cleared from ipad (check lloking under 'on my ipad'), then was able to sync as normal.

  • indrasuryatama Level 1 Level 1 (0 points)

    This solved my problem,

    At the beginning I've Sync problem and there is 5 ghost song, after i done this step, Everything went back without Restoring my iPhone

     

    And to delete the music that not shown in itunes (not sync) go to Settings->General->Usage->Music and clear from that menu

     

    Thanks Rock!!!!!

  • Noah000000 Level 1 Level 1 (0 points)

    This conversation is really old but I hope people are still around. I had this problem and I used the same solution. It worked temporarily, but every time I sync new phantom songs appear. The weird thing is these songs are different every time. Has anyone had this problem?

  • travisfromfraser Level 1 Level 1 (0 points)

    Had the same issue, so frustrating.  Finally got it; try these steps:

     

    From your phone:

    Settings > Music - toggle "Show All Music" to off.

    Open music app - identify all songs that are on your device.

    Settings > Music - toggle "Show All Music" to on.

    From the music app, download songs from iCloud identified in step 2

    Settings > General > Usage > Manage Storage > Music > Edit > All Songs > Delete

    (Optional) Settings > Cellular - In "Use cellular data for" locate Music App and toggle off.

    Settings > Music - toggle "Show All Music" to off.

    Sync with iTunes

     

    At which point I had about three quarters of them gone.  If there are more remaining:

     

    Download and install iExplorer http://www.macroplant.com/iexplorer/

    Plug in device first, then open iExplorer

    Delete the iPhone\Media\iTunes_Control folder (you may want to copy this, just in case)

    Restart the iPhone / iPad

    Start iTunes. Not restore iPhone from back up, select New iPhone (don't worry, you will not lost apps or data on your iPhone doing this)

    Sync with iTunes

  • Run Through It Level 1 Level 1 (0 points)

    I had a slightly similar issue with the ghost songs.

    I went through my music library on my iPhone while connected to iTunes on my computer in order to delete music from my iPhone. I share music with my family, and a lot of songs that I don't personally enjoy manage their way into my library. After discovering I had hundreds of songs that I simply disn't listen to, I began to delete them, seeing it as a way to create more storage space. After deleting many of them, I discovered that all of the ones I had removed were still there in my library, but grey. They could not be opened up, and were simply there and in the way.

    In order to delete these "Ghost Songs" I went into my Settings, then Music, then turned off the "Show All Music" button. Worked like a charm.

  • Evan C.T. Level 1 Level 1 (0 points)

    Haha, I know its been what, 3 year since youve posted this?

     

    Thank you so much. I backed up my stuff on my phone, restored my phone to factory settings and then put all my data back on.

    Not only did the copys delete, but I got back multiple songs that I lost due to iTunes problems.

     

    Thanks!!

Previous 1 2 3 Next