8 Replies Latest reply: Jan 15, 2012 3:04 PM by Linc Davis
JeffinLondon Level 1 Level 1 (0 points)

2 year old MacBook Pro i5 17" 4GB RAM 500GB disk

 

Background...  I'm a reasonably good Windows techie, this is my first MAcBook, so I'm really not up to speed on some of the Unix lingo, but I'm a fast learner and want to learn more about how this beast works!

 

Anyway ...  I recently had a disk crash, replaced the HD at the Apple Store here in London, and then reloaded my files back from a Carbonite backup. Then feeling brave I upgraded to Lion and have been sorting out application upgrades all week.  What a process....


Anyway, at pretty regular intervals, the machine will grind to a halt, the spinning beach ball of death will appear and a pop up window will open that says:

 

Your Mac OSX startup disk has no more space available for application memory.

 

The window lists all the open apps and gives me the opportunity to shut them down. At this point on Activity monitor I see almost zero free memory available, but plenty of CPU available. A few times I saw a process called SafariDAVclient using nearly 2GB of memory(!) I would kill it and it would reappear. it seems gone for good now, but Safari itself seems to eat up memory  up to 2GB. My VM size seems huge to me (180GB) as well.

 

The message itself makes no sense to me because there is 320GB free on the HD.

 

Can anyone tell me in technical terms what the message means, and how I might change my configuration to prevent it from happening?

 

Also, what's up with Safari? Does it always use 2GB of memory? Seems insane for a browser.

 

Thanks in advance,

 

Jeff


MacBook Pro, Mac OS X (10.7.2), 4GB RAM 500GB HD i5
  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Do you have Clean My Mac installed and have you tried repairing permissions?

     

    http://apple.stackexchange.com/questions/18409/startup-disk-has-no-more-space-av ailable-for-application-memory

     

    User at that link is running v10.6 but same error message.

  • JeffinLondon Level 1 Level 1 (0 points)

    I'll get Clean my Mac and try that, and yes I have done the repair disk and repair permissions.

     

    At the moment, I have ditched Safari and am using Chrome and that has at least for now fixed the problem.

     

    Safari was growing to over 2.5GB and then crashed.

     

    Thx for the help.

  • Linc Davis Level 10 Level 10 (158,885 points)

    The message means that a swapfile could not be created. It has nothing to do with file permissions. One of the first things you should learn about the Mac platform is that "repairing permissions" in Disk Utility, although hugely popular, is a waste of time unless you have a specific indication of a permission error involving system files -- which you don't, and probably never will. It spews bogus error messages that sometimes frighten inexperienced users into taking drastic and unnecessary actions.

     

    The second thing you should learn is that with few exceptions, commercial "utility" software for the Mac is useless if you have adequate backups -- which you must have.

     

    A VM size of 180 GB is perfectly normal. Mine is 324 GB right now.

     

    Since you have plenty of space on your startup volume, the error message you saw was invalid. I've seen reports of similar errors, and they seem to represent a bug in Lion. I don't know what triggers it. A reboot seems to resolve the issue, at least temporarily.

  • Linc Davis Level 10 Level 10 (158,885 points)

    I'll get Clean my Mac...

     

    That brings up the next point you should learn. Most of the usability issues reported here are caused by defective or incompatible third-party software that users install; specifically, third-party system modifications like that one. If you want a usable computer, don't install such things unless absolutely necessary to get your work done. Above all, never install any third-party software unless you know how to uninstall it. There is no built-in uninstallation method as there is in Windows.

  • JeffinLondon Level 1 Level 1 (0 points)

    Thanks link...  The 'Clen my Mac' did delete a few hundred MB of log files, etc, harmless I suppose but not hugely helpful as well.

     

    And no 'uninstall' ability...  ??  egads, I'm disliking OS X already! 

     

    Anyway, since I stopped uping Safari, the error message seems to have gone away. Chrome works just fine.  I posted the Safari crash report over on that forum, maybe you can take a look to see if anything jumps out at you.

     

    Thanks again ... btw, I ordered "The Missing Manual".  Is that a useful book for wannabes like me or is there a better book on the market?

     

    - JIL

  • Linc Davis Level 10 Level 10 (158,885 points)

    You didn't mention a Safari crash in your original post. I can tell you that Safari works fine for me, and probably for most people. Do you want to troubleshoot the problem or are you satisfied with things as they are?

  • JeffinLondon Level 1 Level 1 (0 points)

    I do want to trouble shoot the problem.

     

    - Originally there were no 'crash' problems. The system would just lock up and finally stop with the 'no application memory in statrtup disk message'

     

    - Someone here suggested I switch Safari to 32-bit mode; I did that, and Safari would then crash every time I ran it.

     

    - You then asked me to post the crash report, which I did, and then suggested I switch to 64-bit mode.

     

    - So I am back in 64-bit mode, and the original behavior has returned. Safari grows to use about 2GB real memory and the the system stops, and I get the no application memory message.

     

    Can you suggest anything else to look at ?

     

    Thanks,  Jeff

  • Linc Davis Level 10 Level 10 (158,885 points)

    I just noticed that you have two simultaneous threads going on this topic. Please don't do that. I'll respond in the other thread.