Previous 1 2 Next 22 Replies Latest reply: Nov 6, 2013 9:23 PM by DazedAndContused
aubreedee Level 1 (0 points)

I have an Apple TV 1st generation that I tried to do a factory restore on.  I did not unplug durring the progress bar.  It then started up with the apple, then the opening video with all the tv screens.  It asked me for the language, I selected English, then had me choose the correct internet connection so I typed in the password for our Wi-Fi, then it came up with the code to connect to our home computer and started flashing a new code every 2 seconds.  I unplugged the Apple TV and waited about a minute then plugged back in.  It again had the normal start up, but then after the opening video it began flashing between a screen with the apple then a blank black screen then to a menu screen and cycling through each screen about every 1-2 seconds.  I unplugged again and waited about 10 minutes but then had the same results.  Is there anyway I can do another system restore as I cant get it to stop flashing. 

  • aubreedee Level 1 (0 points)

    K I found an answer on similar thread that had a link on how to do a FORCED RESTART: (scroll down to # 4)


    The forced restart worked like it was supossed to.  I ran dianostics and it said my Apple Tv was working fine, then I selected RESTART.  I had the same results.  So I forced restarted again and did another dianostic test.  Again it said everything was fine so this time I did a FACTORY RESTORE and I am still having the same problem of flashing screens. 


    Is there any other options?  I am wanting to give this to a friend who does not have the money to purchase a new apple tv, plus has an older tv and does not have the option for an HDMI cable. 

  • Rudegar Level 7 (24,610 points)

    the atv1g is at the end of it's line

    apple will never make another update for it

    it works pretty much with hdmi setups

    doubt you should hold you breath for a compatability fix for your older tv

  • aubreedee Level 1 (0 points)

    I FIXED IT!!!  So here is how to fix your Apple TV 1st generation if you are having the problems listed above.  I am listing it step by step as I have not found the solution to my problem ANYWHERE and I have been looking all day and figured it out myself.  Here we go:


    If you have done a FACTORY RESTORE and it is now flashing different through different screens I recomend doing a FORCED RESTART from the totally awesome guys at MethodShop, here is the link:


    If their instructions do not fix your problem here is what I figured out (assuming the diagonstic test says that your Apple TV is working correctly).


    Keep your Apple TV plugged in, and allow it to go to sleep.  It can take up to 45 minutes.  Once it has gone to sleep (the screen will have photos scrolling on the TV) press the MENU button on the remote to wake it up.  The Apple TV will wake up on the MENU screen.  Scroll down to SETTINGS then select SYSTEM UPDATE.  Follow all instructions to update the system to the current update. 


    WARNING: If you take too long once you have woken up the Apple TV it will start freaking out again and you will have to let it go to sleep again.


    I have tried this twice now to make sure the first time was not a fluke and its working perfect now.


    Hope this helps someone else!

  • ESN Level 1 (0 points)

    Having the EXACT same problem.  My hard drive failed on my PC and I had to do a complete Windows 7 restore.  Everything went smoothly (including restoring my iTunes library and syncing w/ my iPhone 4s and iPad).  But my 1st gen ATV wasn't showing up in iTunes and I couldn't figure out a way to force iTunes to look for it without erasing the content (under Computers in 3.02) and resyncing.  I figured if I was going to go through that trouble I may as well do a full restore and defrag the drive, etc (had issues a year or so ago where the ATV ran really slowly and a restore fixed it).


    Anyway I did the restore and was having this exact problem. Ran the diagnostic and it said everything was fine.  So I tried another restore and same issue.  Haven't tried the reset yet.  If that doesn't work I will try your trick of letting the ATV go to sleep.  Right now I have it unplugged because it seemed like it could hurt hte ATV to have it stuck in this setup loop.


    Will give it a shot tomorrow.

  • bakso Level 1 (0 points)

    Thanks all for this info. Somehow I was playing with my ATV2 next to my ATV1 and I managed to reset it to factory defaults while using the ATV2 (the remotes are interchangeable). Got stuck with this annoying situation of flashing apple logo bakc and forth to the menu. It seems related to the network connetivity. I unplugged and let my ATV cool down for an hour first.


    With the help from this post I did the forced reset and managed to connect to my wireless network (no password) during first setup. Then I could navigate to download to the newer firmware. After 15 minutes I felt I should plug in the ethernet cable. It mentioned the download could not be completed and started the Apple logo again.


    Then I unplugged again and put it in the freezer for 10 minutes (I live in the tropics, so i wanted to start with a cool machine). I waited another 10 minutes to get rid of condensation and redid force reset, factory restore and connecting to wireless (no LAN connected of course) during initial setup. Now it is downloading the upgrade again, so I won't touch anything and just pray for the next 2 hours or so. I've disabled screensaver.


    I hope I'm not over confident, but will post back if needed.

  • Clifftheif Level 1 (0 points)

    Amazing, waited for the screen saver, then updated and shes back to normal! THANK YOU!

  • andersofnorway Level 1 (0 points)

    works! thanks! i was so confused with the problem, I waited for the screen saver and updated and its normal!! yay i dont have to throw away this box

  • Hsotnicam Elppa Level 1 (0 points)

    1st Gen Apple TV doing the same, but I found that the error start point is connecting with my iTunes library. 

    1. I factory reset the iTV, but did not connect to my iTunes library.

    2. Pulled frozen corn out of the freezer and put in the pressure cooker for 12 minutes

    2. Boil 2 qts of water and add 16 oz of pasta

    3. Cook pasta for 8-10 minutes and then dump a jar of sauce all over

    4. installed the updates and then

    5. pulled the corn out of the pressure cooker

    6. Ate the corn and pasta watching the download icon spin and sipped a tall glass of Country Time Lemonade

    7. Updated more until Apple had nothing left

    8. connected to my iTunes library and watched

    9. The Big Lebowski



  • Jim_Guidry Level 1 (0 points)


    It took about 4 depressing minuites of blinking after the screen saver was cancelled, but after that it ran great. 


  • laserob Level 1 (0 points)

    While the ATV is in the loop, unplug the network cable to stop the loop.  Then hover over software update, plug in your network cable and quickly select update (will say no update available) then immediately press menu, then select update again.  I was able to then see the download update now option.  Hope this helps!

  • Thomas Hanford Level 1 (5 points)

    Laserob - thanks for your post - this did the trick for me - after a few days of experimenting with virtually everything!

  • gustavohm-11 Level 1 (0 points)

    Thanks laserob! Followed your instructions and Apple TV is up and running!

  • ninjapig Level 1 (5 points)

    Thanks Laserob! Although I couldn't quite get your fix working.  The timing was juts too tight - I could get to the download update option, but the loop would ALWAYS cut back in and it was driving me nuts!  I tried it so many times - it was me playing out the definition of insanity.


    BUT - in frustration I stumbled across another fix!  When the cable is plugged in and the loop was switching between the menu and the Apple logo - I pulled it out, but before waiting until it stopped flashing - I plugged it back in again!  Then - once it did stop flashing a second or two later - the cable was still plugged in and therefore I was connected to the network.


    I could then go to Settings and update the software with no fear of the dreaded loop returning.  It updated and now it works great!!  Thanks for your post - without that I really think I would have been stuffed.

Previous 1 2 Next