9 Replies Latest reply: May 13, 2012 11:11 AM by geminidiva67
ankitnavgwal Level 1 Level 1 (0 points)

hello,

I can see my wifi which is WPA2 AES secured, but when I enter my password it says "unable to join network" I have a netgear wg111v3 router which is working fine for other device. I've tried turning the router and iphone off and on, but no change.please help me...my phone has iOS5.0.1 ver of software.


iPhone 4, iOS 5.0.1
  • diesel vdub Level 7 Level 7 (21,975 points)

    Has it ever connected to that Wi-Fi network?

    Try Settings > General > Reset > Reset Network Settings.

    Verify on the router that MAC address filtering is either off or the MAC address of the device is entered into the allowed list.

    Temporarily turn off security to ensure the device can connect.

  • Michael JCM Level 1 Level 1 (0 points)

    iPhone4 iOS5.0.1

     

    Same problem in my case. Issue started recently, could be linked to the iOS5.0.1 upgrade ?

    No problem at home but impossibility to connect to secured networks in hotels and other friends house in other countries.

     

    diesel vdub "Try Settings > General > Reset > Reset Network Settings.Try Settings > General > Reset > Reset Network Settings." did not work for me. Other pqrt of the solution not applicable as I do not have access to the router.

     

    Any other recommendations ?

  • ttricia Level 1 Level 1 (0 points)

    I have the same problem, have reset router (new apple extreme - which is when problem started) a number of times to no avail. Ipad links and imacs but not phone, pc or playstations.

    Did anyone solve their problem with this....?

  • Haverty Level 1 Level 1 (0 points)

    I have a Belkin N600 router with two networks defined - my main network and a guest network.

     

    All my devices except my iPhone connect fine to the main network. My iPhone can 'see' the main network but when I try and connect I get 'unable to join the network'. It doesn't even ask for the key.

     

    My iPhone connects just fine to the guest network.

     

    What on earth could cause this?

  • ttricia Level 1 Level 1 (0 points)

    Hi Harverty I have had the same problem but with the airport extreme... It's basically because it's an "n" router geared up for new wireless devices i believe. My iphone strangly isn't one of them  nor the new PS3 ...!!

     

    The settings below worked on my new Apple extreme  to get iphone & PS3 to link BUT the downside is the connection speed gradually got slower and slower on everything.... Switch back my to normal settings on extreme mac and other devices rock at super speed -  but iphone and ps3  although they see both main and guest can't connect again....

     

    Go to Wireless

    Radio Mode:  choose 802.11a/n - 802.11g

    Radio Channel Selection - Manual

    click EDIT: chose manually the channels, 48 (5 Ghz) and channel 5 (2,4 Ghz).

    Choose WPA/WPA2 Personal as security settings.

     

    I wish I had my old router back with it's old technology as everything work perfectly fine on it for years till it died....

  • Haverty Level 1 Level 1 (0 points)

    Thanks ttricia. I’ve tried the settings you suggest as well as many other combinations, all without success.

     

    It seems crazy that my iPhone connects perfectly to the guest network but not the main network on the same router, even though it can clearly see it. Every other device I have connects just fine.

     

    I think I’m going to revert to the n router supplied by my ISP and sell the Belkin. I bought the Belkin mainly for dual-band and increased range. I can live without dual-band, and see no significant increase in range, so the Belkin may as well go on eBay.

  • Arouellevt Level 1 Level 1 (0 points)

    Thank you! The reset network in general settings did the trick! 

  • DrBukk Level 1 Level 1 (0 points)

    I had to tell my phone to forget the network it was detecting and then it gave me a chance to enter my password. It's case sensitive. This is on a Belkin.

  • geminidiva67 Level 1 Level 1 (0 points)

    Thank you, ttricia!  These settings worked perfectly to solve my issue with joining my Belkin N750db network.