6 Replies Latest reply: Feb 16, 2012 7:11 PM by suirauqa
paulpleiss Level 1 Level 1

My Iphone 4s keeps losing wifi signal at home.  My phone will still show wifi connectivity, but I will be unable to access any webpages or internet services.  The only way to get it back is to restart the phone.  Turning on/off wifi or putting airplane mode on/off does not work.  I am concerned that I got a "lemon" of a phone.  Any ideas or help?

 

-Paul

Reply by Anthony K. on Jan 16, 2012 6:48 PM Helpful

Did you update the last firmware. 5.0.1 (9A406)? check at settings / general / about / version

 

If not, back up at iTunes first, restore 5.0.1 newest firmware, try connect wifi first, see any difference. If works, then restore your back up.

 

You must choose restore button in iTunes.

All replies

  • Anthony K. Level 1 Level 1

    Try to Reset Network Settings at reset page. Reconnect wifi, make sure correct wifi password.

  • paulpleiss Level 1 Level 1

    Still no joy.  The WiFi doesn't seem to be the issue as my computer and other devices continue to work fine, it's just the Iphone4S that keeps failing.

     

    -P

  • Anthony K. Level 1 Level 1

    Did you update the last firmware. 5.0.1 (9A406)? check at settings / general / about / version

     

    If not, back up at iTunes first, restore 5.0.1 newest firmware, try connect wifi first, see any difference. If works, then restore your back up.

     

    You must choose restore button in iTunes.

  • paulpleiss Level 1 Level 1

    I'm in the middle of a restore right now.  We'll see what happens for the next 24hrs.

     

    -P

  • Anthony K. Level 1 Level 1

    If wifi ok, try to do the followings steps, those helps me to save the battery. Try it.

     

    1. Go to Settiings / General / Siri / turn off Raise to speak and then reboot.

    (A sensor upper the earphone is continuing on even if you turn it off, YOU MUST REBOOT YOUR IPHONE AFTER THAT.)

    I think that it is the major problem about battery drain.

     

    2. Go to Settings / Location Services / System Services / Turn off Setting Time Zone

     

    3. Go to Settings / Notifications / Turn off Calendar, weather, stock or move them to Not in Notification Center

    (calendar may be not need but I don't use this function, so I turn it off.) (Weather and stock always runs GPS or  internet to update the states.)

     

    4. Click weather and turn off local weather. Set your area in the weather list. If using local weather, it always run the GPS.

  • suirauqa Level 1 Level 1

    Are you sure it's 9A406? My phone says 9A405.