Previous 1 2 3 Next 31 Replies Latest reply: Jan 4, 2015 9:05 PM by SolarBeenleigh Branched to a new discussion.
Schmatty Level 1 Level 1 (0 points)

Bing randomly became my defaut search engine today. The search bar in the upper right hand of my safari says google and google is checked off as my selected search engine yet, everytime i use that search bar, bing is what is used instead of google. This is very annoying as nothing i do fixes it and I freaking hate Bing.

Please help!!!!

Thanks.


MacBook Pro, Mac OS X (10.7.2)
  • Linc Davis Level 10 Level 10 (141,490 points)

    Select Safari > Preferences > Extensions. Are any Safari extensions installed?

  • Schmatty Level 1 Level 1 (0 points)

    no there are no extentions, i even turned extensions off and still nothing

  • Linc Davis Level 10 Level 10 (141,490 points)

    Launch the Terminal application by entering the first few letters of its name into a Spotlight search. Drag or copy -- do not type -- the following line into the window:

     

    defaults read -g NSPreferredWebServices

     

    Press return. Post any lines of output that appear below what you entered -- the text, please, not a screenshot.

  • Schmatty Level 1 Level 1 (0 points)

    This is what came up:

     

    {

        NSWebServicesProviderWebSearch =     {

            NSDefaultDisplayName = Google;

            NSProviderIdentifier = "com.google.www";

        };

    }

  • Linc Davis Level 10 Level 10 (141,490 points)

    Please read this whole message before doing anything.

     

    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    The purpose of this exercise is to determine whether the problem is localized to your user account, or is system-wide. Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select “Help” from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Any application you run will behave as if you were running it for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    As Guest, launch the application(s) and test. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

  • Schmatty Level 1 Level 1 (0 points)

    That fixed it! thank you so much!

  • Eric Moccio Level 1 Level 1 (5 points)

    It is hard to see what it is that you did to fix this problem. My brother is experiencing this too. Could you clarify how you fixed it?

     

    Thanks

  • CP71 Level 1 Level 1 (0 points)

    Hi there

    I have tried everything and this Bing installation seems to have really slowed down my Mac.

     

    In Safari Preferences

    - My Default Search Engine is Google

    - I have previously uninstalled installermac in Extensions and that hasnt worked

    - I have reset Safari

    - I have tried the suggestion above and when I type into Terminal the text outlined it does nto retrieve anything

     

    Bing is driving me Bang!

     

    Any help would be appreciated

  • elquevulguis Level 1 Level 1 (0 points)
    1. Go to Safari and select "Preferences"
    2. Under the General section go to "Home Page"
    3. Change the home page from the Conduit search option to something else (e.g. www.google.com)
    4. Keep the dialog box open and select the "Exensions" tab.
    5. Find the Conduit Search tool, select "Uninstall" and click the "Uninstall" button.
    6. Close and reopen the browser to see the changes take effect.

    Note: At this stage Conduit Search is removed, however address bar searches may still be set to Bing. To change address bar searches to Google or Yahoo! select the magnifying glass on the left-side of the address bar and choose your preferred search provider from the drop-down menu.

     

    copypasted from: http://forums.divx.com/divx/topics/bing_search_page_appears_when_opening_a_new_t ab_window_on_firefox_macos

  • Soniazam Level 1 Level 1 (0 points)

    Just to say that elquevulguis' solution above fixed it for me - phew!

  • Clark-Gawne Level 1 Level 1 (0 points)

    Elquevulguis,

     

    I have gone to preferences, set google as my home page, i have removed all conduit search options, closed safari and reopened it. The conduit search options appear removed however BING still is!

     

    I have the magnifying glass on the left-side of the address bar set to google and Bing will still take over the search, Its really frustrating!!

     

    I have reset safari and still BING takes over my searches.

     

    Is there something else i can do to remove this from my computer?

     

    Really appreciate your assistance.

  • davidoff_p Level 1 Level 1 (0 points)

    I have the same problem Clark

    Very annoying

  • mbmow Level 1 Level 1 (0 points)

    I had the same propblem for a week. I changed the home page to google . reset safari. and bing came back.

    Then I changed the home page to one of the other pages that was listed. i.e. yahoo. closed and reopened safari. searched and it worked. Then changed the home page to google and did the same again. Now all fixed

  • dan one with spirit Level 1 Level 1 (0 points)

    Went to prefs, then extensions. Omnibar was listed. Did a search (yes, bing did it!) and found that omnibar enables the address bar to be used for searches.

    Back to the prefs; extensions>omnibus has a drop-down menu there. 2 choices: "genie" and default. It was set to genieo; switched it to default.

    Now I'm back to google!!!

Previous 1 2 3 Next