10 Replies Latest reply: Jan 26, 2013 7:28 PM by The Art Of Sound
kagakuninja Level 1 Level 1

I bought Logic Pro from the app store a couple weeks ago.  This is being installed on a new Macbook Pro, to replace my old copy of Logic Express.  Every time I try and run Logic, it wants to download 2 GB of files.  When the download is finished, it asks for my admin password; I type it in, and Logic quits.  When I run again, it wants to download again.  I've done this twice, and it still wants to download.  We are talking several hours of load on my internet connection.

Logic Pro, Mac OS X (10.7.2)
  • Pancenter Level 6 Level 6



    This has been mentioned before but I don't know if a fix was ever posted.

  • kagakuninja Level 1 Level 1

    I found a possible answer in this thread:




    I'm downloading the 2GB files, for the 3rd time (hogging my internet bandwith for 4 hours).  I have a new machine, current OS, and adequate disk space.  This bug is inexcusable.

  • kagakuninja Level 1 Level 1

    This is ******* me off.  I've deleted everything I could find relating to Logic, rebooted, re-downloaded it, and tried the trick of saving the 2GB download.  It still can't install and run.  Is there any way to talk to or email a human at apple?

  • kagakuninja Level 1 Level 1

    OK, I downloaded again, after the re-install, and magically it worked.  F'n unbelievable.

  • Pancenter Level 6 Level 6

    kagakuninja wrote:


    OK, I downloaded again, after the re-install, and magically it worked.  F'n unbelievable.


    Yeah, the same scenario has happened to several other folks.. on one system the (evidently) partial download started to install and ended up causing errors on the system drive.


    Welcome to the new Apple.. I've noticed since the iphone, ipod, ipad frenzy has taken off customers seem to receive less consideration than before. It's more like a take it or leave it deal.. maybe that's the way it always was and is just more obvious now.

  • k19c61 Level 1 Level 1



    I'm having the same issue. I have an iMac 3.2Ghz Intel Cor i3, 4GB RAM, running OS X v10.6.8. 


    Last night I ordered Logic Pro 9 from the Apple Store and started the download. It was going to take a while so I went to bed.


    Next morning it was hung at 1.9GB of a 2.0GB download, so I canceled the download. I shut off the screen saver and energy savings options in Preferences and tried downloading again. And again. Then I started researching what was happening, and finally came across your post.


    I guess the Logic Pro.app (about 443.5MB) goes online and starts downloading a 2.0GB file that contains "Basic Content".


    I read that perhaps one of the files was corrupted, so I threw all the downloads in the Trash and went to the App Store to download again (3rd time). OOOPS! No longer does it say "Installed" --- it says $199.99. Yikes! And Logic Pro 9 is not listed as one of my purchases on iTunes or in the App Store.


    I went to the email that Apple sent to confirm my purchase and tried to "Report a Problem" by clicking the link on the email. Failure again!. The "Report a Problem" button is entirely missing from the page that comes up in iTunes.


    Got my fingers crossed this last download will work for me. I've been very satisfied with Apple until this event. Argghh! It's like Microsoft, but worse.

  • k19c61 Level 1 Level 1

    I used the Disk Utillity Repair Permissions and that seems to have done the trick, at least as far as getting Logic Pro to load all the Basic Content. Getting the App Store to recognize that I've purchased Logic Pro 9 is another story.

  • andrewguitarist Level 1 Level 1

    I literally just had this same problem. I resterted my computer...downloaded again and it worked. My problem not is once it came up it had some other content i could have download but by mistake i passed over it. Does anyone know where i go to access this infromation again to be downloaded??

  • andrewguitarist Level 1 Level 1

    Btw idk why everyone is having such problems with download time. Mine only took around 5 min to instal and then all the "Extra content" took 20 min :/

  • The Art Of Sound Level 6 Level 6

    Quite a few people who had this issue... discovered the problem actually lay with their Internet Service provider...


    Several limit the size of any given single file to less than the size of the Additional Content download file... which causes the download to prematurely terminate before it has finished downloading... causing Logic to sometimes (Though not always..) having to download again from the beginning.. as the file gets corrupted by the abrupt manner in which is was terminated. This explains why some people have to do the download several times before it completes successfully.. and others, no matter how many times they start the download, find it never ever completes successfully.


    A call to their ISP requesting a temporary (or in a couple of cases... permanent) increase in this max file limit..,in every case, resolved the issue...


    Known ISP's who have been reported as having / causing this issue include BT, Comcast, Time Warner, Northlands, Frontier & Verizon DSL (Not FIOS) and there are probably others I can't recall.. or don't know about yet.


    The typical max file sizes.. for one contiguous file.. have been reported as either 2GB, 4GB, 5GB or 10GB... depending on the ISP and the type of Account the customer purchased from them. There are several types of account (Some older/grandfathered in ones and some business ones for example)  that do not have any limit... so it is very dependant on what, who and when...