5 Replies Latest reply: Jan 19, 2012 6:40 AM by Dolg213
Dolg213 Level 1 (0 points)

Hi all,


I have read what has been said o nthis topic on the boards.  I have my Apple TV with an optical out and HDMI out both going to a receiver.  I can switch receiver HDMI outputs (watch a show on tv) with the Apple TV sound still working.  However, as soon as I turn off the TV, the Airplay stops.


There has to be a way around this.  I mean its ridiculous of Apple to think that everyone always needs to have the TV on to listen to music.  Is there a setting or something I can change?  This is one of the main reasons I bought Apple TV, it seemed like more bang for the buck than Airport Express.  All I want to do is play music wirelessly!

AppleTV 2
  • djbutt63 Level 1 (5 points)

    I am also very irritated with this - also expected that it would be able to replace my airport express for streaming music to the home stereo. I can see no logical reason for this limitation!!

  • gusjc Level 1 (20 points)

    I can listen to music through my receiver without having my TV on. Must be a receiver/TV-specific setting.


    Try starting AirPlay with the TV already off and see if that works. If not, you should check your receiver/TV manuals to see if there's some setting which could be messing things up (such as Control for HDMI, or Bravia Sync, Philips EasyLink, etc).

  • Eric Goodill1 Level 1 (20 points)

    I have my HDMI output going to my TV and my TOS output going to my receiver. When I turn my TV off, the audio continues allowing me to stream music from my iTunes library to my AppleTV and then to my receiver via AirPlay. I don't know if my different connectivity makes the difference or not.



  • Matthew Smith Level 5 (6,790 points)

    Check the settings on your TV. It sounds like the TV is controling the Apple TV. When the TV turns off it is turning off the Apple TV.

  • Dolg213 Level 1 (0 points)

    I figured it out -


    Apple released a software update about a month ago.  Go to settings > update software


    It will work after this