3 Replies Latest reply: Feb 2, 2012 9:01 AM by ilober
dewps Level 1 Level 1 (0 points)

This is driving me insane! I've had my iPhone (4s) for a little over a week now. It was connecting to my home router perfectly fine for the last week, but the last couple days when I try to connect it pops up with "unable to join network". I've tried resetting my network settings and I reset my router. It will connect to other wifi networks, just not my house.

I've been looking on different forums for a few hours now and can't find a solution. Pease help this is very frustrating!

Thanks in advance


iPhone 4S, iOS 5.0.1
  • 1. Re: iPhone "unable to join to network"
    dani4576 Level 2 Level 2 (365 points)

    I really hate to say it, but this happened to me with my home's wifi the first day I got my new iPhone 4S. When this happened, before doing anything, I did a hard reset and my problem was fixed. If you only had your phone a week, the backup process should not take too long and you will be connected to wifi in no time.

     

    Thank you for choosing Apple.

  • 2. Re: iPhone "unable to join to network"
    Charlie_Seattle Level 1 Level 1 (0 points)

    I didn't understand what device the hard reset referred to. But I turned the power switch on the wireless router off and then on (also disconnected and reconnected the power cord) and that fixed the problem. I could then enter my password to connect to router. The confusing part was that I would enter my password and then get the message "Unable to connect to the network." I kept thinking there was a problem with the password. The iPhone does need to connect to the router before it can verify the password so it seems like the error message could say that so you would know whether there was a problem with the password, the router, or the network. I wish Apple would think about this some more. Hooking up to a wireless network the first few times you do it is filled with opportunities for things to go wrong. Apple should be able to figure out a way to improve this user expereince.

  • 3. Re: iPhone "unable to join to network"
    ilober Level 1 Level 1 (0 points)

    I got my iPhone 4s yesterday. First time around it connected to my secure home network without issue. When I returned last night after being out I kept getting 'unable to join network' message. I entered the password manually a number of times, then copied/pasted to be sure and nothing worked. Reset network settings didn't work.

     

    This worked for me:

    • Turned phone off completely
    • Disconnected router power cord
    • Turned phone back on (don't try to connect yet)
    • Put power cord back into router and waited about a minute
    • Entered WiFi password and it connected

     

    So far so good ... hope this helps