Skip navigation

Corrupted permissions... again?

3724 Views 18 Replies Latest reply: Jul 10, 2013 7:52 AM by webdevii RSS
  • Mark23 Level 3 Level 3 (975 points)
    Currently Being Moderated
    Apr 10, 2012 12:38 AM (in response to Chazz Layne)

    The only thing really failing on me out of the blue, untill I spend a lot of time working on the issue, is Profile Manager. Previous solutions don't seem to last. Grrr...

     

    Let's hope that Tim Cook has something good and solid to offer, as Steve Jobs must have been hindered by his deteriorating health when Lion was developed and released...

     

    Anyway, the Mac is the best hardware to run Windows on, so you don't have to bring in your PC, you could just use Bootcamp for that purpose.

  • Mark23 Level 3 Level 3 (975 points)
    Currently Being Moderated
    Apr 20, 2012 12:59 PM (in response to Chazz Layne)

    I had multiple IP's set on my server, which randomly seemed to switch. It seems like there is an incompatibility still between Server Admin and server.app. Since Apple is pressing developers to test server admin and server.app I am confident those problems will resolve eventually, but for now I have deleted all-but-1 IPv4 and 1 IPv6 address (same interface), the networking interface overview for my server within Server Admin was updated and it looks like it works solid now, this was not by design I presume, so this must be another bug plaguing Lion...

     

    After upgrading Postgres to 9.1.3 and upgrading webmail (upgrade: usr/share/webmail) from www.roundcube.net, making a new site webmail.example.com with the files stored in /Library/Server/Web/Data/Sites/CustomSitesDefault/webmail/ I made a symbolic link from that 'directory' to the actual built in webmail facility found in /usr/share/webmail by entering the following in terminal.

    ln -s -i /usr/share/webmail/ /Library/Server/Web/Data/Sites/CustomSitesDefault/webmail/

     

    By doing this it will ask to remove a directory, if you didn't put any important files in there, which I presume you didn't, confirm with the letter y and press enter.

     

    Webmail now works every time the way I want it

  • webdevii Calculating status...
    Currently Being Moderated
    Jul 10, 2013 7:52 AM (in response to Chazz Layne)

    I am having the exact problem with a QNap File Server, my permissions file became corrupted after doing the latest firmware update.  However I can not attribute it to the firmware itself as the system worked fine until after about a week.

     

    My actual problem, when logging in as the admin account I am able to download files from the server via the web interface, although when I log in as a user with read only permissions set on the file share and try to download a file it downloads as a Zero Byte file with no contents.  On the other hand when I try and download a Folder containing files it zips the folder with the file contents and downloads correctly.  as was in the above post I have spent countless hours on the phone with tech support first, second and third tier technicians and all of them said the same thing, wipe and reinitilize the server from scratch.

     

    What the heck is going on here.

    Dev

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.