7 Replies Latest reply: Jan 27, 2014 5:19 AM by mag444
Franeye Level 1 Level 1 (0 points)

When I want to see the files through Finder, I click a folder to open it and the list remains blank, no matter how much time I wait. I know there are files, and I can acess them through apps (like Word or Preview, or whatever), but the very same files just don't show up in Finder when I open the folder they are in.

 

I have a MacBook Air 13-inch, late 2010 with a Intel Core 2 Duo 2,13 Ghz and 4GB Ram running OS X Lion 10.7.2 (11C74)

 

Does anyone have a clue how to fix that?

 

Thanks


MacBook Air, Also on Network are a G5 and 3 PC's
  • macjack Level 9 Level 9 (50,625 points)

    Where is this folder located, in your Documents folder in your User, or elsewhere on the drive?

  • Franeye Level 1 Level 1 (0 points)

    Usually in the documents folder, but it happens with my dropbox folder or with mounted sparseimages folders.

  • macjack Level 9 Level 9 (50,625 points)

    Let's try rebuilding Finder preferences...

     

    Go to Finder "Go" menu hold the option key and choose Library. Then go to Preferences trash these files:

    com.apple.finder.plist

    com.apple.sidebarlists.plist

     

    Then, restart, or log out and in again.

    (You will have to reset a few finder prefs the way you like them.)

  • purple51melissa Level 1 Level 1 (0 points)

    I am having the same issue.  I am only able to access finder through the Dock, I used to be able to access finder when I clicked on the desktop.  When I click on Finder the "Go" menu and hold the option key and choose Library - nothing happens. 

  • Franeye Level 1 Level 1 (0 points)

    Seems to have worked all right. Thank you !

  • mdodel Level 1 Level 1 (0 points)

    None of this helped my problem so perhaps there are mulitple issues with Finder and the Open File container in Mavericks.  For me the problem was that after some unknown period of time after starting Mavericks the Finder would become unresponsive to opening new folders with a spinning gray wheel.  In addition some apps were unable to populate the File Open container file list.  The Console showed that com.apple.IconServicesAgent had extremely high CPU usage and a very high CPU Time.  The Console showed hundreds or more errors for com.apple.IconServicesAgent.  Using the Activity Monitor to "Quit" -> "Force Quit" com.apple.IconServicesAgent resolves the problem temporarily.  I tried the network fix but the problem came back.  I deleted the Finder plist and the problem came back. 

     

    What has seemed to work was deleting the "com.apple.finder" cache folder.  I found this suggestion here: https://discussions.apple.com/thread/5472367?start=45&tstart=0

     

     

     

    Ok, I think I solved this problem.

     

    Here's my solution:

     

    1 - Kill "com.apple.IconServicesAgent" using Activity Monitor

    2 - In Finder go to "Go to folder" under "Go" menu and paste: ~/Library/Caches/

    3 - Delete "com.apple.finder" (save a copy as backup if you want)

    4 - Kill Finder

     

    That's it. Let me know if this works for you, it did for me.

     

     

    If you don't have the same problem as I described then this may not help you but it has solved the problem here.

     

    Mark

     

  • mag444 Level 1 Level 1 (0 points)

    Worked great for me, man.... Thanks!